ArchLinux: 202006-12: chromium: arbitrary code execution

    Date 30 Jun 2020
    107
    Posted By LinuxSecurity Advisories
    The package chromium before version 83.0.4103.116-1 is vulnerable to arbitrary code execution.
    Arch Linux Security Advisory ASA-202006-12
    ==========================================
    
    Severity: High
    Date    : 2020-06-28
    CVE-ID  : CVE-2020-6509
    Package : chromium
    Type    : arbitrary code execution
    Remote  : Yes
    Link    : https://security.archlinux.org/AVG-1192
    
    Summary
    =======
    
    The package chromium before version 83.0.4103.116-1 is vulnerable to
    arbitrary code execution.
    
    Resolution
    ==========
    
    Upgrade to 83.0.4103.116-1.
    
    # pacman -Syu "chromium>=83.0.4103.116-1"
    
    The problem has been fixed upstream in version 83.0.4103.116.
    
    Workaround
    ==========
    
    None.
    
    Description
    ===========
    
    A use-after-free vulnerability has been found in the extensions
    component of chromium before 83.0.4103.116.
    
    Impact
    ======
    
    A remote attacker can execute arbitrary code on the affected host.
    
    References
    ==========
    
    https://chromereleases.googleblog.com/2020/06/stable-channel-update-for-desktop_22.html
    https://crbug.com/1092308
    https://security.archlinux.org/CVE-2020-6509
    

    LinuxSecurity Poll

    How do you feel about the elimination of the terms 'blacklist' and 'slave' from the Linux kernel?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/32-how-do-you-feel-about-the-elimination-of-the-terms-blacklist-and-slave-from-the-linux-kernel?task=poll.vote&format=json
    32
    radio
    [{"id":"112","title":"I strongly support this change - racially charged language should not be used in the code and documentation of the kernel and other open-source projects.","votes":"7","type":"x","order":"1","pct":18.42,"resources":[]},{"id":"113","title":"I'm indifferent - this small change will not affect broader issues of racial insensitivity and white privilege.","votes":"4","type":"x","order":"2","pct":10.53,"resources":[]},{"id":"114","title":"I'm opposed to this change - there is no need to change language that has been used for years. It doesn't make sense for people to take offense to terminology used in community projects.","votes":"27","type":"x","order":"3","pct":71.05,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350
    bottom 200

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.