Gentoo: GLSA-202003-65: FFmpeg: Multiple vulnerabilities

    Date 30 Mar 2020
    336
    Posted By LinuxSecurity Advisories
    Multiple vulnerabilities have been found in FFmpeg, the worst of which allows remote attackers to execute arbitrary code.
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    Gentoo Linux Security Advisory                           GLSA 202003-65
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                               https://security.gentoo.org/
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
     Severity: Normal
        Title: FFmpeg: Multiple vulnerabilities
         Date: March 30, 2020
         Bugs: #660924, #692418, #711144
           ID: 202003-65
    
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
    Synopsis
    ========
    
    Multiple vulnerabilities have been found in FFmpeg, the worst of which
    allows remote attackers to execute arbitrary code.
    
    Background
    ==========
    
    FFmpeg is a complete, cross-platform solution to record, convert and
    stream audio and video.
    
    Affected packages
    =================
    
        -------------------------------------------------------------------
         Package              /     Vulnerable     /            Unaffected
        -------------------------------------------------------------------
      1  media-video/ffmpeg             >= 4                     >= 4.2.0
    
    Description
    ===========
    
    Multiple vulnerabilities have been discovered in FFmpeg. Please review
    the CVE identifiers referenced below for details.
    
    Impact
    ======
    
    A remote attacker could entice a user or automated system using FFmpeg
    to process a specially crafted file, resulting in the execution of
    arbitrary code or a Denial of Service.
    
    Workaround
    ==========
    
    There is no known workaround at this time.
    
    Resolution
    ==========
    
    All FFmpeg 4.x users should upgrade to the latest version:
    
      # emerge --sync
      # emerge --ask --oneshot --verbose ">=media-video/ffmpeg-4.2.0"
    
    References
    ==========
    
    [  1 ] CVE-2018-10001
           https://nvd.nist.gov/vuln/detail/CVE-2018-10001
    [  2 ] CVE-2018-6912
           https://nvd.nist.gov/vuln/detail/CVE-2018-6912
    [  3 ] CVE-2018-7557
           https://nvd.nist.gov/vuln/detail/CVE-2018-7557
    [  4 ] CVE-2018-7751
           https://nvd.nist.gov/vuln/detail/CVE-2018-7751
    [  5 ] CVE-2018-9841
           https://nvd.nist.gov/vuln/detail/CVE-2018-9841
    [  6 ] CVE-2019-12730
           https://nvd.nist.gov/vuln/detail/CVE-2019-12730
    [  7 ] CVE-2019-13312
           https://nvd.nist.gov/vuln/detail/CVE-2019-13312
    [  8 ] CVE-2019-13390
           https://nvd.nist.gov/vuln/detail/CVE-2019-13390
    [  9 ] CVE-2019-17539
           https://nvd.nist.gov/vuln/detail/CVE-2019-17539
    [ 10 ] CVE-2019-17542
           https://nvd.nist.gov/vuln/detail/CVE-2019-17542
    
    Availability
    ============
    
    This GLSA and any updates to it are available for viewing at
    the Gentoo Security Website:
    
     https://security.gentoo.org/glsa/202003-65
    
    Concerns?
    =========
    
    Security is a primary focus of Gentoo Linux and ensuring the
    confidentiality and security of our users' machines is of utmost
    importance to us. Any security concerns should be addressed to
    This email address is being protected from spambots. You need JavaScript enabled to view it. or alternatively, you may file a bug at
    https://bugs.gentoo.org.
    
    License
    =======
    
    Copyright 2020 Gentoo Foundation, Inc; referenced text
    belongs to its owner(s).
    
    The contents of this document are licensed under the
    Creative Commons - Attribution / Share Alike license.
    
    https://creativecommons.org/licenses/by-sa/2.5
    
    
    

    LinuxSecurity Poll

    Do you agree with Linus Torvalds' decision to reject the controversial patch mitigating the Snoop attack on Intel CPUs?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/28-do-you-agree-with-linus-torvalds-decision-to-reject-the-controversial-patch-mitigating-the-snoop-attack-on-intel-cpus?task=poll.vote&format=json
    28
    radio
    [{"id":"100","title":"Yes - this was undoubtedly the right decision.","votes":"1","type":"x","order":"1","pct":33.33,"resources":[]},{"id":"101","title":"Not sure...","votes":"2","type":"x","order":"2","pct":66.67,"resources":[]},{"id":"102","title":"No - he made a big mistake here.","votes":"0","type":"x","order":"3","pct":0,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350
    bottom 200

    Advisories

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.