Mageia 2019-0116: firefox security update

    Date21 Mar 2019
    CategoryMageia
    285
    Posted ByLinuxSecurity Advisories
    Proxy Auto-Configuration file can define localhost access to be proxied (CVE-2018-18506). Memory safety bugs fixed in Firefox 66 and Firefox ESR 60.6 (CVE-2019-9788).
    MGASA-2019-0116 - Updated firefox packages fix security vulnerability
    
    Publication date: 21 Mar 2019
    URL: https://advisories.mageia.org/MGASA-2019-0116.html
    Type: security
    Affected Mageia releases: 6
    CVE: CVE-2018-18506,
         CVE-2019-9788,
         CVE-2019-9790,
         CVE-2019-9791,
         CVE-2019-9792,
         CVE-2019-9793,
         CVE-2019-9795,
         CVE-2019-9796
    
    Proxy Auto-Configuration file can define localhost access to be proxied
    (CVE-2018-18506).
    
    Memory safety bugs fixed in Firefox 66 and Firefox ESR 60.6
    (CVE-2019-9788).
    
    Use-after-free when removing in-use DOM elements (CVE-2019-9790).
    
    Type inference is incorrect for constructors entered through on-stack
    replacement with IonMonkey (CVE-2019-9791).
    
    IonMonkey leaks JS_OPTIMIZED_OUT magic value to script (CVE-2019-9792).
    
    Improper bounds checks when Spectre mitigations are disabled
    (CVE-2019-9793).
    
    Type-confusion in IonMonkey JIT compiler (CVE-2019-9795).
    
    Use-after-free with SMIL animation controller (CVE-2019-9796).
    
    References:
    - https://bugs.mageia.org/show_bug.cgi?id=24534
    - https://www.mozilla.org/en-US/security/advisories/mfsa2019-08/
    - https://www.mozilla.org/en-US/security/known-vulnerabilities/firefox-esr/
    - https://access.redhat.com/errata/RHSA-2019:0622
    - https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-18506
    - https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-9788
    - https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-9790
    - https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-9791
    - https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-9792
    - https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-9793
    - https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-9795
    - https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-9796
    
    SRPMS:
    - 6/core/firefox-60.6.0-2.mga6
    - 6/core/firefox-l10n-60.6.0-1.mga6
    - 6/core/nspr-4.21-1.mga6
    - 6/core/rootcerts-20190306.00-1.mga6
    - 6/core/nss-3.36.7-1.1.mga6
    

    LinuxSecurity Poll

    Has your email account ever been pwned in a data breach?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 2 answer(s).
    /component/communitypolls/?task=poll.vote
    12
    radio
    [{"id":"53","title":"Yes","votes":"4","type":"x","order":"1","pct":80,"resources":[]},{"id":"54","title":"No","votes":"1","type":"x","order":"2","pct":20,"resources":[]}]["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"]["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"]350
    bottom200

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.