Mageia 2019-0316: thunderbird security update

    Date07 Nov 2019
    CategoryMageia
    137
    Posted ByLinuxSecurity Advisories
    Mageia Large
    The updated packages fix security issues: Use-after-free when creating index updates in IndexedDB. (CVE-2019-11757)
    MGASA-2019-0316 - Updated thunderbird packages fix security vulnerabilities
    
    Publication date: 07 Nov 2019
    URL: https://advisories.mageia.org/MGASA-2019-0316.html
    Type: security
    Affected Mageia releases: 7
    CVE: CVE-2019-11757,
         CVE-2019-11758,
         CVE-2019-11759,
         CVE-2019-11760,
         CVE-2019-11761,
         CVE-2019-11762,
         CVE-2019-11763,
         CVE-2019-11764,
         CVE-2019-15903
    
    The updated packages fix security issues:
    
    Use-after-free when creating index updates in IndexedDB.
    (CVE-2019-11757)
    
    Potentially exploitable crash due to 360 Total Security.
    (CVE-2019-11758)
    
    Stack buffer overflow in HKDF output. (CVE-2019-11759)
    
    Stack buffer overflow in WebRTC networking. (CVE-2019-11760)
    
    Unintended access to a privileged JSONView object. (CVE-2019-11761)
    
    document.domain-based origin isolation has same-origin-property
    violation. (CVE-2019-11762)
    
    Incorrect HTML parsing results in XSS bypass technique. (CVE-2019-11763)
    
    Memory safety bugs fixed in Thunderbird 68.2. (CVE-2019-11764)
    
    Heap overflow in expat library in XML_GetCurrentLineNumber.
    (CVE-2019-15903)
    
    Enigmail has been updated to 2.1.3.
    
    References:
    - https://bugs.mageia.org/show_bug.cgi?id=25597
    - https://www.thunderbird.net/en-US/thunderbird/68.2.0/releasenotes/
    - https://www.thunderbird.net/en-US/thunderbird/68.2.1/releasenotes/
    - https://www.mozilla.org/en-US/security/advisories/mfsa2019-35/
    - https://enigmail.net/index.php/en/download/changelog#enig2.1.3
    - https://access.redhat.com/errata/RHSA-2019:3237
    - https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-11757
    - https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-11758
    - https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-11759
    - https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-11760
    - https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-11761
    - https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-11762
    - https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-11763
    - https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-11764
    - https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-15903
    
    SRPMS:
    - 7/core/thunderbird-68.2.1-1.mga7
    - 7/core/thunderbird-l10n-68.2.1-1.mga7
    

    LinuxSecurity Poll

    What do you think of the articles on LinuxSecurity?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/24-what-do-you-think-of-the-quality-of-the-articles-on-linuxsecurity?task=poll.vote&format=json
    24
    radio
    [{"id":"87","title":"Excellent, don't change a thing!","votes":"39","type":"x","order":"1","pct":50.65,"resources":[]},{"id":"88","title":"Should be more technical","votes":"11","type":"x","order":"2","pct":14.29,"resources":[]},{"id":"89","title":"Should include more HOWTOs","votes":"27","type":"x","order":"3","pct":35.06,"resources":[]}]["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"]["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"]350
    bottom200

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.