Mageia 2020-0280: libvncserver security update

    Date 05 Jul 2020
    746
    Posted By LinuxSecurity Advisories
    Updated libvncserver packages fix security vulnerabilities: libvncclient/sockets.c in LibVNCServer had a buffer overflow via a long socket filename (CVE-2019-20839).
    MGASA-2020-0280 - Updated libvncserver packages fix security vulnerability
    
    Publication date: 05 Jul 2020
    URL: https://advisories.mageia.org/MGASA-2020-0280.html
    Type: security
    Affected Mageia releases: 7
    CVE: CVE-2019-20839,
         CVE-2020-14397,
         CVE-2020-14398,
         CVE-2020-14399,
         CVE-2020-14400,
         CVE-2020-14401,
         CVE-2020-14402,
         CVE-2020-14403,
         CVE-2020-14404,
         CVE-2020-14405
    
    Updated libvncserver packages fix security vulnerabilities:
    
    libvncclient/sockets.c in LibVNCServer had a buffer overflow via a long
    socket filename (CVE-2019-20839).
    
    libvncserver/rfbregion.c had a NULL pointer dereference (CVE-2020-14397).
    
    Byte-aligned data was accessed through uint32_t pointers in
    libvncclient/rfbproto.c (CVE-2020-14399).
    
    Byte-aligned data was accessed through uint16_t pointers in
    libvncserver/translate.c (CVE-2020-14400).
    
    libvncserver/scale.c had a pixel_value integer overflow (CVE-2020-14401).
    
    libvncserver/corre.c allowed out-of-bounds access via encodings
    (CVE-2020-14402).
    
    libvncserver/hextile.c allowed out-of-bounds access via encodings
    (CVE-2020-14403).
    
    libvncserver/rre.c allowed out-of-bounds access via encodings
    (CVE-2020-14404).
    
    libvncclient/rfbproto.c does not limit TextChat size (CVE-2020-14405).
    
    The libvncserver package has been updated to version 0.9.13, fixing these
    issues and several others.  See the release announcement for details.
    
    References:
    - https://bugs.mageia.org/show_bug.cgi?id=26881
    - https://github.com/LibVNC/libvncserver/releases/tag/LibVNCServer-0.9.13
    - https://www.debian.org/lts/security/2020/dla-2264
    - https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-20839
    - https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-14397
    - https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-14398
    - https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-14399
    - https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-14400
    - https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-14401
    - https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-14402
    - https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-14403
    - https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-14404
    - https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-14405
    
    SRPMS:
    - 7/core/libvncserver-0.9.13-1.mga7
    

    LinuxSecurity Poll

    Are you planning to use the 1Password password manager now that it is available to Linux users?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/35-are-you-planning-to-use-the-1password-password-manager-now-that-it-is-available-to-linux-users?task=poll.vote&format=json
    35
    radio
    [{"id":"122","title":"Yes","votes":"1","type":"x","order":"1","pct":25,"resources":[]},{"id":"123","title":"No ","votes":"2","type":"x","order":"2","pct":50,"resources":[]},{"id":"124","title":"Not sure at the moment","votes":"1","type":"x","order":"3","pct":25,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350
    bottom 200

    Advisories

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.