openSUSE: 2019:1419-1: important: xen

    Date20 May 2019
    CategoryopenSUSE
    310
    Posted ByLinuxSecurity Advisories
    An update that fixes 5 vulnerabilities is now available.
       openSUSE Security Update: Security update for xen
    ______________________________________________________________________________
    
    Announcement ID:    openSUSE-SU-2019:1419-1
    Rating:             important
    References:         #1027519 #1111331 #1120095 #1130680 
    Cross-References:   CVE-2018-12126 CVE-2018-12127 CVE-2018-12130
                        CVE-2018-20815 CVE-2019-11091
    Affected Products:
                        openSUSE Leap 42.3
    ______________________________________________________________________________
    
       An update that fixes 5 vulnerabilities is now available.
    
    Description:
    
       This update for xen fixes the following issues:
    
       Four new speculative execution information leak issues have been
       identified in Intel CPUs. (bsc#1111331)
    
       - CVE-2018-12126: Microarchitectural Store Buffer Data Sampling (MSBDS)
       - CVE-2018-12127: Microarchitectural Fill Buffer Data Sampling (MFBDS)
       - CVE-2018-12130: Microarchitectural Load Port Data Samling (MLPDS)
       - CVE-2019-11091: Microarchitectural Data Sampling Uncacheable Memory
         (MDSUM)
    
       These updates contain the XEN Hypervisor adjustments, that additionaly
       also use CPU Microcode updates.
    
       The mitigation can be controlled via the "mds" commandline option, see the
       documentation.
    
       For more information on this set of vulnerabilities, check out
       https://www.suse.com/support/kb/doc/?id=7023736
    
       Security issue fixed:
    
       - CVE-2018-20815: Fixed a heap buffer overflow while loading device tree
         blob (bsc#1130680)
    
       Other fixes:
    
       - Added code to change LIBXL_HOTPLUG_TIMEOUT at runtime.
    
         The included README has details about the impact of this change
       (bsc#1120095)
    
       This update was imported from the SUSE:SLE-12-SP3:Update update project.
    
    
    Patch Instructions:
    
       To install this openSUSE Security Update use the SUSE recommended installation methods
       like YaST online_update or "zypper patch".
    
       Alternatively you can run the command listed for your product:
    
       - openSUSE Leap 42.3:
    
          zypper in -t patch openSUSE-2019-1419=1
    
    
    
    Package List:
    
       - openSUSE Leap 42.3 (i586 x86_64):
    
          xen-debugsource-4.9.4_04-40.1
          xen-devel-4.9.4_04-40.1
          xen-libs-4.9.4_04-40.1
          xen-libs-debuginfo-4.9.4_04-40.1
          xen-tools-domU-4.9.4_04-40.1
          xen-tools-domU-debuginfo-4.9.4_04-40.1
    
       - openSUSE Leap 42.3 (x86_64):
    
          xen-4.9.4_04-40.1
          xen-doc-html-4.9.4_04-40.1
          xen-libs-32bit-4.9.4_04-40.1
          xen-libs-debuginfo-32bit-4.9.4_04-40.1
          xen-tools-4.9.4_04-40.1
          xen-tools-debuginfo-4.9.4_04-40.1
    
    
    References:
    
       https://www.suse.com/security/cve/CVE-2018-12126.html
       https://www.suse.com/security/cve/CVE-2018-12127.html
       https://www.suse.com/security/cve/CVE-2018-12130.html
       https://www.suse.com/security/cve/CVE-2018-20815.html
       https://www.suse.com/security/cve/CVE-2019-11091.html
       https://bugzilla.suse.com/1027519
       https://bugzilla.suse.com/1111331
       https://bugzilla.suse.com/1120095
       https://bugzilla.suse.com/1130680
    
    -- 
    

    LinuxSecurity Poll

    Have you used our RSS feeds?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 4 answer(s).
    /component/communitypolls/?task=poll.vote&format=json
    21
    radio
    [{"id":"77","title":"Yes, for articles","votes":"0","type":"x","order":"1","pct":0,"resources":[]},{"id":"78","title":"Yes, for advisories","votes":"1","type":"x","order":"2","pct":33.33,"resources":[]},{"id":"79","title":"Hybrid that contains both","votes":"0","type":"x","order":"3","pct":0,"resources":[]},{"id":"80","title":"No","votes":"2","type":"x","order":"4","pct":66.67,"resources":[]}]["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"]["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"]350
    bottom200

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.