openSUSE: 2019:1618-1: moderate: aubio

    Date24 Jun 2019
    CategoryopenSUSE
    200
    Posted ByLinuxSecurity Advisories
    An update that fixes three vulnerabilities is now available.
       openSUSE Security Update: Security update for aubio
    ______________________________________________________________________________
    
    Announcement ID:    openSUSE-SU-2019:1618-1
    Rating:             moderate
    References:         #1137822 #1137823 #1137828 
    Cross-References:   CVE-2018-19800 CVE-2018-19801 CVE-2018-19802
                       
    Affected Products:
                        openSUSE Leap 42.3
                        openSUSE Leap 15.1
                        openSUSE Leap 15.0
    ______________________________________________________________________________
    
       An update that fixes three vulnerabilities is now available.
    
    Description:
    
       This update for aubio fixes the following issues:
    
       Fixed security issues leading to buffer overflows or segfaults
       (CVE-2018-19800, boo#1137828, CVE-2018-19801, boo#1137822, CVE-2018-19802,
       boo#1137823):
    
    
    Patch Instructions:
    
       To install this openSUSE Security Update use the SUSE recommended installation methods
       like YaST online_update or "zypper patch".
    
       Alternatively you can run the command listed for your product:
    
       - openSUSE Leap 42.3:
    
          zypper in -t patch openSUSE-2019-1618=1
    
       - openSUSE Leap 15.1:
    
          zypper in -t patch openSUSE-2019-1618=1
    
       - openSUSE Leap 15.0:
    
          zypper in -t patch openSUSE-2019-1618=1
    
    
    
    Package List:
    
       - openSUSE Leap 42.3 (i586 x86_64):
    
          aubio-debugsource-0.4.1-9.13.1
          aubio-tools-0.4.1-9.13.1
          aubio-tools-debuginfo-0.4.1-9.13.1
          libaubio-devel-0.4.1-9.13.1
          libaubio4-0.4.1-9.13.1
          libaubio4-debuginfo-0.4.1-9.13.1
    
       - openSUSE Leap 42.3 (x86_64):
    
          libaubio4-32bit-0.4.1-9.13.1
          libaubio4-debuginfo-32bit-0.4.1-9.13.1
    
       - openSUSE Leap 15.1 (i586 x86_64):
    
          aubio-debugsource-0.4.6-lp151.6.3.1
          aubio-tools-0.4.6-lp151.6.3.1
          aubio-tools-debuginfo-0.4.6-lp151.6.3.1
          libaubio-devel-0.4.6-lp151.6.3.1
          libaubio5-0.4.6-lp151.6.3.1
          libaubio5-debuginfo-0.4.6-lp151.6.3.1
    
       - openSUSE Leap 15.1 (x86_64):
    
          libaubio5-32bit-0.4.6-lp151.6.3.1
          libaubio5-32bit-debuginfo-0.4.6-lp151.6.3.1
          python-aubio-debugsource-0.4.6-lp151.6.3.1
          python2-aubio-0.4.6-lp151.6.3.1
          python2-aubio-debuginfo-0.4.6-lp151.6.3.1
          python3-aubio-0.4.6-lp151.6.3.1
          python3-aubio-debuginfo-0.4.6-lp151.6.3.1
    
       - openSUSE Leap 15.0 (i586 x86_64):
    
          aubio-debugsource-0.4.6-lp150.3.10.1
          aubio-tools-0.4.6-lp150.3.10.1
          aubio-tools-debuginfo-0.4.6-lp150.3.10.1
          libaubio-devel-0.4.6-lp150.3.10.1
          libaubio5-0.4.6-lp150.3.10.1
          libaubio5-debuginfo-0.4.6-lp150.3.10.1
    
       - openSUSE Leap 15.0 (x86_64):
    
          libaubio5-32bit-0.4.6-lp150.3.10.1
          libaubio5-32bit-debuginfo-0.4.6-lp150.3.10.1
          python-aubio-debugsource-0.4.6-lp150.3.10.1
          python2-aubio-0.4.6-lp150.3.10.1
          python2-aubio-debuginfo-0.4.6-lp150.3.10.1
          python3-aubio-0.4.6-lp150.3.10.1
          python3-aubio-debuginfo-0.4.6-lp150.3.10.1
    
    
    References:
    
       https://www.suse.com/security/cve/CVE-2018-19800.html
       https://www.suse.com/security/cve/CVE-2018-19801.html
       https://www.suse.com/security/cve/CVE-2018-19802.html
       https://bugzilla.suse.com/1137822
       https://bugzilla.suse.com/1137823
       https://bugzilla.suse.com/1137828
    
    -- 
    

    LinuxSecurity Poll

    Do you read our distribution advisories on a regular basis?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /component/communitypolls/?task=poll.vote&format=json
    23
    radio
    [{"id":"84","title":"Yes, for a single distribution","votes":"0","type":"x","order":"1","pct":0,"resources":[]},{"id":"85","title":"Yes, for multiple distributions","votes":"5","type":"x","order":"2","pct":62.5,"resources":[]},{"id":"86","title":"No","votes":"3","type":"x","order":"3","pct":37.5,"resources":[]}]["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"]["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"]350
    bottom200

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.