openSUSE: 2019:1773-1: moderate: postgresql10

    Date21 Jul 2019
    CategoryopenSUSE
    183
    Posted ByLinuxSecurity Advisories
    An update that fixes two vulnerabilities is now available.
       openSUSE Security Update: Security update for postgresql10
    ______________________________________________________________________________
    
    Announcement ID:    openSUSE-SU-2019:1773-1
    Rating:             moderate
    References:         #1134689 #1138034 
    Cross-References:   CVE-2019-10130 CVE-2019-10164
    Affected Products:
                        openSUSE Leap 15.1
                        openSUSE Leap 15.0
    ______________________________________________________________________________
    
       An update that fixes two vulnerabilities is now available.
    
    Description:
    
       This update for postgresql10 fixes the following issues:
    
       Security issue fixed:
    
       - CVE-2019-10164: Fixed buffer-overflow vulnerabilities in SCRAM verifier
         parsing (bsc#1138034).
       - CVE-2019-10130: Prevent row-level security policies from being bypassed
         via selectivity estimators (bsc#1134689).
    
       Bug fixes:
    
       - For a complete list of fixes check the release notes.
    
          * https://www.postgresql.org/docs/10/release-10-9.html
          * https://www.postgresql.org/docs/10/release-10-8.html
          * https://www.postgresql.org/docs/10/release-10-7.html
    
       This update was imported from the SUSE:SLE-15:Update update project.
    
    
    Patch Instructions:
    
       To install this openSUSE Security Update use the SUSE recommended installation methods
       like YaST online_update or "zypper patch".
    
       Alternatively you can run the command listed for your product:
    
       - openSUSE Leap 15.1:
    
          zypper in -t patch openSUSE-2019-1773=1
    
       - openSUSE Leap 15.0:
    
          zypper in -t patch openSUSE-2019-1773=1
    
    
    
    Package List:
    
       - openSUSE Leap 15.1 (i586 x86_64):
    
          libecpg6-10.9-lp151.2.3.1
          libecpg6-debuginfo-10.9-lp151.2.3.1
          libpq5-10.9-lp151.2.3.1
          libpq5-debuginfo-10.9-lp151.2.3.1
          postgresql10-10.9-lp151.2.3.1
          postgresql10-contrib-10.9-lp151.2.3.1
          postgresql10-contrib-debuginfo-10.9-lp151.2.3.1
          postgresql10-debuginfo-10.9-lp151.2.3.1
          postgresql10-debugsource-10.9-lp151.2.3.1
          postgresql10-devel-10.9-lp151.2.3.1
          postgresql10-devel-debuginfo-10.9-lp151.2.3.1
          postgresql10-plperl-10.9-lp151.2.3.1
          postgresql10-plperl-debuginfo-10.9-lp151.2.3.1
          postgresql10-plpython-10.9-lp151.2.3.1
          postgresql10-plpython-debuginfo-10.9-lp151.2.3.1
          postgresql10-pltcl-10.9-lp151.2.3.1
          postgresql10-pltcl-debuginfo-10.9-lp151.2.3.1
          postgresql10-server-10.9-lp151.2.3.1
          postgresql10-server-debuginfo-10.9-lp151.2.3.1
          postgresql10-test-10.9-lp151.2.3.1
    
       - openSUSE Leap 15.1 (noarch):
    
          postgresql10-docs-10.9-lp151.2.3.1
    
       - openSUSE Leap 15.1 (x86_64):
    
          libecpg6-32bit-10.9-lp151.2.3.1
          libecpg6-32bit-debuginfo-10.9-lp151.2.3.1
          libpq5-32bit-10.9-lp151.2.3.1
          libpq5-32bit-debuginfo-10.9-lp151.2.3.1
    
       - openSUSE Leap 15.0 (i586 x86_64):
    
          libecpg6-10.9-lp150.3.10.1
          libecpg6-debuginfo-10.9-lp150.3.10.1
          libpq5-10.9-lp150.3.10.1
          libpq5-debuginfo-10.9-lp150.3.10.1
          postgresql10-10.9-lp150.3.10.1
          postgresql10-contrib-10.9-lp150.3.10.1
          postgresql10-contrib-debuginfo-10.9-lp150.3.10.1
          postgresql10-debuginfo-10.9-lp150.3.10.1
          postgresql10-debugsource-10.9-lp150.3.10.1
          postgresql10-devel-10.9-lp150.3.10.1
          postgresql10-devel-debuginfo-10.9-lp150.3.10.1
          postgresql10-plperl-10.9-lp150.3.10.1
          postgresql10-plperl-debuginfo-10.9-lp150.3.10.1
          postgresql10-plpython-10.9-lp150.3.10.1
          postgresql10-plpython-debuginfo-10.9-lp150.3.10.1
          postgresql10-pltcl-10.9-lp150.3.10.1
          postgresql10-pltcl-debuginfo-10.9-lp150.3.10.1
          postgresql10-server-10.9-lp150.3.10.1
          postgresql10-server-debuginfo-10.9-lp150.3.10.1
          postgresql10-test-10.9-lp150.3.10.1
    
       - openSUSE Leap 15.0 (noarch):
    
          postgresql10-docs-10.9-lp150.3.10.1
    
       - openSUSE Leap 15.0 (x86_64):
    
          libecpg6-32bit-10.9-lp150.3.10.1
          libecpg6-32bit-debuginfo-10.9-lp150.3.10.1
          libpq5-32bit-10.9-lp150.3.10.1
          libpq5-32bit-debuginfo-10.9-lp150.3.10.1
    
    
    References:
    
       https://www.suse.com/security/cve/CVE-2019-10130.html
       https://www.suse.com/security/cve/CVE-2019-10164.html
       https://bugzilla.suse.com/1134689
       https://bugzilla.suse.com/1138034
    
    -- 
    

    LinuxSecurity Poll

    What do you think of the articles on LinuxSecurity?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/24-what-do-you-think-of-the-quality-of-the-articles-on-linuxsecurity?task=poll.vote&format=json
    24
    radio
    [{"id":"87","title":"Excellent, don't change a thing!","votes":"5","type":"x","order":"1","pct":62.5,"resources":[]},{"id":"88","title":"Should be more technical","votes":"2","type":"x","order":"2","pct":25,"resources":[]},{"id":"89","title":"Should include more HOWTOs","votes":"1","type":"x","order":"3","pct":12.5,"resources":[]}]["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"]["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"]350
    bottom200

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.