openSUSE: 2019:2458-1: important: samba

    Date09 Nov 2019
    CategoryopenSUSE
    120
    Posted ByLinuxSecurity Advisories
    Opensuse Large
    An update that solves three vulnerabilities and has four fixes is now available.
       openSUSE Security Update: Security update for samba
    ______________________________________________________________________________
    
    Announcement ID:    openSUSE-SU-2019:2458-1
    Rating:             important
    References:         #1125601 #1127153 #1130245 #1134452 #1144902 
                        #1154289 #1154598 
    Cross-References:   CVE-2019-10218 CVE-2019-14833 CVE-2019-14847
                       
    Affected Products:
                        openSUSE Leap 15.0
    ______________________________________________________________________________
    
       An update that solves three vulnerabilities and has four
       fixes is now available.
    
    Description:
    
       This update for samba fixes the following issues:
    
       Security issues fixed:
    
       - CVE-2019-14847: User with "get changes" permission can crash AD DC LDAP
         server via dirsync (bsc#1154598).
       - CVE-2019-10218: Client code can return filenames containing path
         separators (bsc#1144902).
       - CVE-2019-14833: Fixed Accent with "check script password" where the
         Samba AD DC check password script does not receive the full password
         (bsc#1154289).
    
       Other issues fixed:
    
       - Fix vfs_ceph realpath (bsc#1134452).
       - MacOS credit accounting breaks with async SESSION SETUP (bsc#1125601).
       - Mac OS X SMB2 implmenetation sees Input/output error or Resource
         temporarily unavailable and drops connection
       - Explicitly enable libcephfs POSIX ACL support (bsc#1130245).
       - Fix vfs_ceph ftruncate and fallocate handling (bsc#1127153). This update
         was imported from the SUSE:SLE-15:Update update project.
    
    
    Patch Instructions:
    
       To install this openSUSE Security Update use the SUSE recommended installation methods
       like YaST online_update or "zypper patch".
    
       Alternatively you can run the command listed for your product:
    
       - openSUSE Leap 15.0:
    
          zypper in -t patch openSUSE-2019-2458=1
    
    
    
    Package List:
    
       - openSUSE Leap 15.0 (i586 x86_64):
    
          ctdb-4.7.11+git.186.d75219614c3-lp150.3.18.2
          ctdb-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          ctdb-pcp-pmda-4.7.11+git.186.d75219614c3-lp150.3.18.2
          ctdb-pcp-pmda-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          ctdb-tests-4.7.11+git.186.d75219614c3-lp150.3.18.2
          ctdb-tests-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libdcerpc-binding0-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libdcerpc-binding0-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libdcerpc-devel-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libdcerpc-samr-devel-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libdcerpc-samr0-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libdcerpc-samr0-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libdcerpc0-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libdcerpc0-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libndr-devel-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libndr-krb5pac-devel-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libndr-krb5pac0-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libndr-krb5pac0-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libndr-nbt-devel-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libndr-nbt0-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libndr-nbt0-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libndr-standard-devel-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libndr-standard0-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libndr-standard0-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libndr0-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libndr0-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libnetapi-devel-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libnetapi0-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libnetapi0-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsamba-credentials-devel-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsamba-credentials0-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsamba-credentials0-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsamba-errors-devel-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsamba-errors0-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsamba-errors0-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsamba-hostconfig-devel-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsamba-hostconfig0-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsamba-hostconfig0-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsamba-passdb-devel-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsamba-passdb0-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsamba-passdb0-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsamba-policy-devel-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsamba-policy0-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsamba-policy0-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsamba-util-devel-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsamba-util0-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsamba-util0-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsamdb-devel-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsamdb0-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsamdb0-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsmbclient-devel-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsmbclient0-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsmbclient0-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsmbconf-devel-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsmbconf0-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsmbconf0-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsmbldap-devel-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsmbldap2-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsmbldap2-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libtevent-util-devel-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libtevent-util0-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libtevent-util0-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libwbclient-devel-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libwbclient0-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libwbclient0-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          samba-4.7.11+git.186.d75219614c3-lp150.3.18.2
          samba-client-4.7.11+git.186.d75219614c3-lp150.3.18.2
          samba-client-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          samba-core-devel-4.7.11+git.186.d75219614c3-lp150.3.18.2
          samba-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          samba-debugsource-4.7.11+git.186.d75219614c3-lp150.3.18.2
          samba-dsdb-modules-4.7.11+git.186.d75219614c3-lp150.3.18.2
          samba-dsdb-modules-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          samba-kdc-4.7.11+git.186.d75219614c3-lp150.3.18.2
          samba-kdc-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          samba-libs-4.7.11+git.186.d75219614c3-lp150.3.18.2
          samba-libs-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          samba-pidl-4.7.11+git.186.d75219614c3-lp150.3.18.2
          samba-python-4.7.11+git.186.d75219614c3-lp150.3.18.2
          samba-python-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          samba-test-4.7.11+git.186.d75219614c3-lp150.3.18.2
          samba-test-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          samba-winbind-4.7.11+git.186.d75219614c3-lp150.3.18.2
          samba-winbind-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
    
       - openSUSE Leap 15.0 (x86_64):
    
          libdcerpc-binding0-32bit-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libdcerpc-binding0-32bit-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libdcerpc-samr0-32bit-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libdcerpc-samr0-32bit-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libdcerpc0-32bit-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libdcerpc0-32bit-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libndr-krb5pac0-32bit-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libndr-krb5pac0-32bit-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libndr-nbt0-32bit-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libndr-nbt0-32bit-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libndr-standard0-32bit-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libndr-standard0-32bit-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libndr0-32bit-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libndr0-32bit-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libnetapi0-32bit-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libnetapi0-32bit-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsamba-credentials0-32bit-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsamba-credentials0-32bit-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsamba-errors0-32bit-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsamba-errors0-32bit-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsamba-hostconfig0-32bit-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsamba-hostconfig0-32bit-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsamba-passdb0-32bit-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsamba-passdb0-32bit-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsamba-policy0-32bit-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsamba-policy0-32bit-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsamba-util0-32bit-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsamba-util0-32bit-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsamdb0-32bit-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsamdb0-32bit-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsmbclient0-32bit-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsmbclient0-32bit-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsmbconf0-32bit-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsmbconf0-32bit-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsmbldap2-32bit-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libsmbldap2-32bit-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libtevent-util0-32bit-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libtevent-util0-32bit-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libwbclient0-32bit-4.7.11+git.186.d75219614c3-lp150.3.18.2
          libwbclient0-32bit-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          samba-ceph-4.7.11+git.186.d75219614c3-lp150.3.18.2
          samba-ceph-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          samba-client-32bit-4.7.11+git.186.d75219614c3-lp150.3.18.2
          samba-client-32bit-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          samba-kdc-32bit-4.7.11+git.186.d75219614c3-lp150.3.18.2
          samba-kdc-32bit-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          samba-libs-32bit-4.7.11+git.186.d75219614c3-lp150.3.18.2
          samba-libs-32bit-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
          samba-winbind-32bit-4.7.11+git.186.d75219614c3-lp150.3.18.2
          samba-winbind-32bit-debuginfo-4.7.11+git.186.d75219614c3-lp150.3.18.2
    
       - openSUSE Leap 15.0 (noarch):
    
          samba-doc-4.7.11+git.186.d75219614c3-lp150.3.18.2
    
    
    References:
    
       https://www.suse.com/security/cve/CVE-2019-10218.html
       https://www.suse.com/security/cve/CVE-2019-14833.html
       https://www.suse.com/security/cve/CVE-2019-14847.html
       https://bugzilla.suse.com/1125601
       https://bugzilla.suse.com/1127153
       https://bugzilla.suse.com/1130245
       https://bugzilla.suse.com/1134452
       https://bugzilla.suse.com/1144902
       https://bugzilla.suse.com/1154289
       https://bugzilla.suse.com/1154598
    
    -- 
    

    LinuxSecurity Poll

    What do you think of the articles on LinuxSecurity?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/24-what-do-you-think-of-the-quality-of-the-articles-on-linuxsecurity?task=poll.vote&format=json
    24
    radio
    [{"id":"87","title":"Excellent, don't change a thing!","votes":"39","type":"x","order":"1","pct":50.65,"resources":[]},{"id":"88","title":"Should be more technical","votes":"11","type":"x","order":"2","pct":14.29,"resources":[]},{"id":"89","title":"Should include more HOWTOs","votes":"27","type":"x","order":"3","pct":35.06,"resources":[]}]["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"]["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"]350
    bottom200

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.