openSUSE: 2019:2599-1: moderate: phpMyAdmin

    Date01 Dec 2019
    CategoryopenSUSE
    85
    Posted ByLinuxSecurity Advisories
    An update that fixes one vulnerability is now available.
       openSUSE Security Update: Security update for phpMyAdmin
    ______________________________________________________________________________
    
    Announcement ID:    openSUSE-SU-2019:2599-1
    Rating:             moderate
    References:         #1157614 
    Cross-References:   CVE-2019-18622
    Affected Products:
                        openSUSE Leap 15.1
                        openSUSE Leap 15.0
                        openSUSE Backports SLE-15-SP1
                        openSUSE Backports SLE-15
    ______________________________________________________________________________
    
       An update that fixes one vulnerability is now available.
    
    Description:
    
       This update for phpMyAdmin fixes the following issues:
    
       phpMyAdmin was updated to 4.9.2:
    
       * CVE-2019-18622: SQL injection in Designer feature (boo#1157614)
       * Fixes for "Failed to set session cookie" error
       * Advisor with MySQL 8.0.3 and newer
       * Fix PHP deprecation errors
       * Fix a situation where exporting users after a delete query could remove
         users
       * Fix incorrect "You do not have privileges to manipulate with the users!"
         warning
       * Fix copying a database's privileges and several other problems moving
         columns with MariaDB
       * Fix for phpMyAdmin not selecting all the values when using shift-click
         to select during Export
    
    
    Patch Instructions:
    
       To install this openSUSE Security Update use the SUSE recommended installation methods
       like YaST online_update or "zypper patch".
    
       Alternatively you can run the command listed for your product:
    
       - openSUSE Leap 15.1:
    
          zypper in -t patch openSUSE-2019-2599=1
    
       - openSUSE Leap 15.0:
    
          zypper in -t patch openSUSE-2019-2599=1
    
       - openSUSE Backports SLE-15-SP1:
    
          zypper in -t patch openSUSE-2019-2599=1
    
       - openSUSE Backports SLE-15:
    
          zypper in -t patch openSUSE-2019-2599=1
    
    
    
    Package List:
    
       - openSUSE Leap 15.1 (noarch):
    
          phpMyAdmin-4.9.2-lp151.2.9.1
    
       - openSUSE Leap 15.0 (noarch):
    
          phpMyAdmin-4.9.2-lp150.37.1
    
       - openSUSE Backports SLE-15-SP1 (noarch):
    
          phpMyAdmin-4.9.2-bp151.3.9.1
    
       - openSUSE Backports SLE-15 (noarch):
    
          phpMyAdmin-4.9.2-bp150.37.1
    
    
    References:
    
       https://www.suse.com/security/cve/CVE-2019-18622.html
       https://bugzilla.suse.com/1157614
    
    -- 
    

    LinuxSecurity Poll

    What do you think of the articles on LinuxSecurity?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/24-what-do-you-think-of-the-quality-of-the-articles-on-linuxsecurity?task=poll.vote&format=json
    24
    radio
    [{"id":"87","title":"Excellent, don't change a thing!","votes":"65","type":"x","order":"1","pct":57.52,"resources":[]},{"id":"88","title":"Should be more technical","votes":"15","type":"x","order":"2","pct":13.27,"resources":[]},{"id":"89","title":"Should include more HOWTOs","votes":"33","type":"x","order":"3","pct":29.2,"resources":[]}]["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"]["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"]350
    bottom200

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.