openSUSE: 2019:2608-1: moderate: freerdp

    Date01 Dec 2019
    CategoryopenSUSE
    49
    Posted ByLinuxSecurity Advisories
    An update that fixes two vulnerabilities is now available.
       openSUSE Security Update: Security update for freerdp
    ______________________________________________________________________________
    
    Announcement ID:    openSUSE-SU-2019:2608-1
    Rating:             moderate
    References:         #1153163 #1153164 
    Cross-References:   CVE-2019-17177 CVE-2019-17178
    Affected Products:
                        openSUSE Leap 15.1
    ______________________________________________________________________________
    
       An update that fixes two vulnerabilities is now available.
    
    Description:
    
       This update for freerdp fixes the following issues:
    
       - CVE-2019-17177: Fixed multiple memory leaks in libfreerdp/codec/region.c
         (bsc#1153163).
       - CVE-2019-17178: Fixed a memory leak in HuffmanTree_makeFromFrequencies
         (bsc#1153164).
    
       This update was imported from the SUSE:SLE-15-SP1:Update update project.
    
    
    Patch Instructions:
    
       To install this openSUSE Security Update use the SUSE recommended installation methods
       like YaST online_update or "zypper patch".
    
       Alternatively you can run the command listed for your product:
    
       - openSUSE Leap 15.1:
    
          zypper in -t patch openSUSE-2019-2608=1
    
    
    
    Package List:
    
       - openSUSE Leap 15.1 (x86_64):
    
          freerdp-2.0.0~rc4-lp151.5.3.1
          freerdp-debuginfo-2.0.0~rc4-lp151.5.3.1
          freerdp-debugsource-2.0.0~rc4-lp151.5.3.1
          freerdp-devel-2.0.0~rc4-lp151.5.3.1
          freerdp-server-2.0.0~rc4-lp151.5.3.1
          freerdp-server-debuginfo-2.0.0~rc4-lp151.5.3.1
          freerdp-wayland-2.0.0~rc4-lp151.5.3.1
          freerdp-wayland-debuginfo-2.0.0~rc4-lp151.5.3.1
          libfreerdp2-2.0.0~rc4-lp151.5.3.1
          libfreerdp2-debuginfo-2.0.0~rc4-lp151.5.3.1
          libuwac0-0-2.0.0~rc4-lp151.5.3.1
          libuwac0-0-debuginfo-2.0.0~rc4-lp151.5.3.1
          libwinpr2-2.0.0~rc4-lp151.5.3.1
          libwinpr2-debuginfo-2.0.0~rc4-lp151.5.3.1
          uwac0-0-devel-2.0.0~rc4-lp151.5.3.1
          winpr2-devel-2.0.0~rc4-lp151.5.3.1
    
    
    References:
    
       https://www.suse.com/security/cve/CVE-2019-17177.html
       https://www.suse.com/security/cve/CVE-2019-17178.html
       https://bugzilla.suse.com/1153163
       https://bugzilla.suse.com/1153164
    
    -- 
    

    LinuxSecurity Poll

    What do you think of the articles on LinuxSecurity?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/24-what-do-you-think-of-the-quality-of-the-articles-on-linuxsecurity?task=poll.vote&format=json
    24
    radio
    [{"id":"87","title":"Excellent, don't change a thing!","votes":"65","type":"x","order":"1","pct":57.52,"resources":[]},{"id":"88","title":"Should be more technical","votes":"15","type":"x","order":"2","pct":13.27,"resources":[]},{"id":"89","title":"Should include more HOWTOs","votes":"33","type":"x","order":"3","pct":29.2,"resources":[]}]["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"]["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"]350
    bottom200

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.