openSUSE: 2020:0080-1: moderate: php7

    Date20 Jan 2020
    104
    Posted ByLinuxSecurity Advisories
    An update that fixes four vulnerabilities is now available.
       openSUSE Security Update: Security update for php7
    ______________________________________________________________________________
    
    Announcement ID:    openSUSE-SU-2020:0080-1
    Rating:             moderate
    References:         #1159922 #1159923 #1159924 #1159927 
    Cross-References:   CVE-2019-11045 CVE-2019-11046 CVE-2019-11047
                        CVE-2019-11050
    Affected Products:
                        openSUSE Leap 15.1
    ______________________________________________________________________________
    
       An update that fixes four vulnerabilities is now available.
    
    Description:
    
       This update for php7 fixes the following issues:
    
       - CVE-2019-11045: Fixed an issue with improper input validation in the
         filename handling of the DirectoryIterator class (bsc#1159923).
       - CVE-2019-11046: Fixed an information leak in bc_shift_addsub()
         (bsc#1159924).
       - CVE-2019-11047, CVE-2019-11050: Fixed multiple information leaks in
         exif_read_data() (bsc#1159922, bsc#1159927).
    
       This update was imported from the SUSE:SLE-15:Update update project.
    
    
    Patch Instructions:
    
       To install this openSUSE Security Update use the SUSE recommended installation methods
       like YaST online_update or "zypper patch".
    
       Alternatively you can run the command listed for your product:
    
       - openSUSE Leap 15.1:
    
          zypper in -t patch openSUSE-2020-80=1
    
    
    
    Package List:
    
       - openSUSE Leap 15.1 (i586 x86_64):
    
          apache2-mod_php7-7.2.5-lp151.6.19.2
          apache2-mod_php7-debuginfo-7.2.5-lp151.6.19.2
          php7-7.2.5-lp151.6.19.2
          php7-bcmath-7.2.5-lp151.6.19.2
          php7-bcmath-debuginfo-7.2.5-lp151.6.19.2
          php7-bz2-7.2.5-lp151.6.19.2
          php7-bz2-debuginfo-7.2.5-lp151.6.19.2
          php7-calendar-7.2.5-lp151.6.19.2
          php7-calendar-debuginfo-7.2.5-lp151.6.19.2
          php7-ctype-7.2.5-lp151.6.19.2
          php7-ctype-debuginfo-7.2.5-lp151.6.19.2
          php7-curl-7.2.5-lp151.6.19.2
          php7-curl-debuginfo-7.2.5-lp151.6.19.2
          php7-dba-7.2.5-lp151.6.19.2
          php7-dba-debuginfo-7.2.5-lp151.6.19.2
          php7-debuginfo-7.2.5-lp151.6.19.2
          php7-debugsource-7.2.5-lp151.6.19.2
          php7-devel-7.2.5-lp151.6.19.2
          php7-dom-7.2.5-lp151.6.19.2
          php7-dom-debuginfo-7.2.5-lp151.6.19.2
          php7-embed-7.2.5-lp151.6.19.2
          php7-embed-debuginfo-7.2.5-lp151.6.19.2
          php7-enchant-7.2.5-lp151.6.19.2
          php7-enchant-debuginfo-7.2.5-lp151.6.19.2
          php7-exif-7.2.5-lp151.6.19.2
          php7-exif-debuginfo-7.2.5-lp151.6.19.2
          php7-fastcgi-7.2.5-lp151.6.19.2
          php7-fastcgi-debuginfo-7.2.5-lp151.6.19.2
          php7-fileinfo-7.2.5-lp151.6.19.2
          php7-fileinfo-debuginfo-7.2.5-lp151.6.19.2
          php7-firebird-7.2.5-lp151.6.19.2
          php7-firebird-debuginfo-7.2.5-lp151.6.19.2
          php7-fpm-7.2.5-lp151.6.19.2
          php7-fpm-debuginfo-7.2.5-lp151.6.19.2
          php7-ftp-7.2.5-lp151.6.19.2
          php7-ftp-debuginfo-7.2.5-lp151.6.19.2
          php7-gd-7.2.5-lp151.6.19.2
          php7-gd-debuginfo-7.2.5-lp151.6.19.2
          php7-gettext-7.2.5-lp151.6.19.2
          php7-gettext-debuginfo-7.2.5-lp151.6.19.2
          php7-gmp-7.2.5-lp151.6.19.2
          php7-gmp-debuginfo-7.2.5-lp151.6.19.2
          php7-iconv-7.2.5-lp151.6.19.2
          php7-iconv-debuginfo-7.2.5-lp151.6.19.2
          php7-intl-7.2.5-lp151.6.19.2
          php7-intl-debuginfo-7.2.5-lp151.6.19.2
          php7-json-7.2.5-lp151.6.19.2
          php7-json-debuginfo-7.2.5-lp151.6.19.2
          php7-ldap-7.2.5-lp151.6.19.2
          php7-ldap-debuginfo-7.2.5-lp151.6.19.2
          php7-mbstring-7.2.5-lp151.6.19.2
          php7-mbstring-debuginfo-7.2.5-lp151.6.19.2
          php7-mysql-7.2.5-lp151.6.19.2
          php7-mysql-debuginfo-7.2.5-lp151.6.19.2
          php7-odbc-7.2.5-lp151.6.19.2
          php7-odbc-debuginfo-7.2.5-lp151.6.19.2
          php7-opcache-7.2.5-lp151.6.19.2
          php7-opcache-debuginfo-7.2.5-lp151.6.19.2
          php7-openssl-7.2.5-lp151.6.19.2
          php7-openssl-debuginfo-7.2.5-lp151.6.19.2
          php7-pcntl-7.2.5-lp151.6.19.2
          php7-pcntl-debuginfo-7.2.5-lp151.6.19.2
          php7-pdo-7.2.5-lp151.6.19.2
          php7-pdo-debuginfo-7.2.5-lp151.6.19.2
          php7-pgsql-7.2.5-lp151.6.19.2
          php7-pgsql-debuginfo-7.2.5-lp151.6.19.2
          php7-phar-7.2.5-lp151.6.19.2
          php7-phar-debuginfo-7.2.5-lp151.6.19.2
          php7-posix-7.2.5-lp151.6.19.2
          php7-posix-debuginfo-7.2.5-lp151.6.19.2
          php7-readline-7.2.5-lp151.6.19.2
          php7-readline-debuginfo-7.2.5-lp151.6.19.2
          php7-shmop-7.2.5-lp151.6.19.2
          php7-shmop-debuginfo-7.2.5-lp151.6.19.2
          php7-snmp-7.2.5-lp151.6.19.2
          php7-snmp-debuginfo-7.2.5-lp151.6.19.2
          php7-soap-7.2.5-lp151.6.19.2
          php7-soap-debuginfo-7.2.5-lp151.6.19.2
          php7-sockets-7.2.5-lp151.6.19.2
          php7-sockets-debuginfo-7.2.5-lp151.6.19.2
          php7-sodium-7.2.5-lp151.6.19.2
          php7-sodium-debuginfo-7.2.5-lp151.6.19.2
          php7-sqlite-7.2.5-lp151.6.19.2
          php7-sqlite-debuginfo-7.2.5-lp151.6.19.2
          php7-sysvmsg-7.2.5-lp151.6.19.2
          php7-sysvmsg-debuginfo-7.2.5-lp151.6.19.2
          php7-sysvsem-7.2.5-lp151.6.19.2
          php7-sysvsem-debuginfo-7.2.5-lp151.6.19.2
          php7-sysvshm-7.2.5-lp151.6.19.2
          php7-sysvshm-debuginfo-7.2.5-lp151.6.19.2
          php7-test-7.2.5-lp151.6.19.2
          php7-tidy-7.2.5-lp151.6.19.2
          php7-tidy-debuginfo-7.2.5-lp151.6.19.2
          php7-tokenizer-7.2.5-lp151.6.19.2
          php7-tokenizer-debuginfo-7.2.5-lp151.6.19.2
          php7-wddx-7.2.5-lp151.6.19.2
          php7-wddx-debuginfo-7.2.5-lp151.6.19.2
          php7-xmlreader-7.2.5-lp151.6.19.2
          php7-xmlreader-debuginfo-7.2.5-lp151.6.19.2
          php7-xmlrpc-7.2.5-lp151.6.19.2
          php7-xmlrpc-debuginfo-7.2.5-lp151.6.19.2
          php7-xmlwriter-7.2.5-lp151.6.19.2
          php7-xmlwriter-debuginfo-7.2.5-lp151.6.19.2
          php7-xsl-7.2.5-lp151.6.19.2
          php7-xsl-debuginfo-7.2.5-lp151.6.19.2
          php7-zip-7.2.5-lp151.6.19.2
          php7-zip-debuginfo-7.2.5-lp151.6.19.2
          php7-zlib-7.2.5-lp151.6.19.2
          php7-zlib-debuginfo-7.2.5-lp151.6.19.2
    
       - openSUSE Leap 15.1 (noarch):
    
          php7-pear-7.2.5-lp151.6.19.2
          php7-pear-Archive_Tar-7.2.5-lp151.6.19.2
    
    
    References:
    
       https://www.suse.com/security/cve/CVE-2019-11045.html
       https://www.suse.com/security/cve/CVE-2019-11046.html
       https://www.suse.com/security/cve/CVE-2019-11047.html
       https://www.suse.com/security/cve/CVE-2019-11050.html
       https://bugzilla.suse.com/1159922
       https://bugzilla.suse.com/1159923
       https://bugzilla.suse.com/1159924
       https://bugzilla.suse.com/1159927
    
    -- 
    
    You are not authorised to post comments.

    Comments powered by CComment

    LinuxSecurity Poll

    What do you think of the LinuxSecurity Privacy news articles?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/25-what-do-you-think-of-the-linuxsecurity-privacy-news-articles?task=poll.vote&format=json
    25
    radio
    [{"id":"90","title":"Love them!","votes":"33","type":"x","order":"1","pct":91.67,"resources":[]},{"id":"91","title":"I'm indifferent","votes":"2","type":"x","order":"2","pct":5.56,"resources":[]},{"id":"92","title":"Not interested in this topic","votes":"1","type":"x","order":"3","pct":2.78,"resources":[]}]["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"]["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"]350
    bottom200

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.