openSUSE: 2020:0958-1: moderate: hylafax+

    Date 14 Jul 2020
    161
    Posted By LinuxSecurity Advisories
    An update that fixes one vulnerability is now available.
       openSUSE Security Update: Security update for hylafax+
    ______________________________________________________________________________
    
    Announcement ID:    openSUSE-SU-2020:0958-1
    Rating:             moderate
    References:         #1172731 
    Cross-References:   CVE-2020-8024
    Affected Products:
                        openSUSE Leap 15.1
    ______________________________________________________________________________
    
       An update that fixes one vulnerability is now available.
    
    Description:
    
       This update for hylafax+ fixes the following issues:
    
       Security issue fixed:
    
       - CVE-2020-8024 boo#1172731
    
       hylafax+ was updated to version 7.0.2:
    
       * change FIXEDWIDTH default to better accommodate auto-rotation (13 Dec
         2019)
       * prevent SSL_accept() from blocking (5 Dec 2019)
       * support libtiff v4.1 (5 Dec 2019)
       * fix ignoremodembusy feature broken by ModemGroup limits feature (16 Nov
         2019)
    
       Version 7.0.1:
    
       * create a client timeout setting and change the default from 60 to 3600
         seconds (26 Sep 2019)
       * extend timeout for receiving ECM frames (21 Aug 2019)
       * fix timeout in Class 1 frame reception (5 Aug 2019)
       * improve Class 1 protocol handling when MaxRecvPages exceeded (31 Jul
         2019)
       * fix ModemGroup limit default (11 Jul 2019)
       * fix recovery for SSL Fax write failures (6 Jun 2019)
    
       Version 7.0.0:
    
       * add LDAP features for compatibility with ActiveDirectory (25 Mar-1 Apr
         2019)
       * fix recovery after SSL Fax "accept failure" (18 Mar 2019)
       * add TextFormat overstrike option and disable by default (6 Feb 2019)
       * fix the page size of cover sheets returned via notify (8 Jan 2019)
       * fix or silence numerous compiler warnings (19, 22, 28 Dec 2018)
       * fix pagehandling updating after a proxy has been used (7-8 Dec 2018)
       * add faxmail stderr output of RFC2047 decoding results (5 Dec 2018)
       * fix faxmail handling of headers encoded with UTF-8 (4 Dec 2018)
       * fix faxmail handling of base64-encoded text parts (4 Dec 2018)
       * add SSL Fax support (9-26, 29 Nov; 11, 18, 25 Dec 2018; 2, 7, 23 Jan
         2019)
    
    
    Patch Instructions:
    
       To install this openSUSE Security Update use the SUSE recommended installation methods
       like YaST online_update or "zypper patch".
    
       Alternatively you can run the command listed for your product:
    
       - openSUSE Leap 15.1:
    
          zypper in -t patch openSUSE-2020-958=1
    
    
    
    Package List:
    
       - openSUSE Leap 15.1 (x86_64):
    
          hylafax+-7.0.2-lp151.4.3.1
          hylafax+-client-7.0.2-lp151.4.3.1
          hylafax+-client-debuginfo-7.0.2-lp151.4.3.1
          hylafax+-debuginfo-7.0.2-lp151.4.3.1
          hylafax+-debugsource-7.0.2-lp151.4.3.1
          libfaxutil7_0_2-7.0.2-lp151.4.3.1
          libfaxutil7_0_2-debuginfo-7.0.2-lp151.4.3.1
    
    
    References:
    
       https://www.suse.com/security/cve/CVE-2020-8024.html
       https://bugzilla.suse.com/1172731
    
    -- 
    

    LinuxSecurity Poll

    Are you planning to use the 1Password password manager now that it is available to Linux users?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/35-are-you-planning-to-use-the-1password-password-manager-now-that-it-is-available-to-linux-users?task=poll.vote&format=json
    35
    radio
    [{"id":"122","title":"Yes","votes":"1","type":"x","order":"1","pct":25,"resources":[]},{"id":"123","title":"No ","votes":"2","type":"x","order":"2","pct":50,"resources":[]},{"id":"124","title":"Not sure at the moment","votes":"1","type":"x","order":"3","pct":25,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350
    bottom 200

    Advisories

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.