Linux Security
    Linux Security
    Linux Security

    openSUSE: 2020:1494-1: moderate: curl

    Date
    166
    Posted By
    An update that fixes one vulnerability is now available.
       openSUSE Security Update: Security update for curl
    ______________________________________________________________________________
    
    Announcement ID:    openSUSE-SU-2020:1494-1
    Rating:             moderate
    References:         #1175109 
    Cross-References:   CVE-2020-8231
    Affected Products:
                        openSUSE Leap 15.2
    ______________________________________________________________________________
    
       An update that fixes one vulnerability is now available.
    
    Description:
    
       This update for curl fixes the following issues:
    
       - An application that performs multiple requests with libcurl's multi API
         and sets the 'CURLOPT_CONNECT_ONLY' option, might in rare circumstances
         experience that when subsequently using the setup connect-only transfer,
         libcurl will pick and use the wrong connection and instead pick another
         one the application has created since then. [bsc#1175109, CVE-2020-8231]
    
       This update was imported from the SUSE:SLE-15-SP2:Update update project.
    
    
    Patch Instructions:
    
       To install this openSUSE Security Update use the SUSE recommended installation methods
       like YaST online_update or "zypper patch".
    
       Alternatively you can run the command listed for your product:
    
       - openSUSE Leap 15.2:
    
          zypper in -t patch openSUSE-2020-1494=1
    
    
    
    Package List:
    
       - openSUSE Leap 15.2 (i586 x86_64):
    
          curl-7.66.0-lp152.3.9.1
          curl-debuginfo-7.66.0-lp152.3.9.1
          curl-debugsource-7.66.0-lp152.3.9.1
          curl-mini-7.66.0-lp152.3.9.1
          curl-mini-debuginfo-7.66.0-lp152.3.9.1
          curl-mini-debugsource-7.66.0-lp152.3.9.1
          libcurl-devel-7.66.0-lp152.3.9.1
          libcurl-mini-devel-7.66.0-lp152.3.9.1
          libcurl4-7.66.0-lp152.3.9.1
          libcurl4-debuginfo-7.66.0-lp152.3.9.1
          libcurl4-mini-7.66.0-lp152.3.9.1
          libcurl4-mini-debuginfo-7.66.0-lp152.3.9.1
    
       - openSUSE Leap 15.2 (x86_64):
    
          libcurl-devel-32bit-7.66.0-lp152.3.9.1
          libcurl4-32bit-7.66.0-lp152.3.9.1
          libcurl4-32bit-debuginfo-7.66.0-lp152.3.9.1
    
    
    References:
    
       https://www.suse.com/security/cve/CVE-2020-8231.html
       https://bugzilla.suse.com/1175109
    
    -- 
    

    Advisories

    LinuxSecurity Poll

    Tails is the most secure Linux distro out there.

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 2 answer(s).
    /main-polls/41-ubuntu-is-a-more-secure-distro-than-fedora?task=poll.vote&format=json
    41
    radio
    [{"id":"142","title":"Yes - Tails get my vote!","votes":"1","type":"x","order":"1","pct":100,"resources":[]},{"id":"143","title":"Nope - Parrot OS has surpassed Tails in its security and privacy.","votes":"0","type":"x","order":"2","pct":0,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350


    VIEW MORE POLLS

    bottom 200

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.