Linux Security
    Linux Security
    Linux Security

    openSUSE: 2020:1501-1: moderate: libqt4

    Date
    126
    Posted By
    An update that solves four vulnerabilities and has one errata is now available.
       openSUSE Security Update: Security update for libqt4
    ______________________________________________________________________________
    
    Announcement ID:    openSUSE-SU-2020:1501-1
    Rating:             moderate
    References:         #1118595 #1118596 #1118599 #1121214 #1176315 
                        
    Cross-References:   CVE-2018-15518 CVE-2018-19869 CVE-2018-19873
                        CVE-2020-17507
    Affected Products:
                        openSUSE Leap 15.2
    ______________________________________________________________________________
    
       An update that solves four vulnerabilities and has one
       errata is now available.
    
    Description:
    
       This update for libqt4 fixes the following issues:
    
       * Fix buffer over-read in read_xbm_body (boo#1176315, CVE-2020-17507)
       * Fix "double free or corruption" in QXmlStreamReader (boo#1118595,
         CVE-2018-15518)
       * Fix QBmpHandler segfault on malformed BMP file boo#1118596,
         CVE-2018-19873)
       * Fix crash when parsing malformed url reference (boo#1118599,
         CVE-2018-19869)
    
    
       This update was imported from the openSUSE:Leap:15.1:Update update project.
    
    
    Patch Instructions:
    
       To install this openSUSE Security Update use the SUSE recommended installation methods
       like YaST online_update or "zypper patch".
    
       Alternatively you can run the command listed for your product:
    
       - openSUSE Leap 15.2:
    
          zypper in -t patch openSUSE-2020-1501=1
    
    
    
    Package List:
    
       - openSUSE Leap 15.2 (i586 x86_64):
    
          libqt4-4.8.7-lp152.10.3.1
          libqt4-debuginfo-4.8.7-lp152.10.3.1
          libqt4-debugsource-4.8.7-lp152.10.3.1
          libqt4-devel-4.8.7-lp152.10.3.1
          libqt4-devel-debuginfo-4.8.7-lp152.10.3.1
          libqt4-linguist-4.8.7-lp152.10.3.1
          libqt4-linguist-debuginfo-4.8.7-lp152.10.3.1
          libqt4-private-headers-devel-4.8.7-lp152.10.3.1
          libqt4-qt3support-4.8.7-lp152.10.3.1
          libqt4-qt3support-debuginfo-4.8.7-lp152.10.3.1
          libqt4-sql-4.8.7-lp152.10.3.1
          libqt4-sql-debuginfo-4.8.7-lp152.10.3.1
          libqt4-sql-sqlite-4.8.7-lp152.10.3.1
          libqt4-sql-sqlite-debuginfo-4.8.7-lp152.10.3.1
          libqt4-x11-4.8.7-lp152.10.3.1
          libqt4-x11-debuginfo-4.8.7-lp152.10.3.1
    
       - openSUSE Leap 15.2 (x86_64):
    
          libqt4-32bit-4.8.7-lp152.10.3.1
          libqt4-32bit-debuginfo-4.8.7-lp152.10.3.1
          libqt4-devel-32bit-4.8.7-lp152.10.3.1
          libqt4-devel-32bit-debuginfo-4.8.7-lp152.10.3.1
          libqt4-devel-doc-4.8.7-lp152.10.3.1
          libqt4-devel-doc-debuginfo-4.8.7-lp152.10.3.1
          libqt4-devel-doc-debugsource-4.8.7-lp152.10.3.1
          libqt4-qt3support-32bit-4.8.7-lp152.10.3.1
          libqt4-qt3support-32bit-debuginfo-4.8.7-lp152.10.3.1
          libqt4-sql-32bit-4.8.7-lp152.10.3.1
          libqt4-sql-32bit-debuginfo-4.8.7-lp152.10.3.1
          libqt4-sql-plugins-debugsource-4.8.7-lp152.10.3.1
          libqt4-sql-postgresql-4.8.7-lp152.10.3.1
          libqt4-sql-postgresql-debuginfo-4.8.7-lp152.10.3.1
          libqt4-sql-sqlite-32bit-4.8.7-lp152.10.3.1
          libqt4-sql-sqlite-32bit-debuginfo-4.8.7-lp152.10.3.1
          libqt4-sql-unixODBC-4.8.7-lp152.10.3.1
          libqt4-sql-unixODBC-debuginfo-4.8.7-lp152.10.3.1
          libqt4-x11-32bit-4.8.7-lp152.10.3.1
          libqt4-x11-32bit-debuginfo-4.8.7-lp152.10.3.1
          qt4-x11-tools-4.8.7-lp152.10.3.1
          qt4-x11-tools-debuginfo-4.8.7-lp152.10.3.1
    
       - openSUSE Leap 15.2 (noarch):
    
          libqt4-devel-doc-data-4.8.7-lp152.10.3.1
    
    
    References:
    
       https://www.suse.com/security/cve/CVE-2018-15518.html
       https://www.suse.com/security/cve/CVE-2018-19869.html
       https://www.suse.com/security/cve/CVE-2018-19873.html
       https://www.suse.com/security/cve/CVE-2020-17507.html
       https://bugzilla.suse.com/1118595
       https://bugzilla.suse.com/1118596
       https://bugzilla.suse.com/1118599
       https://bugzilla.suse.com/1121214
       https://bugzilla.suse.com/1176315
    
    -- 
    

    LinuxSecurity Poll

    Tails is the most secure Linux distro out there.

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 2 answer(s).
    /main-polls/41-ubuntu-is-a-more-secure-distro-than-fedora?task=poll.vote&format=json
    41
    radio
    [{"id":"142","title":"Yes - Tails get my vote!","votes":"4","type":"x","order":"1","pct":66.67,"resources":[]},{"id":"143","title":"Nope - Parrot OS has surpassed Tails in its security and privacy.","votes":"2","type":"x","order":"2","pct":33.33,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350

    Please vote first in order to view vote results.


    VIEW MORE POLLS

    bottom 200

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.