RedHat: RHSA-2020-2816:01 Important: RH-SSO 7.4.1 adapters for Red Hat

    Date 02 Jul 2020
    192
    Posted By LinuxSecurity Advisories
    A security update is now available for Red Hat Single Sign-On 7.4.1 adapters for Red Hat JBoss Enterprise Application Platform 6 Red Hat Product Security has rated this update as having a security impact of
    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA256
    
    =====================================================================
                       Red Hat Security Advisory
    
    Synopsis:          Important: RH-SSO 7.4.1 adapters for Red Hat JBoss Enterprise Application Platform 6
    Advisory ID:       RHSA-2020:2816-01
    Product:           Red Hat JBoss Enterprise Application Platform
    Advisory URL:      https://access.redhat.com/errata/RHSA-2020:2816
    Issue date:        2020-07-02
    CVE Names:         CVE-2020-1714 
    =====================================================================
    
    1. Summary:
    
    A security update is now available for Red Hat Single Sign-On 7.4.1
    adapters for Red Hat JBoss Enterprise Application Platform 6
    
    Red Hat Product Security has rated this update as having a security impact
    of
    Important. A Common Vulnerability Scoring System (CVSS) base score, which
    gives a detailed severity rating, is available for each vulnerability from
    the CVE link(s) in the References section.
    
    2. Relevant releases/architectures:
    
    Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 6 Server - noarch
    Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 7 Server - noarch
    
    3. Description:
    
    Packages: Red Hat Single Sign-On 7.4.1 adapters for Red Hat JBoss
    Enterprise Application Platform 6
    
    Security Fix(es):
    
    * keycloak: Lack of checks in ObjectInputStream leading to Remote Code
    Execution (CVE-2020-1714)
    
    For more details about the security issue(s), including the impact, a CVSS
    score, acknowledgments, and other related information, refer to the CVE
    page(s)
    listed in the References section.
    
    4. Solution:
    
    Before applying this update, make sure all previously released errata
    relevant to your system have been applied.
    
    For details on how to apply this update, refer to:
    
    https://access.redhat.com/articles/11258
    
    5. Bugs fixed (https://bugzilla.redhat.com/):
    
    1705975 - CVE-2020-1714 keycloak: Lack of checks in ObjectInputStream leading to Remote Code Execution
    
    6. JIRA issues fixed (https://issues.jboss.org/):
    
    KEYCLOAK-13949 - Create RPMs for the RH-SSO 7.4.1 adapters for Red Hat JBoss Enterprise Application Platform 6
    
    7. Package List:
    
    Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 6 Server:
    
    Source:
    keycloak-adapter-sso7_4-eap6-9.0.4-1.redhat_00001.1.ep6.el6.src.rpm
    
    noarch:
    keycloak-adapter-sso7_4-eap6-9.0.4-1.redhat_00001.1.ep6.el6.noarch.rpm
    keycloak-saml-adapter-sso7_4-eap6-9.0.4-1.redhat_00001.1.ep6.el6.noarch.rpm
    
    Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 7 Server:
    
    Source:
    keycloak-adapter-sso7_4-eap6-9.0.4-1.redhat_00001.1.ep6.el7.src.rpm
    
    noarch:
    keycloak-adapter-sso7_4-eap6-9.0.4-1.redhat_00001.1.ep6.el7.noarch.rpm
    keycloak-saml-adapter-sso7_4-eap6-9.0.4-1.redhat_00001.1.ep6.el7.noarch.rpm
    
    These packages are GPG signed by Red Hat for security.  Our key and
    details on how to verify the signature are available from
    https://access.redhat.com/security/team/key/
    
    8. References:
    
    https://access.redhat.com/security/cve/CVE-2020-1714
    https://access.redhat.com/security/updates/classification/#important
    https://access.redhat.com/documentation/en-us/red_hat_single_sign-on/7.4/
    
    9. Contact:
    
    The Red Hat security contact is . More contact
    details at https://access.redhat.com/security/team/contact/
    
    Copyright 2020 Red Hat, Inc.
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1
    
    iQIVAwUBXv3vttzjgjWX9erEAQip+g//fUaBD88/9hlJWte4MlRqtgCZH1Bts3za
    Mad/Msagcj6UlFBHUg94bX6RItRornmSYDvspTUhQhAJ+9NEHlhBLBbxUB/p1rVf
    Y99XjUK6Z/p4HIgZYKid7P+3fGtWr8/RRClH3Zk2Po6XaQ7J0yZld0np94YFA5rm
    RiWX+6TBFVTNSommJzKxRU8fIkLtJ1JsL6yrUoc6KDIcHUuf01aZJINLpU+uYI5l
    z0P1QZG/Re94bnth6hO5Z0ykQxFRH2uKl52qzAmqBn3WZD2YpWz43SNcrWL8banM
    toLlBIGGP0XT4um/WE7RZrzGL3UeymF3p71sQ8A/VinIEygZyPB+Rkm4W0B3HJQd
    v+2ln4811QH/y0hRjAW9wS3d1G1zWLKBVy9jmCfEtm3FO0OdVXrhbaoIm/De63Gt
    Yx2jDPRinbEkkh2+whLflnwAvD8sIrgwlaobk5siCuRDr/5HzDzATjVWf6AGxdpq
    dWthvIQFHPlLUryUttcjFNVxLW8CxGfkT7OhsTCNVKoDdrIipNq12ulC2EDO5yk4
    Hl2d14XP8u1qQ2zY6greVHZhinYkSH+d8SpKFOkmHmeKk/DI/xvJ5YSStFxtfGay
    Nv/DGhx0gETTZ8zA++rpGmubXlREX64greEemjF7V4nXW9U1gkJoa9dCta81YQXn
    XP76+/SEPWU=
    =GwKJ
    -----END PGP SIGNATURE-----
    
    --
    RHSA-announce mailing list
    This email address is being protected from spambots. You need JavaScript enabled to view it.
    https://www.redhat.com/mailman/listinfo/rhsa-announce
    

    LinuxSecurity Poll

    Are you planning to use the 1Password password manager now that it is available to Linux users?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/35-are-you-planning-to-use-the-1password-password-manager-now-that-it-is-available-to-linux-users?task=poll.vote&format=json
    35
    radio
    [{"id":"122","title":"Yes","votes":"1","type":"x","order":"1","pct":25,"resources":[]},{"id":"123","title":"No ","votes":"2","type":"x","order":"2","pct":50,"resources":[]},{"id":"124","title":"Not sure at the moment","votes":"1","type":"x","order":"3","pct":25,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350
    bottom 200

    Advisories

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.