RedHat: RHSA-2020-3248:01 Important: Red Hat build of Quarkus 1.3.4 SP1

    Date 30 Jul 2020
    141
    Posted By LinuxSecurity Advisories
    An update is now available for Red Hat build of Quarkus. Red Hat Product Security has rated this update as having a security impact of Important. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each
    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA256
    
    =====================================================================
                       Red Hat Security Advisory
    
    Synopsis:          Important: Red Hat build of Quarkus 1.3.4 SP1 release and security update
    Advisory ID:       RHSA-2020:3248-01
    Product:           Red Hat build of Quarkus
    Advisory URL:      https://access.redhat.com/errata/RHSA-2020:3248
    Issue date:        2020-07-30
    CVE Names:         CVE-2020-13692 CVE-2020-14326 
    =====================================================================
    
    1. Summary:
    
    An update is now available for Red Hat build of Quarkus.
    
    Red Hat Product Security has rated this update as having a security impact
    of Important. A Common Vulnerability Scoring System (CVSS) base score,
    which gives a detailed severity rating, is available for each
    vulnerability. For more information, see the CVE links in the References
    section.
    
    2. Description:
    
    This release of Red Hat build of Quarkus 1.3.4 SP1 includes security
    updates, bug fixes, and enhancements. For more information, see the release
    notes page listed in the References section.
    
    Security Fix(es):
    
    * postgresql-jdbc: XML external entity (XXE) vulnerability in
    PgSQLXML(CVE-2020-13692)
    
    * RESTEasy: Caching routes in RootNode may result in DoS (CVE-2020-14326)
    
    For more details about the security issues and their impact, the CVSS
    score, acknowledgments, and other related information see the CVE pages
    listed in the References section.
    
    3. Solution:
    
    Before applying the update, back up your existing installation, including
    all applications, configuration files, databases and database settings, and
    so on.
    
    The References section of this erratum contains a download link for the
    update. You must be logged in to download the update.
    
    4. Bugs fixed (https://bugzilla.redhat.com/):
    
    1852985 - CVE-2020-13692 postgresql-jdbc: XML external entity (XXE) vulnerability in PgSQLXML
    1855826 - CVE-2020-14326 RESTEasy: Caching routes in RootNode may result in DoS
    
    5. References:
    
    https://access.redhat.com/security/cve/CVE-2020-13692
    https://access.redhat.com/security/cve/CVE-2020-14326
    https://access.redhat.com/security/updates/classification/#important
    https://access.redhat.com/jbossnetwork/restricted/listSoftware.html?product=redhat.quarkus&downloadType=distributions&version=1.3.4.SP1
    https://access.redhat.com/documentation/en-us/red_hat_build_of_quarkus/1.3/html/release_notes_for_red_hat_build_of_quarkus_1.3/index
    https://access.redhat.com/articles/4966181
    
    6. Contact:
    
    The Red Hat security contact is . More contact
    details at https://access.redhat.com/security/team/contact/
    
    Copyright 2020 Red Hat, Inc.
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1
    
    iQIVAwUBXyLNDtzjgjWX9erEAQixIg//XiHi46a5v30MSwQ1vXJVQf4AbbyS7oGO
    mRt1g9owwLpk8sna9a1GWwixVpDJTv//2frvBFMosgClh7sPbiXcrASmSNg5xE5o
    o3mGChv/V8Dyi1PU8b2RAgGhYho4OwNLRaFv6YXxWmJJHiKM4p37OMFXrpsVYCEA
    5o1YPZfysm2Ps3FwLcAPYPMW2pb4zNIKSh2fTVXb/7URUUoz+uLRg4/ZyYUSJAgs
    bsXjH7RvNjYNZzAHaE2lYpxt5buAyRhKgOZfg8/uDU6dTKHQK8lxdEAHT4kjAkEX
    P3WuMIxtZpjTWbaA+OF1vdVBfcf7ZJw6OoAwufU5uGVIWwVi+HS3xhOOXw8Mwjhu
    zdA5UIulFa+zCF1hHOUtmnQ2Aj+iWaI0QbfacfILutYskuqfbXAJRPXIYm6rfDfK
    mYL2Jlt/mt3D01Y3LQuQKYIjUf55WReMAMJx8ljrvTvbancxMLPJ4zCdAqL/rAEA
    46k96LCsDkIaeiqn+mJZpLtxfeeD6GKusEs/joNS0SMsPlANC2BlqsE3mYI1Acll
    ZS+Jn5kyFoBHVphnIfBKy6ut3JddBflBEMFbP0uT/pWKNYetDpwmyAAHwgyT7Ay3
    Ts9OQHVz1ugaLIu7Rv32xIiZc2JIstPBTXLaGO2FC9ur6YW8t421nlAj20E8YMHo
    2VM1F+aLeOw=
    =0hK2
    -----END PGP SIGNATURE-----
    
    --
    RHSA-announce mailing list
    This email address is being protected from spambots. You need JavaScript enabled to view it.
    https://www.redhat.com/mailman/listinfo/rhsa-announce
    

    LinuxSecurity Poll

    If you are using full-disk encryption: are you concerned about the resulting performance hit?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 2 answer(s).
    /main-polls/34-if-you-are-using-full-disk-encryption-are-you-concerned-about-the-resulting-performance-hit?task=poll.vote&format=json
    34
    radio
    [{"id":"120","title":"Yes","votes":"14","type":"x","order":"1","pct":60.87,"resources":[]},{"id":"121","title":"No ","votes":"9","type":"x","order":"2","pct":39.13,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350
    bottom 200

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.