Linux Security
    Linux Security
    Linux Security

    RedHat: RHSA-2021-0289:01 Important: firefox security update

    Date 27 Jan 2021
    171
    Posted By LinuxSecurity Advisories
    An update for firefox is now available for Red Hat Enterprise Linux 8.2 Extended Update Support. Red Hat Product Security has rated this update as having a security impact of Important. A Common Vulnerability Scoring System (CVSS) base score,
    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA256
    
    =====================================================================
                       Red Hat Security Advisory
    
    Synopsis:          Important: firefox security update
    Advisory ID:       RHSA-2021:0289-01
    Product:           Red Hat Enterprise Linux
    Advisory URL:      https://access.redhat.com/errata/RHSA-2021:0289
    Issue date:        2021-01-27
    CVE Names:         CVE-2020-26976 CVE-2021-23953 CVE-2021-23954 
                       CVE-2021-23960 CVE-2021-23964 
    =====================================================================
    
    1. Summary:
    
    An update for firefox is now available for Red Hat Enterprise Linux 8.2
    Extended Update Support.
    
    Red Hat Product Security has rated this update as having a security impact
    of Important. A Common Vulnerability Scoring System (CVSS) base score,
    which gives a detailed severity rating, is available for each vulnerability
    from the CVE link(s) in the References section.
    
    2. Relevant releases/architectures:
    
    Red Hat Enterprise Linux AppStream EUS (v. 8.2) - aarch64, ppc64le, s390x, x86_64
    
    3. Description:
    
    Mozilla Firefox is an open-source web browser, designed for standards
    compliance, performance, and portability.
    
    This update upgrades Firefox to version 78.7.0 ESR.
    
    Security Fix(es):
    
    * Mozilla: Cross-origin information leakage via redirected PDF requests
    (CVE-2021-23953)
    
    * Mozilla: Type confusion when using logical assignment operators in
    JavaScript switch statements (CVE-2021-23954)
    
    * Mozilla: Memory safety bugs fixed in Firefox 85 and Firefox ESR 78.7
    (CVE-2021-23964)
    
    * Mozilla: HTTPS pages could have been intercepted by a registered service
    worker when they should not have been (CVE-2020-26976)
    
    * Mozilla: Use-after-poison for incorrectly redeclared JavaScript variables
    during GC (CVE-2021-23960)
    
    For more details about the security issue(s), including the impact, a CVSS
    score, acknowledgments, and other related information, refer to the CVE
    page(s) listed in the References section.
    
    4. Solution:
    
    For details on how to apply this update, which includes the changes
    described in this advisory, refer to:
    
    https://access.redhat.com/articles/11258
    
    After installing the update, Firefox must be restarted for the changes to
    take effect.
    
    5. Bugs fixed (https://bugzilla.redhat.com/):
    
    1920646 - CVE-2021-23953 Mozilla: Cross-origin information leakage via redirected PDF requests
    1920648 - CVE-2021-23954 Mozilla: Type confusion when using logical assignment operators in JavaScript switch statements
    1920649 - CVE-2020-26976 Mozilla: HTTPS pages could have been intercepted by a registered service worker when they should not have been
    1920650 - CVE-2021-23960 Mozilla: Use-after-poison for incorrectly redeclared JavaScript variables during GC
    1920651 - CVE-2021-23964 Mozilla: Memory safety bugs fixed in Firefox 85 and Firefox ESR 78.7
    
    6. Package List:
    
    Red Hat Enterprise Linux AppStream EUS (v. 8.2):
    
    Source:
    firefox-78.7.0-2.el8_2.src.rpm
    
    aarch64:
    firefox-78.7.0-2.el8_2.aarch64.rpm
    firefox-debuginfo-78.7.0-2.el8_2.aarch64.rpm
    firefox-debugsource-78.7.0-2.el8_2.aarch64.rpm
    
    ppc64le:
    firefox-78.7.0-2.el8_2.ppc64le.rpm
    firefox-debuginfo-78.7.0-2.el8_2.ppc64le.rpm
    firefox-debugsource-78.7.0-2.el8_2.ppc64le.rpm
    
    s390x:
    firefox-78.7.0-2.el8_2.s390x.rpm
    firefox-debuginfo-78.7.0-2.el8_2.s390x.rpm
    firefox-debugsource-78.7.0-2.el8_2.s390x.rpm
    
    x86_64:
    firefox-78.7.0-2.el8_2.x86_64.rpm
    firefox-debuginfo-78.7.0-2.el8_2.x86_64.rpm
    firefox-debugsource-78.7.0-2.el8_2.x86_64.rpm
    
    These packages are GPG signed by Red Hat for security.  Our key and
    details on how to verify the signature are available from
    https://access.redhat.com/security/team/key/
    
    7. References:
    
    https://access.redhat.com/security/cve/CVE-2020-26976
    https://access.redhat.com/security/cve/CVE-2021-23953
    https://access.redhat.com/security/cve/CVE-2021-23954
    https://access.redhat.com/security/cve/CVE-2021-23960
    https://access.redhat.com/security/cve/CVE-2021-23964
    https://access.redhat.com/security/updates/classification/#important
    
    8. Contact:
    
    The Red Hat security contact is . More contact
    details at https://access.redhat.com/security/team/contact/
    
    Copyright 2021 Red Hat, Inc.
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1
    
    iQIVAwUBYBGqbtzjgjWX9erEAQgfeQ/6A1Hg1sZtqn8sjTe6gC4K/+CUq0gA1FWr
    CCZvIboZ36IrbHJUFVa7OLRNMzLtd12MixDtxboHFv1xcfftK9yyocjHT9dHLjbd
    Jx7cbQ9P+QQtnLfoz3vvpsag7S3pWMTWAMXmu3aOrhNS3S1yYuF72KxqD6YBFba6
    35Gt/MAlVJAdXfGCtYLruAPsjO/UU0nXOW7+mhXlCdVN3ZN42bXz/jLbI9vM9A2q
    UMHSjiBRQBYSpGJsdSJqAZZSY4+tlcKpAQ4/asuRJnDxmLaYR6qhPae5TMV9V05Y
    W7yFE7x8Sv1zQJDABescbpL0OSBJMe9dIA6kECGQX+aiUk+22R+HMiUy8qLs8XgU
    24DDmCipMV/IX7kfs2SOpctPWzu5jE9RbpMU15erXJj78fPiaBN/DLU336FqI7Bp
    r5NgPTF5P91gePjAllhX1x2h2eJiDXVLTtRAi4mLhFMYilz7QKUq95Y2JBivV5rn
    OVXeOvH0VD5NGcOY7eOhZDCBSQRu1eZ+cFF1AXtyHTGsjB/n37+a667NbnSeTtvj
    usHXre8Ev9+GqO0RynaflVcM5RJ1oBCHb6N7WfoQXq5WSC86NV5r7vnycvsWxvsV
    9Ax0Ks29ppwSuVPuE/N2tv5ZZYqeXnOPtLy+9tdPIku6kG2OuoGgh9mFfH06A9a5
    NFMZVFFsCKE=
    =+vwX
    -----END PGP SIGNATURE-----
    
    --
    RHSA-announce mailing list
    This email address is being protected from spambots. You need JavaScript enabled to view it.
    https://www.redhat.com/mailman/listinfo/rhsa-announce
    

    LinuxSecurity Poll

    Which is the best secure Linux distro for pentesting?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/50-which-is-the-best-secure-linux-distro-for-pentesting?task=poll.vote&format=json
    50
    radio
    [{"id":"174","title":"Kali Linux","votes":"6","type":"x","order":"1","pct":54.55,"resources":[]},{"id":"175","title":"Parrot OS","votes":"5","type":"x","order":"2","pct":45.45,"resources":[]},{"id":"176","title":"BlackArch Linux","votes":"0","type":"x","order":"3","pct":0,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350

    Please vote first in order to view vote results.


    VIEW MORE POLLS

    bottom 200

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.