Linux Security
Linux Security
Linux Security

RedHat: RHSA-2021-1074:01 Important: flatpak security update

Date 06 Apr 2021
60
Posted By LinuxSecurity Advisories
An update for flatpak is now available for Red Hat Enterprise Linux 8.1 Extended Update Support. Red Hat Product Security has rated this update as having a security impact of Important. A Common Vulnerability Scoring System (CVSS) base score,
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Important: flatpak security update
Advisory ID:       RHSA-2021:1074-01
Product:           Red Hat Enterprise Linux
Advisory URL:      https://access.redhat.com/errata/RHSA-2021:1074
Issue date:        2021-04-06
CVE Names:         CVE-2021-21381 
=====================================================================

1. Summary:

An update for flatpak is now available for Red Hat Enterprise Linux 8.1
Extended Update Support.

Red Hat Product Security has rated this update as having a security impact
of Important. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available for each vulnerability
from the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux AppStream EUS (v. 8.1) - aarch64, ppc64le, s390x, x86_64

3. Description:

Flatpak is a system for building, distributing, and running sandboxed
desktop applications on Linux.

Security Fix(es):

* flatpak: "file forwarding" feature can be used to gain unprivileged
access to files (CVE-2021-21381)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
page(s) listed in the References section.

4. Solution:

For details on how to apply this update, which includes the changes
described in this advisory, refer to:

https://access.redhat.com/articles/11258

5. Bugs fixed (https://bugzilla.redhat.com/):

1936985 - CVE-2021-21381 flatpak: "file forwarding" feature can be used to gain unprivileged access to files

6. Package List:

Red Hat Enterprise Linux AppStream EUS (v. 8.1):

Source:
flatpak-1.0.9-4.el8_1.src.rpm

aarch64:
flatpak-1.0.9-4.el8_1.aarch64.rpm
flatpak-debuginfo-1.0.9-4.el8_1.aarch64.rpm
flatpak-debugsource-1.0.9-4.el8_1.aarch64.rpm
flatpak-libs-1.0.9-4.el8_1.aarch64.rpm
flatpak-libs-debuginfo-1.0.9-4.el8_1.aarch64.rpm

ppc64le:
flatpak-1.0.9-4.el8_1.ppc64le.rpm
flatpak-debuginfo-1.0.9-4.el8_1.ppc64le.rpm
flatpak-debugsource-1.0.9-4.el8_1.ppc64le.rpm
flatpak-libs-1.0.9-4.el8_1.ppc64le.rpm
flatpak-libs-debuginfo-1.0.9-4.el8_1.ppc64le.rpm

s390x:
flatpak-1.0.9-4.el8_1.s390x.rpm
flatpak-debuginfo-1.0.9-4.el8_1.s390x.rpm
flatpak-debugsource-1.0.9-4.el8_1.s390x.rpm
flatpak-libs-1.0.9-4.el8_1.s390x.rpm
flatpak-libs-debuginfo-1.0.9-4.el8_1.s390x.rpm

x86_64:
flatpak-1.0.9-4.el8_1.x86_64.rpm
flatpak-debuginfo-1.0.9-4.el8_1.i686.rpm
flatpak-debuginfo-1.0.9-4.el8_1.x86_64.rpm
flatpak-debugsource-1.0.9-4.el8_1.i686.rpm
flatpak-debugsource-1.0.9-4.el8_1.x86_64.rpm
flatpak-libs-1.0.9-4.el8_1.i686.rpm
flatpak-libs-1.0.9-4.el8_1.x86_64.rpm
flatpak-libs-debuginfo-1.0.9-4.el8_1.i686.rpm
flatpak-libs-debuginfo-1.0.9-4.el8_1.x86_64.rpm

These packages are GPG signed by Red Hat for security.  Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2021-21381
https://access.redhat.com/security/updates/classification/#important

8. Contact:

The Red Hat security contact is . More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2021 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIVAwUBYGwrzdzjgjWX9erEAQjIFQ//c02abp73JHk8VKRTd47UPfJH9V2fp2R/
vtAoNmuaVnSLTUlPEorS3GiYN5cfJzWjq2jdx1jqf0xTkPRfcDqVLIkfJ4TEyuGX
6hkk3h5XtBemmDkzAiDvIH69LlcvTe51phZyxeerdTH2BFjnQ0Hd+j+P3nKN8iaC
Z+xIFl9ybN0yTDlG7ggvpvQkFV5twcsUx5Y1KpSD9O9ryUZmj4G8yWFt88NZDu2U
VMyyn+Z80ULY77Hz0yNJFLixyK2ESY+RNeekA6z7Sax6vq0jSgt+GlCVREfNG5Hn
0leRd/ctwLhMFtfK/6S2zpunDqyxqlJMLGdIuZ3CIyKUdUlUfkQbSBCiYCe5jhxx
RybbxLy0F8wGf9JD8e83zsmI8nGIUwUEoSSae6begbu20nRxRPNPe+wC4z5CCt1/
EnVfDpv0fWbkFBqa+yj8rrvjmkPUyb5BGKxoQSPKCjXYPybNpr2qOFg3N05bDDcB
eLA3dZdWgDvyBQSEeLbfuZvxFQ39INB5fQbnMEz9SGUaICb707OewFHp8LYLwnJG
BwbZyFMZUfCx4ZAHuybueMpwZfwLbIguR9AnUDPf/ZWI5cfHYduhIqhHTA9Mz1E1
cfJT9xZboXuJtSSBp/gm/yp3zROBEGV8kQF0iC40bzr2HOAhDA4uCWxPRGgBtJsb
ATZfisRU2yg=
=j4cC
-----END PGP SIGNATURE-----

--
RHSA-announce mailing list
This email address is being protected from spambots. You need JavaScript enabled to view it.
https://listman.redhat.com/mailman/listinfo/rhsa-announce

Advisories

LinuxSecurity Poll

How frequently do you patch/update your system?

No answer selected. Please try again.
Please select either existing option or enter your own, however not both.
Please select minimum 0 answer(s) and maximum 3 answer(s).
/main-polls/52-how-frequently-do-you-patch-update-your-system?task=poll.vote&format=json
52
radio
[{"id":"179","title":"As soon as patches\/updates are released - I track advisories for my distro(s) diligently","votes":"42","type":"x","order":"1","pct":84,"resources":[]},{"id":"180","title":"Every so often, when I think of it","votes":"4","type":"x","order":"2","pct":8,"resources":[]},{"id":"181","title":"Hardly ever","votes":"4","type":"x","order":"3","pct":8,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350

Please vote first in order to view vote results.

VOTE ON THE POLL PAGE


VIEW MORE POLLS

bottom 200

Please enable / Bitte aktiviere JavaScript!
Veuillez activer / Por favor activa el Javascript![ ? ]

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.