SciLinux: Important: ruby on SL7.x x86_64

    Date15 May 2019
    292
    Posted ByLinuxSecurity Advisories
    rubygems: Installing a malicious gem may lead to arbitrary code execution (CVE-2019-8324) * rubygems: Escape sequence injection vulnerability in gem owner (CVE-2019-8322) * rubygems: Escape sequence injection vulnerability in API response handling (CVE-2019-8323) * rubygems: Escape sequence injection vulnerability in errors (CVE-2019-8325) SL7 x86_64 ruby-2.0.0.648-35.el7_6.x86_64.rp [More...]
    Synopsis: Important: ruby security update
    Advisory ID:       SLSA-2019:1235-1
    Issue Date:        2019-05-15
    CVE Numbers:       CVE-2019-8322
                       CVE-2019-8323
                       CVE-2019-8324
                       CVE-2019-8325
    --
    
    Security Fix(es):
    
    * rubygems: Installing a malicious gem may lead to arbitrary code
    execution (CVE-2019-8324)
    
    * rubygems: Escape sequence injection vulnerability in gem owner
    (CVE-2019-8322)
    
    * rubygems: Escape sequence injection vulnerability in API response
    handling (CVE-2019-8323)
    
    * rubygems: Escape sequence injection vulnerability in errors
    (CVE-2019-8325)
    --
    
    SL7
      x86_64
        ruby-2.0.0.648-35.el7_6.x86_64.rpm
        ruby-debuginfo-2.0.0.648-35.el7_6.i686.rpm
        ruby-debuginfo-2.0.0.648-35.el7_6.x86_64.rpm
        ruby-libs-2.0.0.648-35.el7_6.i686.rpm
        ruby-libs-2.0.0.648-35.el7_6.x86_64.rpm
        rubygem-bigdecimal-1.2.0-35.el7_6.x86_64.rpm
        rubygem-io-console-0.4.2-35.el7_6.x86_64.rpm
        rubygem-json-1.7.7-35.el7_6.x86_64.rpm
        rubygem-psych-2.0.0-35.el7_6.x86_64.rpm
        ruby-devel-2.0.0.648-35.el7_6.x86_64.rpm
        ruby-tcltk-2.0.0.648-35.el7_6.x86_64.rpm
        ruby-2.0.0.648-35.el7_6.src.rpm
      noarch
        ruby-irb-2.0.0.648-35.el7_6.noarch.rpm
        rubygem-rdoc-4.0.0-35.el7_6.noarch.rpm
        rubygems-2.0.14.1-35.el7_6.noarch.rpm
        ruby-doc-2.0.0.648-35.el7_6.noarch.rpm
        rubygem-minitest-4.3.2-35.el7_6.noarch.rpm
        rubygem-rake-0.9.6-35.el7_6.noarch.rpm
        rubygems-devel-2.0.14.1-35.el7_6.noarch.rpm
    
    - Scientific Linux Development Team
    
    You are not authorised to post comments.

    LinuxSecurity Poll

    What is your favorite LinuxSecurity.com feature?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /component/communitypolls/?task=poll.vote&format=json
    17
    radio
    [{"id":"65","title":"Feature articles","votes":"0","type":"x","order":"1","pct":0,"resources":[]},{"id":"66","title":"News","votes":"1","type":"x","order":"2","pct":33.33,"resources":[]},{"id":"67","title":"HOWTOs","votes":"2","type":"x","order":"3","pct":66.67,"resources":[]}]["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"]["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"]350
    bottom200

    Advisories

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.