SUSE: 2019:0688-1 moderate: wireshark

    Date21 Mar 2019
    CategorySuSE
    363
    Posted ByLinuxSecurity Advisories
    An update that fixes three vulnerabilities is now available.
    
       SUSE Security Update: Security update for wireshark
    ______________________________________________________________________________
    
    Announcement ID:    SUSE-SU-2019:0688-1
    Rating:             moderate
    References:         #1127367 #1127369 #1127370 
    Cross-References:   CVE-2019-9208 CVE-2019-9209 CVE-2019-9214
                       
    Affected Products:
                        SUSE Linux Enterprise Software Development Kit 12-SP4
                        SUSE Linux Enterprise Software Development Kit 12-SP3
                        SUSE Linux Enterprise Server 12-SP4
                        SUSE Linux Enterprise Server 12-SP3
                        SUSE Linux Enterprise Desktop 12-SP4
                        SUSE Linux Enterprise Desktop 12-SP3
    ______________________________________________________________________________
    
       An update that fixes three vulnerabilities is now available.
    
    Description:
    
       This update for wireshark to version 2.4.13 fixes the following issues:
    
       Security issues fixed:
    
       - CVE-2019-9214: Avoided a dereference of a null coversation which could
         make RPCAP dissector crash (bsc#1127367).
       - CVE-2019-9209: Fixed a buffer overflow in time values which could make
         ASN.1 BER and related dissectors crash (bsc#1127369).
       - CVE-2019-9208: Fixed a null pointer dereference which could make TCAP
         dissector crash (bsc#1127370).
    
       Release notes:
       https://www.wireshark.org/docs/relnotes/wireshark-2.4.13.html
    
    
    Patch Instructions:
    
       To install this SUSE Security Update use the SUSE recommended installation methods
       like YaST online_update or "zypper patch".
    
       Alternatively you can run the command listed for your product:
    
       - SUSE Linux Enterprise Software Development Kit 12-SP4:
    
          zypper in -t patch SUSE-SLE-SDK-12-SP4-2019-688=1
    
       - SUSE Linux Enterprise Software Development Kit 12-SP3:
    
          zypper in -t patch SUSE-SLE-SDK-12-SP3-2019-688=1
    
       - SUSE Linux Enterprise Server 12-SP4:
    
          zypper in -t patch SUSE-SLE-SERVER-12-SP4-2019-688=1
    
       - SUSE Linux Enterprise Server 12-SP3:
    
          zypper in -t patch SUSE-SLE-SERVER-12-SP3-2019-688=1
    
       - SUSE Linux Enterprise Desktop 12-SP4:
    
          zypper in -t patch SUSE-SLE-DESKTOP-12-SP4-2019-688=1
    
       - SUSE Linux Enterprise Desktop 12-SP3:
    
          zypper in -t patch SUSE-SLE-DESKTOP-12-SP3-2019-688=1
    
    
    
    Package List:
    
       - SUSE Linux Enterprise Software Development Kit 12-SP4 (aarch64 ppc64le s390x x86_64):
    
          wireshark-debuginfo-2.4.13-48.42.1
          wireshark-debugsource-2.4.13-48.42.1
          wireshark-devel-2.4.13-48.42.1
    
       - SUSE Linux Enterprise Software Development Kit 12-SP3 (aarch64 ppc64le s390x x86_64):
    
          wireshark-debuginfo-2.4.13-48.42.1
          wireshark-debugsource-2.4.13-48.42.1
          wireshark-devel-2.4.13-48.42.1
    
       - SUSE Linux Enterprise Server 12-SP4 (aarch64 ppc64le s390x x86_64):
    
          libwireshark9-2.4.13-48.42.1
          libwireshark9-debuginfo-2.4.13-48.42.1
          libwiretap7-2.4.13-48.42.1
          libwiretap7-debuginfo-2.4.13-48.42.1
          libwscodecs1-2.4.13-48.42.1
          libwscodecs1-debuginfo-2.4.13-48.42.1
          libwsutil8-2.4.13-48.42.1
          libwsutil8-debuginfo-2.4.13-48.42.1
          wireshark-2.4.13-48.42.1
          wireshark-debuginfo-2.4.13-48.42.1
          wireshark-debugsource-2.4.13-48.42.1
          wireshark-gtk-2.4.13-48.42.1
          wireshark-gtk-debuginfo-2.4.13-48.42.1
    
       - SUSE Linux Enterprise Server 12-SP3 (aarch64 ppc64le s390x x86_64):
    
          libwireshark9-2.4.13-48.42.1
          libwireshark9-debuginfo-2.4.13-48.42.1
          libwiretap7-2.4.13-48.42.1
          libwiretap7-debuginfo-2.4.13-48.42.1
          libwscodecs1-2.4.13-48.42.1
          libwscodecs1-debuginfo-2.4.13-48.42.1
          libwsutil8-2.4.13-48.42.1
          libwsutil8-debuginfo-2.4.13-48.42.1
          wireshark-2.4.13-48.42.1
          wireshark-debuginfo-2.4.13-48.42.1
          wireshark-debugsource-2.4.13-48.42.1
          wireshark-gtk-2.4.13-48.42.1
          wireshark-gtk-debuginfo-2.4.13-48.42.1
    
       - SUSE Linux Enterprise Desktop 12-SP4 (x86_64):
    
          libwireshark9-2.4.13-48.42.1
          libwireshark9-debuginfo-2.4.13-48.42.1
          libwiretap7-2.4.13-48.42.1
          libwiretap7-debuginfo-2.4.13-48.42.1
          libwscodecs1-2.4.13-48.42.1
          libwscodecs1-debuginfo-2.4.13-48.42.1
          libwsutil8-2.4.13-48.42.1
          libwsutil8-debuginfo-2.4.13-48.42.1
          wireshark-2.4.13-48.42.1
          wireshark-debuginfo-2.4.13-48.42.1
          wireshark-debugsource-2.4.13-48.42.1
          wireshark-gtk-2.4.13-48.42.1
          wireshark-gtk-debuginfo-2.4.13-48.42.1
    
       - SUSE Linux Enterprise Desktop 12-SP3 (x86_64):
    
          libwireshark9-2.4.13-48.42.1
          libwireshark9-debuginfo-2.4.13-48.42.1
          libwiretap7-2.4.13-48.42.1
          libwiretap7-debuginfo-2.4.13-48.42.1
          libwscodecs1-2.4.13-48.42.1
          libwscodecs1-debuginfo-2.4.13-48.42.1
          libwsutil8-2.4.13-48.42.1
          libwsutil8-debuginfo-2.4.13-48.42.1
          wireshark-2.4.13-48.42.1
          wireshark-debuginfo-2.4.13-48.42.1
          wireshark-debugsource-2.4.13-48.42.1
          wireshark-gtk-2.4.13-48.42.1
          wireshark-gtk-debuginfo-2.4.13-48.42.1
    
    
    References:
    
       https://www.suse.com/security/cve/CVE-2019-9208.html
       https://www.suse.com/security/cve/CVE-2019-9209.html
       https://www.suse.com/security/cve/CVE-2019-9214.html
       https://bugzilla.suse.com/1127367
       https://bugzilla.suse.com/1127369
       https://bugzilla.suse.com/1127370
    
    _______________________________________________
    sle-security-updates mailing list
    This email address is being protected from spambots. You need JavaScript enabled to view it.
    http://lists.suse.com/mailman/listinfo/sle-security-updates
    
    You are not authorised to post comments.

    LinuxSecurity Poll

    Do you reuse passwords across multiple accounts?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 2 answer(s).
    /component/communitypolls/?task=poll.vote
    13
    radio
    [{"id":"55","title":"Yes","votes":"0","type":"x","order":"1","pct":0,"resources":[]},{"id":"56","title":"No","votes":"0","type":"x","order":"2","pct":0,"resources":[]}]["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"]["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"]350
    bottom200

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.