SUSE: 2019:1345-1 important: java-1_7_1-ibm

    Date24 May 2019
    CategorySuSE
    301
    Posted ByLinuxSecurity Advisories
    An update that fixes 5 vulnerabilities is now available.
    
       SUSE Security Update: Security update for java-1_7_1-ibm
    ______________________________________________________________________________
    
    Announcement ID:    SUSE-SU-2019:1345-1
    Rating:             important
    References:         #1132728 #1132729 #1132732 #1132734 #1134718 
                        
    Cross-References:   CVE-2019-10245 CVE-2019-2602 CVE-2019-2684
                        CVE-2019-2697 CVE-2019-2698
    Affected Products:
                        SUSE OpenStack Cloud 7
                        SUSE Linux Enterprise Software Development Kit 12-SP4
                        SUSE Linux Enterprise Software Development Kit 12-SP3
                        SUSE Linux Enterprise Server for SAP 12-SP2
                        SUSE Linux Enterprise Server for SAP 12-SP1
                        SUSE Linux Enterprise Server 12-SP4
                        SUSE Linux Enterprise Server 12-SP3
                        SUSE Linux Enterprise Server 12-SP2-LTSS
                        SUSE Linux Enterprise Server 12-SP2-BCL
                        SUSE Linux Enterprise Server 12-SP1-LTSS
                        SUSE Linux Enterprise Server 12-LTSS
                        SUSE Enterprise Storage 4
    ______________________________________________________________________________
    
       An update that fixes 5 vulnerabilities is now available.
    
    Description:
    
       This update for java-1_7_1-ibm fixes the following issues:
    
       Update to Java 7.1 Service Refresh 4 Fix Pack 45.
    
       Security issues fixed:
    
       - CVE-2019-10245: Fixed Java bytecode verifier issue causing crashes
         (bsc#1134718).
       - CVE-2019-2698: Fixed out of bounds access flaw in the 2D component
         (bsc#1132729).
       - CVE-2019-2697: Fixed flaw inside the 2D component (bsc#1132734).
       - CVE-2019-2602: Fixed flaw inside BigDecimal implementation (Component:
         Libraries) (bsc#1132728).
       - CVE-2019-2684: Fixed flaw was found in the RMI registry implementation
         (bsc#1132732).
    
    
    Patch Instructions:
    
       To install this SUSE Security Update use the SUSE recommended installation methods
       like YaST online_update or "zypper patch".
    
       Alternatively you can run the command listed for your product:
    
       - SUSE OpenStack Cloud 7:
    
          zypper in -t patch SUSE-OpenStack-Cloud-7-2019-1345=1
    
       - SUSE Linux Enterprise Software Development Kit 12-SP4:
    
          zypper in -t patch SUSE-SLE-SDK-12-SP4-2019-1345=1
    
       - SUSE Linux Enterprise Software Development Kit 12-SP3:
    
          zypper in -t patch SUSE-SLE-SDK-12-SP3-2019-1345=1
    
       - SUSE Linux Enterprise Server for SAP 12-SP2:
    
          zypper in -t patch SUSE-SLE-SAP-12-SP2-2019-1345=1
    
       - SUSE Linux Enterprise Server for SAP 12-SP1:
    
          zypper in -t patch SUSE-SLE-SAP-12-SP1-2019-1345=1
    
       - SUSE Linux Enterprise Server 12-SP4:
    
          zypper in -t patch SUSE-SLE-SERVER-12-SP4-2019-1345=1
    
       - SUSE Linux Enterprise Server 12-SP3:
    
          zypper in -t patch SUSE-SLE-SERVER-12-SP3-2019-1345=1
    
       - SUSE Linux Enterprise Server 12-SP2-LTSS:
    
          zypper in -t patch SUSE-SLE-SERVER-12-SP2-2019-1345=1
    
       - SUSE Linux Enterprise Server 12-SP2-BCL:
    
          zypper in -t patch SUSE-SLE-SERVER-12-SP2-BCL-2019-1345=1
    
       - SUSE Linux Enterprise Server 12-SP1-LTSS:
    
          zypper in -t patch SUSE-SLE-SERVER-12-SP1-2019-1345=1
    
       - SUSE Linux Enterprise Server 12-LTSS:
    
          zypper in -t patch SUSE-SLE-SERVER-12-2019-1345=1
    
       - SUSE Enterprise Storage 4:
    
          zypper in -t patch SUSE-Storage-4-2019-1345=1
    
    
    
    Package List:
    
       - SUSE OpenStack Cloud 7 (s390x x86_64):
    
          java-1_7_1-ibm-1.7.1_sr4.45-38.37.1
          java-1_7_1-ibm-devel-1.7.1_sr4.45-38.37.1
          java-1_7_1-ibm-jdbc-1.7.1_sr4.45-38.37.1
    
       - SUSE OpenStack Cloud 7 (x86_64):
    
          java-1_7_1-ibm-alsa-1.7.1_sr4.45-38.37.1
          java-1_7_1-ibm-plugin-1.7.1_sr4.45-38.37.1
    
       - SUSE Linux Enterprise Software Development Kit 12-SP4 (ppc64le s390x x86_64):
    
          java-1_7_1-ibm-devel-1.7.1_sr4.45-38.37.1
    
       - SUSE Linux Enterprise Software Development Kit 12-SP3 (ppc64le s390x x86_64):
    
          java-1_7_1-ibm-devel-1.7.1_sr4.45-38.37.1
    
       - SUSE Linux Enterprise Server for SAP 12-SP2 (ppc64le x86_64):
    
          java-1_7_1-ibm-1.7.1_sr4.45-38.37.1
          java-1_7_1-ibm-devel-1.7.1_sr4.45-38.37.1
          java-1_7_1-ibm-jdbc-1.7.1_sr4.45-38.37.1
    
       - SUSE Linux Enterprise Server for SAP 12-SP2 (x86_64):
    
          java-1_7_1-ibm-alsa-1.7.1_sr4.45-38.37.1
          java-1_7_1-ibm-plugin-1.7.1_sr4.45-38.37.1
    
       - SUSE Linux Enterprise Server for SAP 12-SP1 (x86_64):
    
          java-1_7_1-ibm-1.7.1_sr4.45-38.37.1
          java-1_7_1-ibm-alsa-1.7.1_sr4.45-38.37.1
          java-1_7_1-ibm-devel-1.7.1_sr4.45-38.37.1
          java-1_7_1-ibm-jdbc-1.7.1_sr4.45-38.37.1
          java-1_7_1-ibm-plugin-1.7.1_sr4.45-38.37.1
    
       - SUSE Linux Enterprise Server 12-SP4 (ppc64le s390x x86_64):
    
          java-1_7_1-ibm-1.7.1_sr4.45-38.37.1
          java-1_7_1-ibm-jdbc-1.7.1_sr4.45-38.37.1
    
       - SUSE Linux Enterprise Server 12-SP4 (x86_64):
    
          java-1_7_1-ibm-alsa-1.7.1_sr4.45-38.37.1
          java-1_7_1-ibm-plugin-1.7.1_sr4.45-38.37.1
    
       - SUSE Linux Enterprise Server 12-SP3 (ppc64le s390x x86_64):
    
          java-1_7_1-ibm-1.7.1_sr4.45-38.37.1
          java-1_7_1-ibm-jdbc-1.7.1_sr4.45-38.37.1
    
       - SUSE Linux Enterprise Server 12-SP3 (x86_64):
    
          java-1_7_1-ibm-alsa-1.7.1_sr4.45-38.37.1
          java-1_7_1-ibm-plugin-1.7.1_sr4.45-38.37.1
    
       - SUSE Linux Enterprise Server 12-SP2-LTSS (ppc64le s390x x86_64):
    
          java-1_7_1-ibm-1.7.1_sr4.45-38.37.1
          java-1_7_1-ibm-devel-1.7.1_sr4.45-38.37.1
          java-1_7_1-ibm-jdbc-1.7.1_sr4.45-38.37.1
    
       - SUSE Linux Enterprise Server 12-SP2-LTSS (x86_64):
    
          java-1_7_1-ibm-alsa-1.7.1_sr4.45-38.37.1
          java-1_7_1-ibm-plugin-1.7.1_sr4.45-38.37.1
    
       - SUSE Linux Enterprise Server 12-SP2-BCL (x86_64):
    
          java-1_7_1-ibm-1.7.1_sr4.45-38.37.1
          java-1_7_1-ibm-alsa-1.7.1_sr4.45-38.37.1
          java-1_7_1-ibm-devel-1.7.1_sr4.45-38.37.1
          java-1_7_1-ibm-jdbc-1.7.1_sr4.45-38.37.1
          java-1_7_1-ibm-plugin-1.7.1_sr4.45-38.37.1
    
       - SUSE Linux Enterprise Server 12-SP1-LTSS (ppc64le s390x x86_64):
    
          java-1_7_1-ibm-1.7.1_sr4.45-38.37.1
          java-1_7_1-ibm-devel-1.7.1_sr4.45-38.37.1
          java-1_7_1-ibm-jdbc-1.7.1_sr4.45-38.37.1
    
       - SUSE Linux Enterprise Server 12-SP1-LTSS (x86_64):
    
          java-1_7_1-ibm-alsa-1.7.1_sr4.45-38.37.1
          java-1_7_1-ibm-plugin-1.7.1_sr4.45-38.37.1
    
       - SUSE Linux Enterprise Server 12-LTSS (ppc64le s390x x86_64):
    
          java-1_7_1-ibm-1.7.1_sr4.45-38.37.1
          java-1_7_1-ibm-devel-1.7.1_sr4.45-38.37.1
          java-1_7_1-ibm-jdbc-1.7.1_sr4.45-38.37.1
    
       - SUSE Linux Enterprise Server 12-LTSS (x86_64):
    
          java-1_7_1-ibm-alsa-1.7.1_sr4.45-38.37.1
          java-1_7_1-ibm-plugin-1.7.1_sr4.45-38.37.1
    
       - SUSE Enterprise Storage 4 (x86_64):
    
          java-1_7_1-ibm-1.7.1_sr4.45-38.37.1
          java-1_7_1-ibm-alsa-1.7.1_sr4.45-38.37.1
          java-1_7_1-ibm-devel-1.7.1_sr4.45-38.37.1
          java-1_7_1-ibm-jdbc-1.7.1_sr4.45-38.37.1
          java-1_7_1-ibm-plugin-1.7.1_sr4.45-38.37.1
    
    
    References:
    
       https://www.suse.com/security/cve/CVE-2019-10245.html
       https://www.suse.com/security/cve/CVE-2019-2602.html
       https://www.suse.com/security/cve/CVE-2019-2684.html
       https://www.suse.com/security/cve/CVE-2019-2697.html
       https://www.suse.com/security/cve/CVE-2019-2698.html
       https://bugzilla.suse.com/1132728
       https://bugzilla.suse.com/1132729
       https://bugzilla.suse.com/1132732
       https://bugzilla.suse.com/1132734
       https://bugzilla.suse.com/1134718
    
    _______________________________________________
    sle-security-updates mailing list
    This email address is being protected from spambots. You need JavaScript enabled to view it.
    http://lists.suse.com/mailman/listinfo/sle-security-updates
    
    You are not authorised to post comments.

    Comments powered by CComment

    LinuxSecurity Poll

    Do you read our distribution advisories on a regular basis?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /component/communitypolls/?task=poll.vote&format=json
    23
    radio
    [{"id":"84","title":"Yes, for a single distribution","votes":"0","type":"x","order":"1","pct":0,"resources":[]},{"id":"85","title":"Yes, for multiple distributions","votes":"6","type":"x","order":"2","pct":60,"resources":[]},{"id":"86","title":"No","votes":"4","type":"x","order":"3","pct":40,"resources":[]}]["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"]["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"]350
    bottom200

    Advisories

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.