SUSE: 2019:1457-1 important: vim

    Date11 Jun 2019
    CategorySuSE
    465
    Posted ByLinuxSecurity Advisories
    An update that fixes one vulnerability is now available.
    
       SUSE Security Update: Security update for vim
    ______________________________________________________________________________
    
    Announcement ID:    SUSE-SU-2019:1457-1
    Rating:             important
    References:         #1137443 
    Cross-References:   CVE-2019-12735
    Affected Products:
                        SUSE Linux Enterprise Module for Desktop Applications 15-SP1
                        SUSE Linux Enterprise Module for Desktop Applications 15
                        SUSE Linux Enterprise Module for Basesystem 15-SP1
                        SUSE Linux Enterprise Module for Basesystem 15
    ______________________________________________________________________________
    
       An update that fixes one vulnerability is now available.
    
    Description:
    
       This update for vim fixes the following issue:
    
       Security issue fixed:
    
       - CVE-2019-12735: Fixed a potential arbitrary code execution vulnerability
         in getchar.c (bsc#1137443).
    
    
    Patch Instructions:
    
       To install this SUSE Security Update use the SUSE recommended installation methods
       like YaST online_update or "zypper patch".
    
       Alternatively you can run the command listed for your product:
    
       - SUSE Linux Enterprise Module for Desktop Applications 15-SP1:
    
          zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-SP1-2019-1457=1
    
       - SUSE Linux Enterprise Module for Desktop Applications 15:
    
          zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-2019-1457=1
    
       - SUSE Linux Enterprise Module for Basesystem 15-SP1:
    
          zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP1-2019-1457=1
    
       - SUSE Linux Enterprise Module for Basesystem 15:
    
          zypper in -t patch SUSE-SLE-Module-Basesystem-15-2019-1457=1
    
    
    
    Package List:
    
       - SUSE Linux Enterprise Module for Desktop Applications 15-SP1 (aarch64 ppc64le s390x x86_64):
    
          gvim-8.0.1568-5.3.1
          gvim-debuginfo-8.0.1568-5.3.1
          vim-debuginfo-8.0.1568-5.3.1
          vim-debugsource-8.0.1568-5.3.1
    
       - SUSE Linux Enterprise Module for Desktop Applications 15 (aarch64 ppc64le s390x x86_64):
    
          gvim-8.0.1568-5.3.1
          gvim-debuginfo-8.0.1568-5.3.1
          vim-debuginfo-8.0.1568-5.3.1
          vim-debugsource-8.0.1568-5.3.1
    
       - SUSE Linux Enterprise Module for Basesystem 15-SP1 (aarch64 ppc64le s390x x86_64):
    
          vim-8.0.1568-5.3.1
          vim-debuginfo-8.0.1568-5.3.1
          vim-debugsource-8.0.1568-5.3.1
    
       - SUSE Linux Enterprise Module for Basesystem 15-SP1 (noarch):
    
          vim-data-8.0.1568-5.3.1
          vim-data-common-8.0.1568-5.3.1
    
       - SUSE Linux Enterprise Module for Basesystem 15 (aarch64 ppc64le s390x x86_64):
    
          vim-8.0.1568-5.3.1
          vim-debuginfo-8.0.1568-5.3.1
          vim-debugsource-8.0.1568-5.3.1
    
       - SUSE Linux Enterprise Module for Basesystem 15 (noarch):
    
          vim-data-8.0.1568-5.3.1
          vim-data-common-8.0.1568-5.3.1
    
    
    References:
    
       https://www.suse.com/security/cve/CVE-2019-12735.html
       https://bugzilla.suse.com/1137443
    
    _______________________________________________
    sle-security-updates mailing list
    This email address is being protected from spambots. You need JavaScript enabled to view it.
    http://lists.suse.com/mailman/listinfo/sle-security-updates
    
    You are not authorised to post comments.

    Comments powered by CComment

    LinuxSecurity Poll

    What do you think of the articles on LinuxSecurity?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/24-what-do-you-think-of-the-quality-of-the-articles-on-linuxsecurity?task=poll.vote&format=json
    24
    radio
    [{"id":"87","title":"Excellent, don't change a thing!","votes":"4","type":"x","order":"1","pct":57.14,"resources":[]},{"id":"88","title":"Should be more technical","votes":"2","type":"x","order":"2","pct":28.57,"resources":[]},{"id":"89","title":"Should include more HOWTOs","votes":"1","type":"x","order":"3","pct":14.29,"resources":[]}]["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"]["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"]350
    bottom200

    Advisories

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.