SUSE: 2019:1547-1 important: libvirt

    Date18 Jun 2019
    CategorySuSE
    431
    Posted ByLinuxSecurity Advisories
    An update that fixes four vulnerabilities is now available.
    
       SUSE Security Update: Security update for libvirt
    ______________________________________________________________________________
    
    Announcement ID:    SUSE-SU-2019:1547-1
    Rating:             important
    References:         #1111331 #1135273 
    Cross-References:   CVE-2018-12126 CVE-2018-12127 CVE-2018-12130
                        CVE-2019-11091
    Affected Products:
                        SUSE Linux Enterprise Software Development Kit 12-SP3
                        SUSE Linux Enterprise Server 12-SP3
                        SUSE Linux Enterprise Desktop 12-SP3
    ______________________________________________________________________________
    
       An update that fixes four vulnerabilities is now available.
    
    Description:
    
       This update for libvirt fixes the following issues:
    
       Four new speculative execution information leak issu Store Buffer Data Sampling (MSBDS)
       - CVE-2018-12127: Microarchitectural Fill Buffer Data Sampling (MFBDS)
       - CVE-2018-12130: Microarchitectural Load Port Data Sampling (MLPDS)
       - CVE-2019-11091: Microarchitectural Data Sampling Uncacheable Memory
         (MDSUM)
    
       These updates contain the libvirt adjustments, that pass through the new
       'md-clear' CPU flag (bsc#1135273).
    
       For more information on this set of vulnerabilities, check out
       https://www.suse.com/support/kb/doc/?id=7023736
    
    
    Patch Instructions:
    
       To install this SUSE Security Update use the SUSE recommended installation methods
       like YaST online_update or "zypper patch".
    
       Alternatively you can run the command listed for your product:
    
       - SUSE Linux Enterprise Software Development Kit 12-SP3:
    
          zypper in -t patch SUSE-SLE-SDK-12-SP3-2019-1547=1
    
       - SUSE Linux Enterprise Server 12-SP3:
    
          zypper in -t patch SUSE-SLE-SERVER-12-SP3-2019-1547=1
    
       - SUSE Linux Enterprise Desktop 12-SP3:
    
          zypper in -t patch SUSE-SLE-DESKTOP-12-SP3-2019-1547=1
    
    
    
    Package List:
    
       - SUSE Linux Enterprise Software Development Kit 12-SP3 (aarch64 ppc64le s390x x86_64):
    
          libvirt-debugsource-3.3.0-5.33.2
          libvirt-devel-3.3.0-5.33.2
    
       - SUSE Linux Enterprise Server 12-SP3 (aarch64 ppc64le s390x x86_64):
    
          libvirt-3.3.0-5.33.2
          libvirt-admin-3.3.0-5.33.2
          libvirt-admin-debuginfo-3.3.0-5.33.2
          libvirt-client-3.3.0-5.33.2
          libvirt-client-debuginfo-3.3.0-5.33.2
          libvirt-daemon-3.3.0-5.33.2
          libvirt-daemon-config-network-3.3.0-5.33.2
          libvirt-daemon-config-nwfilter-3.3.0-5.33.2
          libvirt-daemon-debuginfo-3.3.0-5.33.2
          libvirt-daemon-driver-interface-3.3.0-5.33.2
          libvirt-daemon-driver-interface-debuginfo-3.3.0-5.33.2
          libvirt-daemon-driver-lxc-3.3.0-5.33.2
          libvirt-daemon-driver-lxc-debuginfo-3.3.0-5.33.2
          libvirt-daemon-driver-network-3.3.0-5.33.2
          libvirt-daemon-driver-network-debuginfo-3.3.0-5.33.2
          libvirt-daemon-driver-nodedev-3.3.0-5.33.2
          libvirt-daemon-driver-nodedev-debuginfo-3.3.0-5.33.2
          libvirt-daemon-driver-nwfilter-3.3.0-5.33.2
          libvirt-daemon-driver-nwfilter-debuginfo-3.3.0-5.33.2
          libvirt-daemon-driver-qemu-3.3.0-5.33.2
          libvirt-daemon-driver-qemu-debuginfo-3.3.0-5.33.2
          libvirt-daemon-driver-secret-3.3.0-5.33.2
          libvirt-daemon-driver-secret-debuginfo-3.3.0-5.33.2
          libvirt-daemon-driver-storage-3.3.0-5.33.2
          libvirt-daemon-driver-storage-core-3.3.0-5.33.2
          libvirt-daemon-driver-storage-core-debuginfo-3.3.0-5.33.2
          libvirt-daemon-driver-storage-disk-3.3.0-5.33.2
          libvirt-daemon-driver-storage-disk-debuginfo-3.3.0-5.33.2
          libvirt-daemon-driver-storage-iscsi-3.3.0-5.33.2
          libvirt-daemon-driver-storage-iscsi-debuginfo-3.3.0-5.33.2
          libvirt-daemon-driver-storage-logical-3.3.0-5.33.2
          libvirt-daemon-driver-storage-logical-debuginfo-3.3.0-5.33.2
          libvirt-daemon-driver-storage-mpath-3.3.0-5.33.2
          libvirt-daemon-driver-storage-mpath-debuginfo-3.3.0-5.33.2
          libvirt-daemon-driver-storage-scsi-3.3.0-5.33.2
          libvirt-daemon-driver-storage-scsi-debuginfo-3.3.0-5.33.2
          libvirt-daemon-hooks-3.3.0-5.33.2
          libvirt-daemon-lxc-3.3.0-5.33.2
          libvirt-daemon-qemu-3.3.0-5.33.2
          libvirt-debugsource-3.3.0-5.33.2
          libvirt-doc-3.3.0-5.33.2
          libvirt-libs-3.3.0-5.33.2
          libvirt-libs-debuginfo-3.3.0-5.33.2
          libvirt-lock-sanlock-3.3.0-5.33.2
          libvirt-lock-sanlock-debuginfo-3.3.0-5.33.2
          libvirt-nss-3.3.0-5.33.2
          libvirt-nss-debuginfo-3.3.0-5.33.2
    
       - SUSE Linux Enterprise Server 12-SP3 (aarch64 x86_64):
    
          libvirt-daemon-driver-storage-rbd-3.3.0-5.33.2
          libvirt-daemon-driver-storage-rbd-debuginfo-3.3.0-5.33.2
    
       - SUSE Linux Enterprise Server 12-SP3 (x86_64):
    
          libvirt-daemon-driver-libxl-3.3.0-5.33.2
          libvirt-daemon-driver-libxl-debuginfo-3.3.0-5.33.2
          libvirt-daemon-xen-3.3.0-5.33.2
    
       - SUSE Linux Enterprise Desktop 12-SP3 (x86_64):
    
          libvirt-3.3.0-5.33.2
          libvirt-admin-3.3.0-5.33.2
          libvirt-admin-debuginfo-3.3.0-5.33.2
          libvirt-client-3.3.0-5.33.2
          libvirt-client-debuginfo-3.3.0-5.33.2
          libvirt-daemon-3.3.0-5.33.2
          libvirt-daemon-config-network-3.3.0-5.33.2
          libvirt-daemon-config-nwfilter-3.3.0-5.33.2
          libvirt-daemon-debuginfo-3.3.0-5.33.2
          libvirt-daemon-driver-interface-3.3.0-5.33.2
          libvirt-daemon-driver-interface-debuginfo-3.3.0-5.33.2
          libvirt-daemon-driver-libxl-3.3.0-5.33.2
          libvirt-daemon-driver-libxl-debuginfo-3.3.0-5.33.2
          libvirt-daemon-driver-lxc-3.3.0-5.33.2
          libvirt-daemon-driver-lxc-debuginfo-3.3.0-5.33.2
          libvirt-daemon-driver-network-3.3.0-5.33.2
          libvirt-daemon-driver-network-debuginfo-3.3.0-5.33.2
          libvirt-daemon-driver-nodedev-3.3.0-5.33.2
          libvirt-daemon-driver-nodedev-debuginfo-3.3.0-5.33.2
          libvirt-daemon-driver-nwfilter-3.3.0-5.33.2
          libvirt-daemon-driver-nwfilter-debuginfo-3.3.0-5.33.2
          libvirt-daemon-driver-qemu-3.3.0-5.33.2
          libvirt-daemon-driver-qemu-debuginfo-3.3.0-5.33.2
          libvirt-daemon-driver-secret-3.3.0-5.33.2
          libvirt-daemon-driver-secret-debuginfo-3.3.0-5.33.2
          libvirt-daemon-driver-storage-3.3.0-5.33.2
          libvirt-daemon-driver-storage-core-3.3.0-5.33.2
          libvirt-daemon-driver-storage-core-debuginfo-3.3.0-5.33.2
          libvirt-daemon-driver-storage-disk-3.3.0-5.33.2
          libvirt-daemon-driver-storage-disk-debuginfo-3.3.0-5.33.2
          libvirt-daemon-driver-storage-iscsi-3.3.0-5.33.2
          libvirt-daemon-driver-storage-iscsi-debuginfo-3.3.0-5.33.2
          libvirt-daemon-driver-storage-logical-3.3.0-5.33.2
          libvirt-daemon-driver-storage-logical-debuginfo-3.3.0-5.33.2
          libvirt-daemon-driver-storage-mpath-3.3.0-5.33.2
          libvirt-daemon-driver-storage-mpath-debuginfo-3.3.0-5.33.2
          libvirt-daemon-driver-storage-rbd-3.3.0-5.33.2
          libvirt-daemon-driver-storage-rbd-debuginfo-3.3.0-5.33.2
          libvirt-daemon-driver-storage-scsi-3.3.0-5.33.2
          libvirt-daemon-driver-storage-scsi-debuginfo-3.3.0-5.33.2
          libvirt-daemon-lxc-3.3.0-5.33.2
          libvirt-daemon-qemu-3.3.0-5.33.2
          libvirt-daemon-xen-3.3.0-5.33.2
          libvirt-debugsource-3.3.0-5.33.2
          libvirt-doc-3.3.0-5.33.2
          libvirt-libs-3.3.0-5.33.2
          libvirt-libs-debuginfo-3.3.0-5.33.2
    
    
    References:
    
       https://www.suse.com/security/cve/CVE-2018-12126.html
       https://www.suse.com/security/cve/CVE-2018-12127.html
       https://www.suse.com/security/cve/CVE-2018-12130.html
       https://www.suse.com/security/cve/CVE-2019-11091.html
       https://bugzilla.suse.com/1111331
       https://bugzilla.suse.com/1135273
    
    _______________________________________________
    sle-security-updates mailing list
    This email address is being protected from spambots. You need JavaScript enabled to view it.
    http://lists.suse.com/mailman/listinfo/sle-security-updates
    
    You are not authorised to post comments.

    Comments powered by CComment

    LinuxSecurity Poll

    Do you read our distribution advisories on a regular basis?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /component/communitypolls/?task=poll.vote&format=json
    23
    radio
    [{"id":"84","title":"Yes, for a single distribution","votes":"0","type":"x","order":"1","pct":0,"resources":[]},{"id":"85","title":"Yes, for multiple distributions","votes":"5","type":"x","order":"2","pct":62.5,"resources":[]},{"id":"86","title":"No","votes":"3","type":"x","order":"3","pct":37.5,"resources":[]}]["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"]["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"]350
    bottom200

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.