SUSE: 2019:2971-1 important: libjpeg-turbo

    Date14 Nov 2019
    CategorySuSE
    115
    Posted ByLinuxSecurity Advisories
    An update that fixes one vulnerability is now available.
    
       SUSE Security Update: Security update for libjpeg-turbo
    ______________________________________________________________________________
    
    Announcement ID:    SUSE-SU-2019:2971-1
    Rating:             important
    References:         #1156402 
    Cross-References:   CVE-2019-2201
    Affected Products:
                        SUSE Linux Enterprise Module for Packagehub Subpackages 15
                        SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1
                        SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
                        SUSE Linux Enterprise Module for Desktop Applications 15-SP1
                        SUSE Linux Enterprise Module for Desktop Applications 15
                        SUSE Linux Enterprise Module for Basesystem 15-SP1
                        SUSE Linux Enterprise Module for Basesystem 15
    ______________________________________________________________________________
    
       An update that fixes one vulnerability is now available.
    
    Description:
    
       This update for libjpeg-turbo fixes the following issues:
    
       - CVE-2019-2201: Several integer overflow issues and subsequent segfaults
         occurred in libjpeg-turbo, when attempting to compress or decompress
         gigapixel images. [bsc#1156402]
    
    
    Patch Instructions:
    
       To install this SUSE Security Update use the SUSE recommended installation methods
       like YaST online_update or "zypper patch".
    
       Alternatively you can run the command listed for your product:
    
       - SUSE Linux Enterprise Module for Packagehub Subpackages 15:
    
          zypper in -t patch SUSE-SLE-Module-Packagehub-Subpackages-15-2019-2971=1
    
       - SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1:
    
          zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-2971=1
    
       - SUSE Linux Enterprise Module for Open Buildservice Development Tools 15:
    
          zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-2019-2971=1
    
       - SUSE Linux Enterprise Module for Desktop Applications 15-SP1:
    
          zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-SP1-2019-2971=1
    
       - SUSE Linux Enterprise Module for Desktop Applications 15:
    
          zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-2019-2971=1
    
       - SUSE Linux Enterprise Module for Basesystem 15-SP1:
    
          zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP1-2019-2971=1
    
       - SUSE Linux Enterprise Module for Basesystem 15:
    
          zypper in -t patch SUSE-SLE-Module-Basesystem-15-2019-2971=1
    
    
    
    Package List:
    
       - SUSE Linux Enterprise Module for Packagehub Subpackages 15 (aarch64 ppc64le s390x x86_64):
    
          libjpeg-turbo-1.5.3-5.12.1
          libjpeg-turbo-debuginfo-1.5.3-5.12.1
          libjpeg-turbo-debugsource-1.5.3-5.12.1
    
       - SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1 (aarch64 ppc64le s390x x86_64):
    
          libjpeg-turbo-1.5.3-5.12.1
          libjpeg-turbo-debuginfo-1.5.3-5.12.1
          libjpeg-turbo-debugsource-1.5.3-5.12.1
          libjpeg62-turbo-1.5.3-5.12.1
          libjpeg62-turbo-debugsource-1.5.3-5.12.1
    
       - SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1 (x86_64):
    
          libjpeg62-32bit-62.2.0-5.12.1
          libjpeg62-32bit-debuginfo-62.2.0-5.12.1
          libjpeg62-devel-32bit-62.2.0-5.12.1
          libjpeg8-devel-32bit-8.1.2-5.12.1
          libturbojpeg0-32bit-8.1.2-5.12.1
          libturbojpeg0-32bit-debuginfo-8.1.2-5.12.1
    
       - SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (aarch64 ppc64le s390x x86_64):
    
          libjpeg-turbo-1.5.3-5.12.1
          libjpeg-turbo-debuginfo-1.5.3-5.12.1
          libjpeg-turbo-debugsource-1.5.3-5.12.1
          libjpeg62-turbo-1.5.3-5.12.1
          libjpeg62-turbo-debugsource-1.5.3-5.12.1
    
       - SUSE Linux Enterprise Module for Desktop Applications 15-SP1 (x86_64):
    
          libjpeg8-32bit-8.1.2-5.12.1
          libjpeg8-32bit-debuginfo-8.1.2-5.12.1
    
       - SUSE Linux Enterprise Module for Desktop Applications 15 (x86_64):
    
          libjpeg8-32bit-8.1.2-5.12.1
          libjpeg8-32bit-debuginfo-8.1.2-5.12.1
    
       - SUSE Linux Enterprise Module for Basesystem 15-SP1 (aarch64 ppc64le s390x x86_64):
    
          libjpeg62-62.2.0-5.12.1
          libjpeg62-debuginfo-62.2.0-5.12.1
          libjpeg62-devel-62.2.0-5.12.1
          libjpeg8-8.1.2-5.12.1
          libjpeg8-debuginfo-8.1.2-5.12.1
          libjpeg8-devel-8.1.2-5.12.1
          libturbojpeg0-8.1.2-5.12.1
          libturbojpeg0-debuginfo-8.1.2-5.12.1
    
       - SUSE Linux Enterprise Module for Basesystem 15 (aarch64 ppc64le s390x x86_64):
    
          libjpeg62-62.2.0-5.12.1
          libjpeg62-debuginfo-62.2.0-5.12.1
          libjpeg62-devel-62.2.0-5.12.1
          libjpeg8-8.1.2-5.12.1
          libjpeg8-debuginfo-8.1.2-5.12.1
          libjpeg8-devel-8.1.2-5.12.1
          libturbojpeg0-8.1.2-5.12.1
          libturbojpeg0-debuginfo-8.1.2-5.12.1
    
    
    References:
    
       https://www.suse.com/security/cve/CVE-2019-2201.html
       https://bugzilla.suse.com/1156402
    
    _______________________________________________
    sle-security-updates mailing list
    This email address is being protected from spambots. You need JavaScript enabled to view it.
    http://lists.suse.com/mailman/listinfo/sle-security-updates
    
    You are not authorised to post comments.

    Comments powered by CComment

    LinuxSecurity Poll

    What do you think of the articles on LinuxSecurity?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/24-what-do-you-think-of-the-quality-of-the-articles-on-linuxsecurity?task=poll.vote&format=json
    24
    radio
    [{"id":"87","title":"Excellent, don't change a thing!","votes":"65","type":"x","order":"1","pct":57.52,"resources":[]},{"id":"88","title":"Should be more technical","votes":"15","type":"x","order":"2","pct":13.27,"resources":[]},{"id":"89","title":"Should include more HOWTOs","votes":"33","type":"x","order":"3","pct":29.2,"resources":[]}]["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"]["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"]350
    bottom200

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.