Linux Security
    Linux Security
    Linux Security

    SUSE: 2020:2237-1 important: libvirt

    Date
    222
    Posted By
    An update that solves one vulnerability and has four fixes is now available.
    
       SUSE Security Update: Security update for libvirt
    ______________________________________________________________________________
    
    Announcement ID:    SUSE-SU-2020:2237-1
    Rating:             important
    References:         #1161883 #1167007 #1171946 #1172052 #1174458 
                        
    Cross-References:   CVE-2020-14339
    Affected Products:
                        SUSE Linux Enterprise Module for Server Applications 15-SP1
                        SUSE Linux Enterprise Module for Basesystem 15-SP1
    ______________________________________________________________________________
    
       An update that solves one vulnerability and has four fixes
       is now available.
    
    Description:
    
       This update for libvirt fixes the following issues:
    
       - CVE-2020-14339: Don't leak /dev/mapper/control into QEMU. Use ioctl's to
         obtain the dependency tree of disks and drop use of libdevmapper. -
         bsc#1161883, bsc#1174458
       - qemu: Setup emulator thread and cpuset.mems before exec - bsc#1171946
       - libxl: Normalize MAC address in device conf on netdev hotplug -
         bsc#1172052
       - spec: Use a functional requires instead of explicit version requires for
         the new memory-related libxl APIs - bsc#1167007
    
    
    Patch Instructions:
    
       To install this SUSE Security Update use the SUSE recommended installation methods
       like YaST online_update or "zypper patch".
    
       Alternatively you can run the command listed for your product:
    
       - SUSE Linux Enterprise Module for Server Applications 15-SP1:
    
          zypper in -t patch SUSE-SLE-Module-Server-Applications-15-SP1-2020-2237=1
    
       - SUSE Linux Enterprise Module for Basesystem 15-SP1:
    
          zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP1-2020-2237=1
    
    
    
    Package List:
    
       - SUSE Linux Enterprise Module for Server Applications 15-SP1 (aarch64 ppc64le s390x x86_64):
    
          libvirt-5.1.0-8.19.1
          libvirt-admin-5.1.0-8.19.1
          libvirt-admin-debuginfo-5.1.0-8.19.1
          libvirt-client-5.1.0-8.19.1
          libvirt-client-debuginfo-5.1.0-8.19.1
          libvirt-daemon-5.1.0-8.19.1
          libvirt-daemon-config-network-5.1.0-8.19.1
          libvirt-daemon-config-nwfilter-5.1.0-8.19.1
          libvirt-daemon-debuginfo-5.1.0-8.19.1
          libvirt-daemon-driver-interface-5.1.0-8.19.1
          libvirt-daemon-driver-interface-debuginfo-5.1.0-8.19.1
          libvirt-daemon-driver-lxc-5.1.0-8.19.1
          libvirt-daemon-driver-lxc-debuginfo-5.1.0-8.19.1
          libvirt-daemon-driver-network-5.1.0-8.19.1
          libvirt-daemon-driver-network-debuginfo-5.1.0-8.19.1
          libvirt-daemon-driver-nodedev-5.1.0-8.19.1
          libvirt-daemon-driver-nodedev-debuginfo-5.1.0-8.19.1
          libvirt-daemon-driver-nwfilter-5.1.0-8.19.1
          libvirt-daemon-driver-nwfilter-debuginfo-5.1.0-8.19.1
          libvirt-daemon-driver-qemu-5.1.0-8.19.1
          libvirt-daemon-driver-qemu-debuginfo-5.1.0-8.19.1
          libvirt-daemon-driver-secret-5.1.0-8.19.1
          libvirt-daemon-driver-secret-debuginfo-5.1.0-8.19.1
          libvirt-daemon-driver-storage-5.1.0-8.19.1
          libvirt-daemon-driver-storage-core-5.1.0-8.19.1
          libvirt-daemon-driver-storage-core-debuginfo-5.1.0-8.19.1
          libvirt-daemon-driver-storage-disk-5.1.0-8.19.1
          libvirt-daemon-driver-storage-disk-debuginfo-5.1.0-8.19.1
          libvirt-daemon-driver-storage-iscsi-5.1.0-8.19.1
          libvirt-daemon-driver-storage-iscsi-debuginfo-5.1.0-8.19.1
          libvirt-daemon-driver-storage-logical-5.1.0-8.19.1
          libvirt-daemon-driver-storage-logical-debuginfo-5.1.0-8.19.1
          libvirt-daemon-driver-storage-mpath-5.1.0-8.19.1
          libvirt-daemon-driver-storage-mpath-debuginfo-5.1.0-8.19.1
          libvirt-daemon-driver-storage-scsi-5.1.0-8.19.1
          libvirt-daemon-driver-storage-scsi-debuginfo-5.1.0-8.19.1
          libvirt-daemon-hooks-5.1.0-8.19.1
          libvirt-daemon-lxc-5.1.0-8.19.1
          libvirt-daemon-qemu-5.1.0-8.19.1
          libvirt-debugsource-5.1.0-8.19.1
          libvirt-devel-5.1.0-8.19.1
          libvirt-lock-sanlock-5.1.0-8.19.1
          libvirt-lock-sanlock-debuginfo-5.1.0-8.19.1
          libvirt-nss-5.1.0-8.19.1
          libvirt-nss-debuginfo-5.1.0-8.19.1
    
       - SUSE Linux Enterprise Module for Server Applications 15-SP1 (aarch64 x86_64):
    
          libvirt-daemon-driver-storage-rbd-5.1.0-8.19.1
          libvirt-daemon-driver-storage-rbd-debuginfo-5.1.0-8.19.1
    
       - SUSE Linux Enterprise Module for Server Applications 15-SP1 (noarch):
    
          libvirt-bash-completion-5.1.0-8.19.1
          libvirt-doc-5.1.0-8.19.1
    
       - SUSE Linux Enterprise Module for Server Applications 15-SP1 (x86_64):
    
          libvirt-daemon-driver-libxl-5.1.0-8.19.1
          libvirt-daemon-driver-libxl-debuginfo-5.1.0-8.19.1
          libvirt-daemon-xen-5.1.0-8.19.1
    
       - SUSE Linux Enterprise Module for Basesystem 15-SP1 (aarch64 ppc64le s390x x86_64):
    
          libvirt-debugsource-5.1.0-8.19.1
          libvirt-libs-5.1.0-8.19.1
          libvirt-libs-debuginfo-5.1.0-8.19.1
    
    
    References:
    
       https://www.suse.com/security/cve/CVE-2020-14339.html
       https://bugzilla.suse.com/1161883
       https://bugzilla.suse.com/1167007
       https://bugzilla.suse.com/1171946
       https://bugzilla.suse.com/1172052
       https://bugzilla.suse.com/1174458
    
    _______________________________________________
    sle-security-updates mailing list
    This email address is being protected from spambots. You need JavaScript enabled to view it.
    https://lists.suse.com/mailman/listinfo/sle-security-updates
    

    Advisories

    LinuxSecurity Poll

    How are you contributing to Open Source?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 4 answer(s).
    /main-polls/37-how-are-you-contributing-to-open-source?task=poll.vote&format=json
    37
    radio
    [{"id":"127","title":"I'm involved with the development of an open-source project(s).","votes":"2","type":"x","order":"1","pct":100,"resources":[]},{"id":"128","title":"I've reported vulnerabilities I've discovered in open-source code.","votes":"0","type":"x","order":"2","pct":0,"resources":[]},{"id":"129","title":"I've provided developers with feedback on their projects.","votes":"0","type":"x","order":"3","pct":0,"resources":[]},{"id":"130","title":"I've helped another community member get started contributing to Open Source.","votes":"0","type":"x","order":"4","pct":0,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350


    VIEW MORE POLLS

    bottom 200

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.