Linux Security
    Linux Security
    Linux Security

    SUSE: 2020:2645-1 important: perl-DBI

    Date
    115
    Posted By
    An update that fixes two vulnerabilities is now available.
    
       SUSE Security Update: Security update for perl-DBI
    ______________________________________________________________________________
    
    Announcement ID:    SUSE-SU-2020:2645-1
    Rating:             important
    References:         #1176409 #1176412 
    Cross-References:   CVE-2020-14392 CVE-2020-14393
    Affected Products:
                        SUSE Linux Enterprise Server for SAP 15
                        SUSE Linux Enterprise Server 15-LTSS
                        SUSE Linux Enterprise Module for Basesystem 15-SP1
                        SUSE Linux Enterprise High Performance Computing 15-LTSS
                        SUSE Linux Enterprise High Performance Computing 15-ESPOS
    ______________________________________________________________________________
    
       An update that fixes two vulnerabilities is now available.
    
    Description:
    
       This update for perl-DBI fixes the following issues:
    
       Security issues fixed:
    
       - CVE-2020-14392: Memory corruption in XS functions when Perl stack is
         reallocated (bsc#1176412).
       - CVE-2020-14393: Fixed a buffer overflow on an overlong DBD class name
         (bsc#1176409).
    
    
    Patch Instructions:
    
       To install this SUSE Security Update use the SUSE recommended installation methods
       like YaST online_update or "zypper patch".
    
       Alternatively you can run the command listed for your product:
    
       - SUSE Linux Enterprise Server for SAP 15:
    
          zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-2020-2645=1
    
       - SUSE Linux Enterprise Server 15-LTSS:
    
          zypper in -t patch SUSE-SLE-Product-SLES-15-2020-2645=1
    
       - SUSE Linux Enterprise Module for Basesystem 15-SP1:
    
          zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP1-2020-2645=1
    
       - SUSE Linux Enterprise High Performance Computing 15-LTSS:
    
          zypper in -t patch SUSE-SLE-Product-HPC-15-2020-2645=1
    
       - SUSE Linux Enterprise High Performance Computing 15-ESPOS:
    
          zypper in -t patch SUSE-SLE-Product-HPC-15-2020-2645=1
    
    
    
    Package List:
    
       - SUSE Linux Enterprise Server for SAP 15 (ppc64le x86_64):
    
          perl-DBI-1.639-3.8.1
          perl-DBI-debuginfo-1.639-3.8.1
          perl-DBI-debugsource-1.639-3.8.1
    
       - SUSE Linux Enterprise Server 15-LTSS (aarch64 s390x):
    
          perl-DBI-1.639-3.8.1
          perl-DBI-debuginfo-1.639-3.8.1
          perl-DBI-debugsource-1.639-3.8.1
    
       - SUSE Linux Enterprise Module for Basesystem 15-SP1 (aarch64 ppc64le s390x x86_64):
    
          perl-DBI-1.639-3.8.1
          perl-DBI-debuginfo-1.639-3.8.1
          perl-DBI-debugsource-1.639-3.8.1
    
       - SUSE Linux Enterprise High Performance Computing 15-LTSS (aarch64 x86_64):
    
          perl-DBI-1.639-3.8.1
          perl-DBI-debuginfo-1.639-3.8.1
          perl-DBI-debugsource-1.639-3.8.1
    
       - SUSE Linux Enterprise High Performance Computing 15-ESPOS (aarch64 x86_64):
    
          perl-DBI-1.639-3.8.1
          perl-DBI-debuginfo-1.639-3.8.1
          perl-DBI-debugsource-1.639-3.8.1
    
    
    References:
    
       https://www.suse.com/security/cve/CVE-2020-14392.html
       https://www.suse.com/security/cve/CVE-2020-14393.html
       https://bugzilla.suse.com/1176409
       https://bugzilla.suse.com/1176412
    
    _______________________________________________
    sle-security-updates mailing list
    This email address is being protected from spambots. You need JavaScript enabled to view it.
    https://lists.suse.com/mailman/listinfo/sle-security-updates
    

    Advisories

    LinuxSecurity Poll

    How are you contributing to Open Source?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 4 answer(s).
    /main-polls/37-how-are-you-contributing-to-open-source?task=poll.vote&format=json
    37
    radio
    [{"id":"127","title":"I'm involved with the development of an open-source project(s).","votes":"2","type":"x","order":"1","pct":100,"resources":[]},{"id":"128","title":"I've reported vulnerabilities I've discovered in open-source code.","votes":"0","type":"x","order":"2","pct":0,"resources":[]},{"id":"129","title":"I've provided developers with feedback on their projects.","votes":"0","type":"x","order":"3","pct":0,"resources":[]},{"id":"130","title":"I've helped another community member get started contributing to Open Source.","votes":"0","type":"x","order":"4","pct":0,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350


    VIEW MORE POLLS

    bottom 200

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.