Linux Security
    Linux Security
    Linux Security

    SUSE: 2020:2896-1 important: php74

    Date 13 Oct 2020
    181
    Posted By LinuxSecurity Advisories
    An update that solves two vulnerabilities and has one errata is now available.
    
       SUSE Security Update: Security update for php74
    ______________________________________________________________________________
    
    Announcement ID:    SUSE-SU-2020:2896-1
    Rating:             important
    References:         #1173786 #1177351 #1177352 
    Cross-References:   CVE-2020-7069 CVE-2020-7070
    Affected Products:
                        SUSE Linux Enterprise Software Development Kit 12-SP5
                        SUSE Linux Enterprise Module for Web Scripting 12
    ______________________________________________________________________________
    
       An update that solves two vulnerabilities and has one
       errata is now available.
    
    Description:
    
       This update for php74 fixes the following issues:
    
       - CVE-2020-7069: Fixed an issue when AES-CCM mode was used with
         openssl_encrypt() function with 12 bytes IV,
         only first 7 bytes of the IV was used (bsc#1177351).
       - CVE-2020-7070: Fixed an issue where percent-encoded cookies could have
         been used to overwrite existing prefixed cookie names (bsc#1177352).
       - Added tmpfiles.d for php-fpm to provide a base for a socket (bsc#1173786)
    
    
    Patch Instructions:
    
       To install this SUSE Security Update use the SUSE recommended installation methods
       like YaST online_update or "zypper patch".
    
       Alternatively you can run the command listed for your product:
    
       - SUSE Linux Enterprise Software Development Kit 12-SP5:
    
          zypper in -t patch SUSE-SLE-SDK-12-SP5-2020-2896=1
    
       - SUSE Linux Enterprise Module for Web Scripting 12:
    
          zypper in -t patch SUSE-SLE-Module-Web-Scripting-12-2020-2896=1
    
    
    
    Package List:
    
       - SUSE Linux Enterprise Software Development Kit 12-SP5 (aarch64 ppc64le s390x x86_64):
    
          php74-debuginfo-7.4.6-1.13.1
          php74-debugsource-7.4.6-1.13.1
          php74-devel-7.4.6-1.13.1
    
       - SUSE Linux Enterprise Module for Web Scripting 12 (aarch64 ppc64le s390x x86_64):
    
          apache2-mod_php74-7.4.6-1.13.1
          apache2-mod_php74-debuginfo-7.4.6-1.13.1
          php74-7.4.6-1.13.1
          php74-bcmath-7.4.6-1.13.1
          php74-bcmath-debuginfo-7.4.6-1.13.1
          php74-bz2-7.4.6-1.13.1
          php74-bz2-debuginfo-7.4.6-1.13.1
          php74-calendar-7.4.6-1.13.1
          php74-calendar-debuginfo-7.4.6-1.13.1
          php74-ctype-7.4.6-1.13.1
          php74-ctype-debuginfo-7.4.6-1.13.1
          php74-curl-7.4.6-1.13.1
          php74-curl-debuginfo-7.4.6-1.13.1
          php74-dba-7.4.6-1.13.1
          php74-dba-debuginfo-7.4.6-1.13.1
          php74-debuginfo-7.4.6-1.13.1
          php74-debugsource-7.4.6-1.13.1
          php74-dom-7.4.6-1.13.1
          php74-dom-debuginfo-7.4.6-1.13.1
          php74-enchant-7.4.6-1.13.1
          php74-enchant-debuginfo-7.4.6-1.13.1
          php74-exif-7.4.6-1.13.1
          php74-exif-debuginfo-7.4.6-1.13.1
          php74-fastcgi-7.4.6-1.13.1
          php74-fastcgi-debuginfo-7.4.6-1.13.1
          php74-fileinfo-7.4.6-1.13.1
          php74-fileinfo-debuginfo-7.4.6-1.13.1
          php74-fpm-7.4.6-1.13.1
          php74-fpm-debuginfo-7.4.6-1.13.1
          php74-ftp-7.4.6-1.13.1
          php74-ftp-debuginfo-7.4.6-1.13.1
          php74-gd-7.4.6-1.13.1
          php74-gd-debuginfo-7.4.6-1.13.1
          php74-gettext-7.4.6-1.13.1
          php74-gettext-debuginfo-7.4.6-1.13.1
          php74-gmp-7.4.6-1.13.1
          php74-gmp-debuginfo-7.4.6-1.13.1
          php74-iconv-7.4.6-1.13.1
          php74-iconv-debuginfo-7.4.6-1.13.1
          php74-intl-7.4.6-1.13.1
          php74-intl-debuginfo-7.4.6-1.13.1
          php74-json-7.4.6-1.13.1
          php74-json-debuginfo-7.4.6-1.13.1
          php74-ldap-7.4.6-1.13.1
          php74-ldap-debuginfo-7.4.6-1.13.1
          php74-mbstring-7.4.6-1.13.1
          php74-mbstring-debuginfo-7.4.6-1.13.1
          php74-mysql-7.4.6-1.13.1
          php74-mysql-debuginfo-7.4.6-1.13.1
          php74-odbc-7.4.6-1.13.1
          php74-odbc-debuginfo-7.4.6-1.13.1
          php74-opcache-7.4.6-1.13.1
          php74-opcache-debuginfo-7.4.6-1.13.1
          php74-openssl-7.4.6-1.13.1
          php74-openssl-debuginfo-7.4.6-1.13.1
          php74-pcntl-7.4.6-1.13.1
          php74-pcntl-debuginfo-7.4.6-1.13.1
          php74-pdo-7.4.6-1.13.1
          php74-pdo-debuginfo-7.4.6-1.13.1
          php74-pgsql-7.4.6-1.13.1
          php74-pgsql-debuginfo-7.4.6-1.13.1
          php74-phar-7.4.6-1.13.1
          php74-phar-debuginfo-7.4.6-1.13.1
          php74-posix-7.4.6-1.13.1
          php74-posix-debuginfo-7.4.6-1.13.1
          php74-readline-7.4.6-1.13.1
          php74-readline-debuginfo-7.4.6-1.13.1
          php74-shmop-7.4.6-1.13.1
          php74-shmop-debuginfo-7.4.6-1.13.1
          php74-snmp-7.4.6-1.13.1
          php74-snmp-debuginfo-7.4.6-1.13.1
          php74-soap-7.4.6-1.13.1
          php74-soap-debuginfo-7.4.6-1.13.1
          php74-sockets-7.4.6-1.13.1
          php74-sockets-debuginfo-7.4.6-1.13.1
          php74-sodium-7.4.6-1.13.1
          php74-sodium-debuginfo-7.4.6-1.13.1
          php74-sqlite-7.4.6-1.13.1
          php74-sqlite-debuginfo-7.4.6-1.13.1
          php74-sysvmsg-7.4.6-1.13.1
          php74-sysvmsg-debuginfo-7.4.6-1.13.1
          php74-sysvsem-7.4.6-1.13.1
          php74-sysvsem-debuginfo-7.4.6-1.13.1
          php74-sysvshm-7.4.6-1.13.1
          php74-sysvshm-debuginfo-7.4.6-1.13.1
          php74-tidy-7.4.6-1.13.1
          php74-tidy-debuginfo-7.4.6-1.13.1
          php74-tokenizer-7.4.6-1.13.1
          php74-tokenizer-debuginfo-7.4.6-1.13.1
          php74-xmlreader-7.4.6-1.13.1
          php74-xmlreader-debuginfo-7.4.6-1.13.1
          php74-xmlrpc-7.4.6-1.13.1
          php74-xmlrpc-debuginfo-7.4.6-1.13.1
          php74-xmlwriter-7.4.6-1.13.1
          php74-xmlwriter-debuginfo-7.4.6-1.13.1
          php74-xsl-7.4.6-1.13.1
          php74-xsl-debuginfo-7.4.6-1.13.1
          php74-zip-7.4.6-1.13.1
          php74-zip-debuginfo-7.4.6-1.13.1
          php74-zlib-7.4.6-1.13.1
          php74-zlib-debuginfo-7.4.6-1.13.1
    
    
    References:
    
       https://www.suse.com/security/cve/CVE-2020-7069.html
       https://www.suse.com/security/cve/CVE-2020-7070.html
       https://bugzilla.suse.com/1173786
       https://bugzilla.suse.com/1177351
       https://bugzilla.suse.com/1177352
    
    _______________________________________________
    sle-security-updates mailing list
    This email address is being protected from spambots. You need JavaScript enabled to view it.
    https://lists.suse.com/mailman/listinfo/sle-security-updates
    

    LinuxSecurity Poll

    Which is the best secure Linux distro for pentesting?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/50-which-is-the-best-secure-linux-distro-for-pentesting?task=poll.vote&format=json
    50
    radio
    [{"id":"174","title":"Kali Linux","votes":"9","type":"x","order":"1","pct":56.25,"resources":[]},{"id":"175","title":"Parrot OS","votes":"7","type":"x","order":"2","pct":43.75,"resources":[]},{"id":"176","title":"BlackArch Linux","votes":"0","type":"x","order":"3","pct":0,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350

    Please vote first in order to view vote results.


    VIEW MORE POLLS

    bottom 200

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.