Linux Security
    Linux Security
    Linux Security

    SUSE: 2020:3064-1 moderate: zeromq

    Date 28 Oct 2020
    133
    Posted By LinuxSecurity Advisories
    An update that contains security fixes can now be installed.
    
       SUSE Security Update: Security update for zeromq
    ______________________________________________________________________________
    
    Announcement ID:    SUSE-SU-2020:3064-1
    Rating:             moderate
    References:         #1176257 #1176258 
    Affected Products:
                        SUSE Manager Tools 12
                        SUSE Manager Server 3.2
                        SUSE Manager Proxy 3.2
                        SUSE Linux Enterprise Workstation Extension 12-SP5
                        SUSE Linux Enterprise Software Development Kit 12-SP5
                        SUSE Linux Enterprise Point of Sale 12-SP2
                        SUSE Linux Enterprise Module for Advanced Systems Management 12
                        SUSE Enterprise Storage 5
    ______________________________________________________________________________
    
       An update that contains security fixes can now be installed.
    
    Description:
    
       This update for zeromq fixes the following issues:
    
       - Fixed a memory leak in client induced by malicious server(s) without
         CURVE/ZAP (bsc#1176257)
       - Fixed a stack overflow in PUB/XPUB subscription store (bsc#1176258)
    
    
    Patch Instructions:
    
       To install this SUSE Security Update use the SUSE recommended installation methods
       like YaST online_update or "zypper patch".
    
       Alternatively you can run the command listed for your product:
    
       - SUSE Manager Tools 12:
    
          zypper in -t patch SUSE-SLE-Manager-Tools-12-2020-3064=1
    
       - SUSE Manager Server 3.2:
    
          zypper in -t patch SUSE-SUSE-Manager-Server-3.2-2020-3064=1
    
       - SUSE Manager Proxy 3.2:
    
          zypper in -t patch SUSE-SUSE-Manager-Proxy-3.2-2020-3064=1
    
       - SUSE Linux Enterprise Workstation Extension 12-SP5:
    
          zypper in -t patch SUSE-SLE-WE-12-SP5-2020-3064=1
    
       - SUSE Linux Enterprise Software Development Kit 12-SP5:
    
          zypper in -t patch SUSE-SLE-SDK-12-SP5-2020-3064=1
    
       - SUSE Linux Enterprise Point of Sale 12-SP2:
    
          zypper in -t patch SUSE-SLE-POS-12-SP2-2020-3064=1
    
       - SUSE Linux Enterprise Module for Advanced Systems Management 12:
    
          zypper in -t patch SUSE-SLE-Module-Adv-Systems-Management-12-2020-3064=1
    
       - SUSE Enterprise Storage 5:
    
          zypper in -t patch SUSE-Storage-5-2020-3064=1
    
    
    
    Package List:
    
       - SUSE Manager Tools 12 (aarch64 ppc64le s390x x86_64):
    
          libzmq3-4.0.4-15.6.1
          libzmq3-debuginfo-4.0.4-15.6.1
          zeromq-debugsource-4.0.4-15.6.1
    
       - SUSE Manager Server 3.2 (ppc64le s390x x86_64):
    
          libzmq3-4.0.4-15.6.1
          libzmq3-debuginfo-4.0.4-15.6.1
          zeromq-debugsource-4.0.4-15.6.1
    
       - SUSE Manager Proxy 3.2 (x86_64):
    
          libzmq3-4.0.4-15.6.1
          libzmq3-debuginfo-4.0.4-15.6.1
          zeromq-debugsource-4.0.4-15.6.1
    
       - SUSE Linux Enterprise Workstation Extension 12-SP5 (x86_64):
    
          libzmq3-4.0.4-15.6.1
          libzmq3-debuginfo-4.0.4-15.6.1
          zeromq-debugsource-4.0.4-15.6.1
    
       - SUSE Linux Enterprise Software Development Kit 12-SP5 (aarch64 ppc64le s390x x86_64):
    
          libzmq3-4.0.4-15.6.1
          libzmq3-debuginfo-4.0.4-15.6.1
          zeromq-debugsource-4.0.4-15.6.1
          zeromq-devel-4.0.4-15.6.1
    
       - SUSE Linux Enterprise Point of Sale 12-SP2 (x86_64):
    
          libzmq3-4.0.4-15.6.1
          libzmq3-debuginfo-4.0.4-15.6.1
          zeromq-debugsource-4.0.4-15.6.1
    
       - SUSE Linux Enterprise Module for Advanced Systems Management 12 (ppc64le s390x x86_64):
    
          libzmq3-4.0.4-15.6.1
          libzmq3-debuginfo-4.0.4-15.6.1
          zeromq-debugsource-4.0.4-15.6.1
    
       - SUSE Enterprise Storage 5 (aarch64 x86_64):
    
          libzmq3-4.0.4-15.6.1
          libzmq3-debuginfo-4.0.4-15.6.1
          zeromq-debugsource-4.0.4-15.6.1
    
    
    References:
    
       https://bugzilla.suse.com/1176257
       https://bugzilla.suse.com/1176258
    

    Advisories

    LinuxSecurity Poll

    How long have you been using Linux?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 4 answer(s).
    /main-polls/46-how-long-have-you-been-using-linux?task=poll.vote&format=json
    46
    radio
    [{"id":"160","title":"Just made the switch!","votes":"3","type":"x","order":"1","pct":9.68,"resources":[]},{"id":"161","title":"1-5 years","votes":"5","type":"x","order":"2","pct":16.13,"resources":[]},{"id":"162","title":"6-10 years","votes":"1","type":"x","order":"3","pct":3.23,"resources":[]},{"id":"163","title":">10 years - I'm a veteran!","votes":"22","type":"x","order":"4","pct":70.97,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350

    Please vote first in order to view vote results.


    VIEW MORE POLLS

    bottom 200

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.