Ubuntu 4283-1: QEMU vulnerabilities

    Date18 Feb 2020
    175
    Posted ByLinuxSecurity Advisories
    Several security issues were fixed in QEMU.
    ==========================================================================
    Ubuntu Security Notice USN-4283-1
    February 18, 2020
    
    qemu vulnerabilities
    ==========================================================================
    
    A security issue affects these releases of Ubuntu and its derivatives:
    
    - Ubuntu 19.10
    - Ubuntu 18.04 LTS
    - Ubuntu 16.04 LTS
    
    Summary:
    
    Several security issues were fixed in QEMU.
    
    Software Description:
    - qemu: Machine emulator and virtualizer
    
    Details:
    
    Felipe Franciosi, Raphael Norwitz, and Peter Turschmid discovered that QEMU
    incorrectly handled iSCSI server responses. A remote attacker in control of
    the iSCSI server could use this issue to cause QEMU to crash, leading to a
    denial of service, or possibly execute arbitrary code. (CVE-2020-1711)
    
    It was discovered that the QEMU libslirp component incorrectly handled
    memory. A remote attacker could use this issue to cause QEMU to crash,
    resulting in a denial of service, or possibly execute arbitrary code.
    (CVE-2020-7039, CVE-2020-8608)
    
    Update instructions:
    
    The problem can be corrected by updating your system to the following
    package versions:
    
    Ubuntu 19.10:
      qemu                            1:4.0+dfsg-0ubuntu9.4
      qemu-system                     1:4.0+dfsg-0ubuntu9.4
      qemu-system-arm                 1:4.0+dfsg-0ubuntu9.4
      qemu-system-mips                1:4.0+dfsg-0ubuntu9.4
      qemu-system-ppc                 1:4.0+dfsg-0ubuntu9.4
      qemu-system-s390x               1:4.0+dfsg-0ubuntu9.4
      qemu-system-sparc               1:4.0+dfsg-0ubuntu9.4
      qemu-system-x86                 1:4.0+dfsg-0ubuntu9.4
    
    Ubuntu 18.04 LTS:
      qemu                            1:2.11+dfsg-1ubuntu7.23
      qemu-system                     1:2.11+dfsg-1ubuntu7.23
      qemu-system-arm                 1:2.11+dfsg-1ubuntu7.23
      qemu-system-mips                1:2.11+dfsg-1ubuntu7.23
      qemu-system-ppc                 1:2.11+dfsg-1ubuntu7.23
      qemu-system-s390x               1:2.11+dfsg-1ubuntu7.23
      qemu-system-sparc               1:2.11+dfsg-1ubuntu7.23
      qemu-system-x86                 1:2.11+dfsg-1ubuntu7.23
    
    Ubuntu 16.04 LTS:
      qemu                            1:2.5+dfsg-5ubuntu10.43
      qemu-system                     1:2.5+dfsg-5ubuntu10.43
      qemu-system-aarch64             1:2.5+dfsg-5ubuntu10.43
      qemu-system-arm                 1:2.5+dfsg-5ubuntu10.43
      qemu-system-mips                1:2.5+dfsg-5ubuntu10.43
      qemu-system-ppc                 1:2.5+dfsg-5ubuntu10.43
      qemu-system-s390x               1:2.5+dfsg-5ubuntu10.43
      qemu-system-sparc               1:2.5+dfsg-5ubuntu10.43
      qemu-system-x86                 1:2.5+dfsg-5ubuntu10.43
    
    After a standard system update you need to restart all QEMU virtual
    machines to make all the necessary changes.
    
    References:
      https://usn.ubuntu.com/4283-1
      CVE-2020-1711, CVE-2020-7039, CVE-2020-8608
    
    Package Information:
      https://launchpad.net/ubuntu/+source/qemu/1:4.0+dfsg-0ubuntu9.4
      https://launchpad.net/ubuntu/+source/qemu/1:2.11+dfsg-1ubuntu7.23
      https://launchpad.net/ubuntu/+source/qemu/1:2.5+dfsg-5ubuntu10.43
    
    

    LinuxSecurity Poll

    What do you think of the LinuxSecurity Privacy news articles?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/25-what-do-you-think-of-the-linuxsecurity-privacy-news-articles?task=poll.vote&format=json
    25
    radio
    [{"id":"90","title":"Love them!","votes":"48","type":"x","order":"1","pct":88.89,"resources":[]},{"id":"91","title":"I'm indifferent","votes":"4","type":"x","order":"2","pct":7.41,"resources":[]},{"id":"92","title":"Not interested in this topic","votes":"2","type":"x","order":"3","pct":3.7,"resources":[]}]["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"]["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"]350
    bottom200

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.