-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

- -------------------------------------------------------------------------
Debian Security Advisory DSA-4241-1                   security@debian.org
https://www.debian.org/security/                       Moritz Muehlenhoff
July 05, 2018                         https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package        : libsoup2.4
CVE ID         : CVE-2018-12910

It was discovered that the Soup HTTP library performed insuffient
validation of cookie requests which could result in an out-of-bounds
memory read.

For the stable distribution (stretch), this problem has been fixed in
version 2.56.0-2+deb9u2.

We recommend that you upgrade your libsoup2.4 packages.

For the detailed security status of libsoup2.4 please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/source-package/libsoup2.4

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: debian-security-announce@lists.debian.org

Debian: DSA-4241-1: libsoup2.4 security update

July 5, 2018
It was discovered that the Soup HTTP library performed insuffient validation of cookie requests which could result in an out-of-bounds memory read

Summary

It was discovered that the Soup HTTP library performed insuffient
validation of cookie requests which could result in an out-of-bounds
memory read.

For the stable distribution (stretch), this problem has been fixed in
version 2.56.0-2+deb9u2.

We recommend that you upgrade your libsoup2.4 packages.

For the detailed security status of libsoup2.4 please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/source-package/libsoup2.4

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/



Severity
Package : libsoup2.4
CVE ID : CVE-2018-12910

Related News