Debian: DSA-4936-1: libuv1 security update | LinuxSecurity.com

Advisories

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

- -------------------------------------------------------------------------
Debian Security Advisory DSA-4936-1                   [email protected]
https://www.debian.org/security/                       Moritz Muehlenhoff
July 05, 2021                         https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package        : libuv1
CVE ID         : CVE-2021-22918
Debian Bug     : 990561

An out-of-bounds read was discovered in the uv__idna_to_ascii() function
of Libuv, an asynchronous event notification library, which could result
in denial of service or information disclosure.

For the stable distribution (buster), this problem has been fixed in
version 1.24.1-1+deb10u1.

We recommend that you upgrade your libuv1 packages.

For the detailed security status of libuv1 please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/libuv1

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: [email protected]

Debian: DSA-4936-1: libuv1 security update

July 5, 2021
An out-of-bounds read was discovered in the uv__idna_to_ascii() function of Libuv, an asynchronous event notification library, which could result in denial of service or informatio...

Summary

An out-of-bounds read was discovered in the uv__idna_to_ascii() function
of Libuv, an asynchronous event notification library, which could result
in denial of service or information disclosure.

For the stable distribution (buster), this problem has been fixed in
version 1.24.1-1+deb10u1.

We recommend that you upgrade your libuv1 packages.

For the detailed security status of libuv1 please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/libuv1

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: [email protected]

Severity
Package : libuv1
CVE ID : CVE-2021-22918
Debian Bug : 990561

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.