- -------------------------------------------------------------------------
Debian Security Advisory DSA-5119-1                   [email protected]
https://www.debian.org/security/                     Salvatore Bonaccorso
April 13, 2022                        https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package        : subversion
CVE ID         : CVE-2021-28544 CVE-2022-24070

Several vulnerabilities were discovered in Subversion, a version control
system.

CVE-2021-28544

    Evgeny Kotkov reported that Subversion servers reveal 'copyfrom'
    paths that should be hidden according to configured path-based
    authorization (authz) rules.

CVE-2022-24070

    Thomas Weissschuh reported that Subversion's mod_dav_svn is prone to
    a use-after-free vulnerability when looking up path-based
    authorization rules, which can result in denial of service (crash of
    HTTPD worker handling the request).

For the oldstable distribution (buster), these problems have been fixed
in version 1.10.4-1+deb10u3.

For the stable distribution (bullseye), these problems have been fixed in
version 1.14.1-3+deb11u1.

We recommend that you upgrade your subversion packages.

For the detailed security status of subversion please refer to its
security tracker page at:
https://security-tracker.debian.org/tracker/subversion

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: [email protected]