Debian: DSA-5170-1: nodejs security update | LinuxSecurity.com

Advisories

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

- -------------------------------------------------------------------------
Debian Security Advisory DSA-5170-1                   [email protected]
https://www.debian.org/security/                       Moritz Muehlenhoff
June 27, 2022                         https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package        : nodejs
CVE ID         : CVE-2021-22959 CVE-2021-22960 CVE-2021-44532 CVE-2021-44533 
                 CVE-2022-21824 CVE-2021-44531

Multiple vulnerabilities were discovered in Node.js, which could result in
HTTP request smuggling, a bypass of certificate verification or prototype
pollution.

For the stable distribution (bullseye), these problems have been fixed in
version 12.22.12~dfsg-1~deb11u1.

We recommend that you upgrade your nodejs packages.

For the detailed security status of nodejs please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/nodejs

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: [email protected]

Debian: DSA-5170-1: nodejs security update

June 27, 2022
Multiple vulnerabilities were discovered in Node.js, which could result in HTTP request smuggling, a bypass of certificate verification or prototype pollution

Summary

Multiple vulnerabilities were discovered in Node.js, which could result in
HTTP request smuggling, a bypass of certificate verification or prototype
pollution.

For the stable distribution (bullseye), these problems have been fixed in
version 12.22.12~dfsg-1~deb11u1.

We recommend that you upgrade your nodejs packages.

For the detailed security status of nodejs please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/nodejs

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: [email protected]

Severity
Package : nodejs
CVE ID : CVE-2021-22959 CVE-2021-22960 CVE-2021-44532 CVE-2021-44533
CVE-2022-21824 CVE-2021-44531

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.