Debian: DSA-5189-1: gsasl security update | LinuxSecurity.com

Advisories

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

- -------------------------------------------------------------------------
Debian Security Advisory DSA-5189-1                   [email protected]
https://www.debian.org/security/                       Moritz Muehlenhoff
July 24, 2022                         https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package        : gsasl
CVE ID         : CVE-2022-2469

Simon Josefsson discovered an out-of-bounds memory read in GNU SASL,
an implementation of the Simple Authentication and Security Layer
framework, which could result in denial of service.

For the oldstable distribution (buster), this problem has been fixed
in version 1.8.0-8+deb10u1.

For the stable distribution (bullseye), this problem has been fixed in
version 1.10.0-4+deb11u1.

We recommend that you upgrade your gsasl packages.

For the detailed security status of gsasl please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/gsasl

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: [email protected]

Debian: DSA-5189-1: gsasl security update

July 24, 2022
Simon Josefsson discovered an out-of-bounds memory read in GNU SASL, an implementation of the Simple Authentication and Security Layer framework, which could result in denial of se...

Summary

Simon Josefsson discovered an out-of-bounds memory read in GNU SASL,
an implementation of the Simple Authentication and Security Layer
framework, which could result in denial of service.

For the oldstable distribution (buster), this problem has been fixed
in version 1.8.0-8+deb10u1.

For the stable distribution (bullseye), this problem has been fixed in
version 1.10.0-4+deb11u1.

We recommend that you upgrade your gsasl packages.

For the detailed security status of gsasl please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/gsasl

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: [email protected]

Severity
Package : gsasl
CVE ID : CVE-2022-2469