Debian: DSA-5310-1: ruby-image-processing security update | LinuxSe...

- -------------------------------------------------------------------------
Debian Security Advisory DSA-5310-1                   [email protected]
https://www.debian.org/security/                     Salvatore Bonaccorso
December 31, 2022                     https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package        : ruby-image-processing
CVE ID         : CVE-2022-24720
Debian Bug     : 1007225

It was discovered that ruby-image-processing, a ruby package that
provides higher-level image processing helpers, is prone to a remote
shell execution vulnerability when using the #apply method to apply a
series of operations coming from unsanitized user input.

For the stable distribution (bullseye), this problem has been fixed in
version 1.10.3-1+deb11u1.

We recommend that you upgrade your ruby-image-processing packages.

For the detailed security status of ruby-image-processing please refer
to its security tracker page at:
https://security-tracker.debian.org/tracker/ruby-image-processing

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: [email protected]

Debian: DSA-5310-1: ruby-image-processing security update

December 31, 2022
It was discovered that ruby-image-processing, a ruby package that provides higher-level image processing helpers, is prone to a remote shell execution vulnerability when using the ...

Summary

For the stable distribution (bullseye), this problem has been fixed in
version 1.10.3-1+deb11u1.

We recommend that you upgrade your ruby-image-processing packages.

For the detailed security status of ruby-image-processing please refer
to its security tracker page at:
https://security-tracker.debian.org/tracker/ruby-image-processing

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: [email protected]

Severity
It was discovered that ruby-image-processing, a ruby package that
provides higher-level image processing helpers, is prone to a remote
shell execution vulnerability when using the #apply method to apply a
series of operations coming from unsanitized user input.

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.