Debian: DSA-5316-1: netty security update | LinuxSecurity.com
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

- -------------------------------------------------------------------------
Debian Security Advisory DSA-5316-1                   [email protected]
https://www.debian.org/security/                          Markus Koschany
January 11, 2023                      https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package        : netty
CVE ID         : CVE-2021-37136 CVE-2021-37137 CVE-2021-43797 CVE-2022-41881
                 CVE-2022-41915
Debian Bug     : 1027180 1014769 1001437

Several out-of-memory, stack overflow or HTTP request smuggling vulnerabilities
have been discovered in Netty, a Java NIO client/server socket framework, which
may allow attackers to cause a denial of service or bypass restrictions when
used as a proxy.

For the stable distribution (bullseye), these problems have been fixed in
version 1:4.1.48-4+deb11u1.

We recommend that you upgrade your netty packages.

For the detailed security status of netty please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/netty

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: [email protected]

Debian: DSA-5316-1: netty security update

January 11, 2023
Several out-of-memory, stack overflow or HTTP request smuggling vulnerabilities have been discovered in Netty, a Java NIO client/server socket framework, which may allow attackers ...

Summary

Several out-of-memory, stack overflow or HTTP request smuggling vulnerabilities
have been discovered in Netty, a Java NIO client/server socket framework, which
may allow attackers to cause a denial of service or bypass restrictions when
used as a proxy.

For the stable distribution (bullseye), these problems have been fixed in
version 1:4.1.48-4+deb11u1.

We recommend that you upgrade your netty packages.

For the detailed security status of netty please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/netty

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: [email protected]

Severity
Package : netty
CVE ID : CVE-2021-37136 CVE-2021-37137 CVE-2021-43797 CVE-2022-41881
CVE-2022-41915
Debian Bug : 1027180 1014769 1001437

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.