Linux Security
    Linux Security
    Linux Security

    Debian: New common-lisp-controller packages fix arbitrary code injection

    Date 20 Nov 2005
    5807
    Posted By Joe Shakespeare
    Updated package.
    - --------------------------------------------------------------------------
    Debian Security Advisory DSA 811-2                     This email address is being protected from spambots. You need JavaScript enabled to view it.
    https://www.debian.org/security/                             Martin Schulze
    November 21st, 2005                     https://www.debian.org/security/faq
    - --------------------------------------------------------------------------
    
    Package        : common-lisp-controller
    Vulnerability  : design error
    Problem type   : local
    Debian-specific: no
    CVE ID         : CAN-2005-2657
    
    The bugfix for the problem mentioned below contained an error that
    caused third party programs to fail.  The problem is corrected by this
    update.  For completeness we're including the original advisory text:
    
       Fran�ois-Ren� Rideau discovered a bug in common-lisp-controller, a
       Common Lisp source and compiler manager, that allows a local user
       to compile malicious code into a cache directory which is executed
       by another user if that user has not used Common Lisp before.
    
    The old stable distribution (woody) is not affected by this problem.
    
    For the stable distribution (sarge) this problem has been fixed in
    version 4.15sarge3.
    
    For the unstable distribution (sid) this problem has been fixed in
    version 4.18.
    
    We recommend that you upgrade your common-lisp-controller package.
    
    
    Upgrade Instructions
    - --------------------
    
    wget url
            will fetch the file for you
    dpkg -i file.deb
            will install the referenced file.
    
    If you are using the apt-get package manager, use the line for
    sources.list as given below:
    
    apt-get update
            will update the internal database
    apt-get upgrade
            will install corrected packages
    
    You may use an automated update by adding the resources from the
    footer to the proper configuration.
    
    
    Debian GNU/Linux 3.1 alias sarge
    - --------------------------------
    
      Source archives:
    
        https://security.debian.org/pool/updates/main/c/common-lisp-controller/common-lisp-controller_4.15sarge3.dsc
          Size/MD5 checksum:      599 20ea8fa341ceb1cf7b023aff4df6e389
        https://security.debian.org/pool/updates/main/c/common-lisp-controller/common-lisp-controller_4.15sarge3.tar.gz
          Size/MD5 checksum:    25132 0f2d6f3e075eb70397b6664c37e99867
    
      Architecture independent components:
    
        https://security.debian.org/pool/updates/main/c/common-lisp-controller/common-lisp-controller_4.15sarge3_all.deb
          Size/MD5 checksum:    24184 854430ec786872dc81f7d735dd554e54
    
    
      These files will probably be moved into the stable distribution on
      its next update.
    
    - ---------------------------------------------------------------------------------
    For apt-get: deb https://security.debian.org/ stable/updates main
    For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
    Mailing list: This email address is being protected from spambots. You need JavaScript enabled to view it.
    

    Advisories

    LinuxSecurity Poll

    I agree with Linus Torvalds - Apple's new M1-powered laptops should run on Linux.

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 2 answer(s).
    /main-polls/45-i-agree-with-linus-torvalds-apple-s-new-m1-powered-laptops-should-run-on-linux?task=poll.vote&format=json
    45
    radio
    [{"id":"158","title":"True","votes":"18","type":"x","order":"1","pct":3.51,"resources":[]},{"id":"159","title":"False","votes":"495","type":"x","order":"2","pct":96.49,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350

    Please vote first in order to view vote results.


    VIEW MORE POLLS

    bottom 200

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.