Debian: 'OpenSSH' vulnerabilities

    Date 08 Feb 2001
    2690
    Posted By LinuxSecurity Advisories
    This package fixes two security problems with OpenSSH.
    
    ----------------------------------------------------------------------------
    Debian Security Advisory DSA-027-1                       This email address is being protected from spambots. You need JavaScript enabled to view it. 
    https://www.debian.org/security/                               Martin Schulze
    February 8, 2001
    ----------------------------------------------------------------------------
    
    Package        : openssh
    Vulnerability  : remote memory overwrite, key exchange problem
    Type           : remote exploit
    Debian-specific: no
    
    This upload fixes:
    
     1. Prior versions of OpenSSH are vulnerable to a remote arbitrary
        memory overwrite attack which may eventually lead into a root
        exploit.  No exploit program is known yet but expected to come up
        soon.
    
     2. CORE-SDI has described a problem with regards to RSA key exchange
        and a Bleichenbacher attack to gather the session key from an ssh
        session.
    
    We recommend you upgrade your openssh package immediately.
    
    wget url
            will fetch the file for you
    dpkg -i file.deb
            will install the referenced file.
    
    You may use an automated update by adding the resources from the
    footer to the proper configuration.
    
    
    Debian GNU/Linux 2.2 alias potato
    ------------------------------------
    
      Potato was released for the alpha, arm, i386, m68k, powerpc and sparc
      architectures.
    
    
      Source archives:
    
         https://security.debian.org/dists/stable/updates/main/source/openssh_1.2.3-9.2.diff.gz
          MD5 checksum: b823b3a94de32533cb35c23a9b956c5c
         https://security.debian.org/dists/stable/updates/main/source/openssh_1.2.3-9.2.dsc
          MD5 checksum: bae514efd776c6007944677e767c60a0
         https://security.debian.org/dists/stable/updates/main/source/openssh_1.2.3.orig.tar.gz
          MD5 checksum: 6aad0cc9ceca55f138ed1ba4cf660349
    
      Intel ia32 architecture:
    
         https://security.debian.org/dists/stable/updates/main/binary-i386/ssh-askpass-gnome_1.2.3-9.2_i386.deb
          MD5 checksum: 0283cfa29a7ac7e7857a6e844446202d
         https://security.debian.org/dists/stable/updates/main/binary-i386/ssh_1.2.3-9.2_i386.deb
          MD5 checksum: e093ef0bc4201860c66edc859f064e71
    
      Motorola 680x0 architecture:
    
         https://security.debian.org/dists/stable/updates/main/binary-m68k/ssh-askpass-gnome_1.2.3-9.2_m68k.deb
          MD5 checksum: a7f52d223f5755dacc09c20bbaf10d3e
         https://security.debian.org/dists/stable/updates/main/binary-m68k/ssh_1.2.3-9.2_m68k.deb
          MD5 checksum: 50cbe82d6f733357350cbedebc6b58a6
    
      Sun Sparc architecture:
    
         https://security.debian.org/dists/stable/updates/main/binary-sparc/ssh_1.2.3-9.2_sparc.deb
          MD5 checksum: c2b2aefe74ba8852f0ac0bb2a3145892
         https://security.debian.org/dists/stable/updates/main/binary-sparc/ssh-askpass-gnome_1.2.3-9.2_sparc.deb
          MD5 checksum: d0de50b38fd8b517aa2b62fd15d5fcd4
    
      Alpha architecture:
    
         https://security.debian.org/dists/stable/updates/main/binary-alpha/ssh-askpass-gnome_1.2.3-9.2_alpha.deb
          MD5 checksum: 5be857c6395f02bb9b454bfb13621b06
         https://security.debian.org/dists/stable/updates/main/binary-alpha/ssh_1.2.3-9.2_alpha.deb
          MD5 checksum: e55ef711299a60f5ee5df935a5db4931
    
      PowerPC architecture:
    
         https://security.debian.org/dists/stable/updates/main/binary-powerpc/ssh-askpass-gnome_1.2.3-9.2_powerpc.deb
          MD5 checksum: 343c30fec20cf21f7075d86eed9f66f5
         https://security.debian.org/dists/stable/updates/main/binary-powerpc/ssh_1.2.3-9.2_powerpc.deb
          MD5 checksum: 12d7876a78d4eb9485b1aec8da28d3f9
    
      ARM architecture:
    
         https://security.debian.org/dists/stable/updates/main/binary-arm/ssh-askpass-gnome_1.2.3-9.2_arm.deb
          MD5 checksum: fc55f1ec0dfba1175f7060235a6d6d09
         https://security.debian.org/dists/stable/updates/main/binary-arm/ssh_1.2.3-9.2_arm.deb
          MD5 checksum: 3e01291dedf24d01e5645734ec2c4cfb
    
      Architecture independent:
    
         https://security.debian.org/dists/stable/updates/main/binary-all/ssh-askpass-ptk_1.2.3-9.2_all.deb
          MD5 checksum: 8aecdb6efd301c86c843191e3731b1fc
    
    
      These files will be moved into
       ftp://ftp.debian.org/debian/dists/stable/*/binary-$arch/ soon.
    
    For not yet released architectures please refer to the appropriate
    directory  ftp://ftp.debian.org/debian/dists/sid/binary-$arch/ .
    
    ----------------------------------------------------------------------------
    For apt-get: deb  https://security.debian.org/ stable/updates main
    For dpkg-ftp:  ftp://security.debian.org/debian-security dists/stable/updates/main
    Mailing list: This email address is being protected from spambots. You need JavaScript enabled to view it.
    Package info: `apt-cache show ' and  https://packages.debian.org/
    
    
    

    LinuxSecurity Poll

    Are you considering making the switch to Purism's new Librem 14 Linux laptop to improve your security and privacy online?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/31-are-you-considering-making-the-switch-to-purism-s-new-librem-14-linux-laptop-to-improve-your-security-and-privacy-online?task=poll.vote&format=json
    31
    radio
    [{"id":"109","title":"Yes - the hardware kill switches and default ad blocking\/tracking protection sold me on it.","votes":"3","type":"x","order":"1","pct":37.5,"resources":[]},{"id":"110","title":"Not sure yet - I need to do more research.","votes":"4","type":"x","order":"2","pct":50,"resources":[]},{"id":"111","title":"No - I'm satisfied with my current laptop and have no security\/privacy concerns.","votes":"1","type":"x","order":"3","pct":12.5,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350
    bottom 200

    Advisories

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.