-------------------------------------------------------------------------
Debian LTS Advisory DLA-2751-1                [email protected]
https://www.debian.org/lts/security/                       Christoph Berg
August 31, 2021                               https://wiki.debian.org/LTS
-------------------------------------------------------------------------

Package        : postgresql-9.6
Version        : 9.6.23-0+deb9u1
CVE ID         : CVE-2021-3449

PostgreSQL 9.6.23 fixes this security issue:

  Disallow SSL renegotiation more completely (Michael Paquier)

  SSL renegotiation has been disabled for some time, but the server would
  still cooperate with a client-initiated renegotiation request. A
  maliciously crafted renegotiation request could result in a server crash
  (see OpenSSL issue CVE-2021-3449).  Disable the feature altogether on
  OpenSSL versions that permit doing so, which are 1.1.0h and newer.

For Debian 9 stretch, this problem has been fixed in version
9.6.23-0+deb9u1.

We recommend that you upgrade your postgresql-9.6 packages.

For the detailed security status of postgresql-9.6 please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/postgresql-9.6

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS