Debian LTS: DLA-2772-1: taglib security update

Advisories


- -------------------------------------------------------------------------
Debian LTS Advisory DLA-2772-1                [email protected]
https://www.debian.org/lts/security/                          Adrian Bunk
September 30, 2021                            https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package        : taglib
Version        : 1.11.1+dfsg.1-0.3+deb9u1
CVE ID         : CVE-2017-12678 CVE-2018-11439
Debian Bug     : 871511 903847 915281

Several problems were corrected in TagLib,
a library for reading and editing audio meta data.

CVE-2017-12678

    A crafted audio file could result in a crash.

CVE-2018-11439

    A crafted audio file could result in information disclosure.

Additionally, a bug that can lead to corruption of ogg files
has been fixed.

For Debian 9 stretch, these problems have been fixed in version
1.11.1+dfsg.1-0.3+deb9u1.

We recommend that you upgrade your taglib packages.

For the detailed security status of taglib please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/taglib

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Debian LTS: DLA-2772-1: taglib security update

September 30, 2021
Several problems were corrected in TagLib, a library for reading and editing audio meta data

Summary

CVE-2017-12678

A crafted audio file could result in a crash.

CVE-2018-11439

A crafted audio file could result in information disclosure.

Additionally, a bug that can lead to corruption of ogg files
has been fixed.

For Debian 9 stretch, these problems have been fixed in version
1.11.1+dfsg.1-0.3+deb9u1.

We recommend that you upgrade your taglib packages.

For the detailed security status of taglib please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/taglib

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Severity
Package : taglib
Version : 1.11.1+dfsg.1-0.3+deb9u1
CVE ID : CVE-2017-12678 CVE-2018-11439
Debian Bug : 871511 903847 915281

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.