- -------------------------------------------------------------------------
Debian LTS Advisory DLA-2822-1                [email protected]
https://www.debian.org/lts/security/                    Thorsten Alteholz
November 19, 2021                             https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package        : netkit-rsh
Version        : 0.17-17+deb9u1
CVE ID         : CVE-2019-7282 CVE-2019-7283


Two issues have been found in netkit-rsh, client and server programs for 
remote shell connections.
Due to insufficient input validation in path names sent by server, a 
malicious server can do arbitrary file overwrites in the target directory 
or modify permissions of the target directory.


For Debian 9 stretch, these problems have been fixed in version
0.17-17+deb9u1.

We recommend that you upgrade your netkit-rsh packages.

For the detailed security status of netkit-rsh please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/netkit-rsh

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS