- -------------------------------------------------------------------------
Debian LTS Advisory DLA-2879-1                [email protected]
https://www.debian.org/lts/security/                         Anton Gladky
January 14, 2022                              https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package        : lighttpd
Version        : 1.4.45-1+deb9u1
CVE ID         : CVE-2018-19052

One issue has been discovered in lighttpd: fast webserver with minimal memory
footprint.

CVE-2018-19052: an issue was discovered in mod_alias_physical_handler in
mod_alias.c in lighttpd before 1.4.50. There is potential ../ path traversal of
a single directory above an alias target, with a specific mod_alias
configuration where the matched alias lacks a trailing '/' character, but the
alias target filesystem path does have a trailing '/' character.

For Debian 9 stretch, this problem has been fixed in version
1.4.45-1+deb9u1.

We recommend that you upgrade your lighttpd packages.

For the detailed security status of lighttpd please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/lighttpd

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS