Debian LTS: DLA-3073-1: webkit2gtk security update | LinuxSecurity.com

- -------------------------------------------------------------------------
Debian LTS Advisory DLA-3073-1                [email protected]
https://www.debian.org/lts/security/               Emilio Pozuelo Monfort
August 17, 2022                               https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package        : webkit2gtk
Version        : 2.36.6-1~deb10u1
CVE ID         : CVE-2022-32792 CVE-2022-32816

The following vulnerabilities have been discovered in the WebKitGTK
web engine:

CVE-2022-32792

    Manfred Paul discovered that processing maliciously crafted web
    content may lead to arbitrary code execution.

CVE-2022-32816

    Dohyun Lee discovered that visiting a website that frames
    malicious content may lead to UI spoofing.

For Debian 10 buster, these problems have been fixed in version
2.36.6-1~deb10u1.

We recommend that you upgrade your webkit2gtk packages.

For the detailed security status of webkit2gtk please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/webkit2gtk

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Debian LTS: DLA-3073-1: webkit2gtk security update

August 17, 2022

Summary

CVE-2022-32792

Manfred Paul discovered that processing maliciously crafted web
content may lead to arbitrary code execution.

CVE-2022-32816

Dohyun Lee discovered that visiting a website that frames
malicious content may lead to UI spoofing.

For Debian 10 buster, these problems have been fixed in version
2.36.6-1~deb10u1.

We recommend that you upgrade your webkit2gtk packages.

For the detailed security status of webkit2gtk please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/webkit2gtk

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Severity
Package : webkit2gtk
Version : 2.36.6-1~deb10u1
CVE ID : CVE-2022-32792 CVE-2022-32816

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.