Debian LTS: DLA-3075-1: schroot security update | LinuxSecurity.com

- -------------------------------------------------------------------------
Debian LTS Advisory DLA-3075-1                [email protected]
https://www.debian.org/lts/security/                 Salvatore Bonaccorso
August 18, 2022                               https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package        : schroot
Version        : 1.6.10-6+deb10u1
CVE ID         : CVE-2022-2787

Julian Gilbey discovered that schroot, a tool allowing users to execute
commands in a chroot environment, had too permissive rules on chroot or
session names, allowing a denial of service on the schroot service for
all users that may start a schroot session.

Note that existing chroots and sessions are checked during upgrade, and
an upgrade is aborted if any future invalid name is detected.

Problematic session and chroots can be checked before upgrading with the
following command:

  schroot --list --all | LC_ALL=C grep -vE '^[a-z]+:[a-zA-Z0-9][a-zA-Z0-9_.-]*$'

See

  

for instructions on how to resolve such a situation.

For Debian 10 buster, this problem has been fixed in version
1.6.10-6+deb10u1.

We recommend that you upgrade your schroot packages.

For the detailed security status of schroot please refer to its security
tracker page at:
https://security-tracker.debian.org/tracker/schroot

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Debian LTS: DLA-3075-1: schroot security update

August 18, 2022
Julian Gilbey discovered that schroot, a tool allowing users to execute commands in a chroot environment, had too permissive rules on chroot or session names, allowing a denial of ...

Summary

Note that existing chroots and sessions are checked during upgrade, and
an upgrade is aborted if any future invalid name is detected.

Problematic session and chroots can be checked before upgrading with the
following command:

schroot --list --all | LC_ALL=C grep -vE '^[a-z]+:[a-zA-Z0-9][a-zA-Z0-9_.-]*$'

See



for instructions on how to resolve such a situation.

For Debian 10 buster, this problem has been fixed in version
1.6.10-6+deb10u1.

We recommend that you upgrade your schroot packages.

For the detailed security status of schroot please refer to its security
tracker page at:
https://security-tracker.debian.org/tracker/schroot

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Severity
Package : schroot
Version : 1.6.10-6+deb10u1
CVE ID : CVE-2022-2787

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.