Debian LTS: DLA-3119-1: expat security update | LinuxSecurity.com

- -------------------------------------------------------------------------
Debian LTS Advisory DLA-3119-1                [email protected]
https://www.debian.org/lts/security/                    Thorsten Alteholz
September 25, 2022                            https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package        : expat
Version        : 2.2.6-2+deb10u5
CVE ID         : CVE-2022-40674


Rhodri James discovered a heap use-after-free vulnerability in the 
doContent function in Expat, an XML parsing C library, which could result 
in denial of service or potentially the execution of arbitrary code, if a 
malformed XML file is processed.


For Debian 10 buster, this problem has been fixed in version 
2.2.6-2+deb10u5.

We recommend that you upgrade your expat packages.

For the detailed security status of expat please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/expat

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Debian LTS: DLA-3119-1: expat security update

September 25, 2022

Summary

Rhodri James discovered a heap use-after-free vulnerability in the
doContent function in Expat, an XML parsing C library, which could result
in denial of service or potentially the execution of arbitrary code, if a
malformed XML file is processed.


For Debian 10 buster, this problem has been fixed in version
2.2.6-2+deb10u5.

We recommend that you upgrade your expat packages.

For the detailed security status of expat please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/expat

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS


Severity
Package : expat
Version : 2.2.6-2+deb10u5
CVE ID : CVE-2022-40674

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.