Debian LTS: DLA-3140-1: libpgjava security update | LinuxSecurity.com

- -------------------------------------------------------------------------
Debian LTS Advisory DLA-3140-1                [email protected]
https://www.debian.org/lts/security/                           Chris Lamb
October 07, 2022                              https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package        : libpgjava
Version        : 42.2.5-2+deb10u2
CVE ID         : CVE-2022-31197
Debian Bug     : #1016662

It was discovered that there was a potential SQL injection
vulnerability in libpgjava, a Java library for connecting to
PostgreSQL databases.

A malicious user could have crafted a schema that caused an
application to execute commands as a privileged user due to
the lack of escaping of column names in some operations.

For Debian 10 buster, this problem has been fixed in version
42.2.5-2+deb10u2.

We recommend that you upgrade your libpgjava packages.

For the detailed security status of libpgjava please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/libpgjava

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Debian LTS: DLA-3140-1: libpgjava security update

October 7, 2022
It was discovered that there was a potential SQL injection vulnerability in libpgjava, a Java library for connecting to PostgreSQL databases

Summary

A malicious user could have crafted a schema that caused an
application to execute commands as a privileged user due to
the lack of escaping of column names in some operations.

For Debian 10 buster, this problem has been fixed in version
42.2.5-2+deb10u2.

We recommend that you upgrade your libpgjava packages.

For the detailed security status of libpgjava please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/libpgjava

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS


Severity
Package : libpgjava
Version : 42.2.5-2+deb10u2
CVE ID : CVE-2022-31197
Debian Bug : #1016662

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.