Debian LTS: DLA-3167-1: ncurses security update | LinuxSecurity.com

- -------------------------------------------------------------------------
Debian LTS Advisory DLA-3167-1                [email protected]
https://www.debian.org/lts/security/                    Thorsten Alteholz
October 29, 2022                              https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package        : ncurses
Version        : 6.1+20181013-2+deb10u3
CVE ID         : CVE-2022-29458


An issue has been found in ncurses, a collection of shared libraries for 
terminal handling.
This issue is about an out-of-bounds read in convert_strings in the 
terminfo library.


For Debian 10 buster, this problem has been fixed in version
6.1+20181013-2+deb10u3.

We recommend that you upgrade your ncurses packages.

For the detailed security status of ncurses please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/ncurses

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LT

Debian LTS: DLA-3167-1: ncurses security update

October 29, 2022
An issue has been found in ncurses, a collection of shared libraries for terminal handling

Summary

An issue has been found in ncurses, a collection of shared libraries for
terminal handling.
This issue is about an out-of-bounds read in convert_strings in the
terminfo library.


For Debian 10 buster, this problem has been fixed in version
6.1+20181013-2+deb10u3.

We recommend that you upgrade your ncurses packages.

For the detailed security status of ncurses please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/ncurses

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LT

Severity
Package : ncurses
Version : 6.1+20181013-2+deb10u3
CVE ID : CVE-2022-29458

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.