Debian LTS: DLA-3184-1: libjettison-java security update | LinuxSec...
-------------------------------------------------------------------------
Debian LTS Advisory DLA-3184-1                [email protected]
https://www.debian.org/lts/security/                      Markus Koschany
November 10, 2022                             https://wiki.debian.org/LTS
-------------------------------------------------------------------------

Package        : libjettison-java
Version        : 1.4.0-1+deb10u1
CVE ID         : CVE-2022-40149
Debian Bug     : 1022554

It was discovered that libjettison-java, a collection of StAX parsers and
writers for JSON, was vulnerable to a denial-of-service attack, if the
attacker provided untrusted XML or JSON data.

For Debian 10 buster, this problem has been fixed in version
1.4.0-1+deb10u1.

We recommend that you upgrade your libjettison-java packages.

For the detailed security status of libjettison-java please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/libjettison-java

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Debian LTS: DLA-3184-1: libjettison-java security update

November 10, 2022
It was discovered that libjettison-java, a collection of StAX parsers and writers for JSON, was vulnerable to a denial-of-service attack, if the attacker provided untrusted XML or ...

Summary


It was discovered that libjettison-java, a collection of StAX parsers and
writers for JSON, was vulnerable to a denial-of-service attack, if the
attacker provided untrusted XML or JSON data.

For Debian 10 buster, this problem has been fixed in version
1.4.0-1+deb10u1.

We recommend that you upgrade your libjettison-java packages.

For the detailed security status of libjettison-java please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/libjettison-java

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Severity
Package : libjettison-java
Version : 1.4.0-1+deb10u1
CVE ID : CVE-2022-40149
Debian Bug : 1022554

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.