Debian LTS: DLA-3224-1: http-parser security update | LinuxSecurity...

- -----------------------------------------------------------------------
Debian LTS Advisory DLA-3224-1              [email protected]
https://www.debian.org/lts/security/                      Utkarsh Gupta
December 05, 2022                           https://wiki.debian.org/LTS
- -----------------------------------------------------------------------

Package        : http-parser
Version        : 2.8.1-1+deb10u3
CVE ID         : CVE-2020-8287
Debian Bug     : 1016690

There was a potential HTTP request smuggling vulnerability in
http-parser, a popular library for parsing HTTP messages.

For Debian 10 buster, this problem has been fixed in version
2.8.1-1+deb10u3.

We recommend that you upgrade your http-parser packages.

For the detailed security status of http-parser please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/http-parser

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Debian LTS: DLA-3224-1: http-parser security update

December 5, 2022
There was a potential HTTP request smuggling vulnerability in http-parser, a popular library for parsing HTTP messages

Summary

For Debian 10 buster, this problem has been fixed in version
2.8.1-1+deb10u3.

We recommend that you upgrade your http-parser packages.

For the detailed security status of http-parser please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/http-parser

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Severity
Package : http-parser
Version : 2.8.1-1+deb10u3
CVE ID : CVE-2020-8287
Debian Bug : 1016690

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.